-         

Ergebnis 1 bis 9 von 9

Thema: L7805CV zu heiß???

  1. #1
    Erfahrener Benutzer Roboter Experte
    Registriert seit
    13.05.2005
    Alter
    26
    Beiträge
    601

    L7805CV zu heiß???

    Anzeige

    Hi,

    ich teste grade mein Webserver Board und habe Probleme mit dem
    Spannungsregler L7805CV. Laut verschiedener Beschreibungen kann
    der 7805 (wovon ich ausgehe das er einer ist) bis 1A und ohne Kühlung
    bis 0,5A. Das Board zieht mit Netzwerkkarte (8019AS Chip) 220mA.
    Ohne etwas um den 100mA Bereich. An dem 5V Regulator ist noch ein
    3,3V Regulator für die SD Karte. Der Beschaltung: Eingang 12V~
    + Gleichrichter + 100nf + 100µ + L7805CV + 100µ Ausgang 5V +
    3,3V Regulator + 100µ. Das Board ist mit einem Atmega16 bestückt.

    Nun das Problem:

    Selbst ohne Netzwerkkarte wird dieses **** Regulator Ding langsam
    aber sicher heiß. Mit Netzwerkarte (zog vorher 100mA mehr aber nun ist
    der 5V --> 9V Aufwärtsregler draußen) wird das ding so heiß das man an
    meinem Finger eine Rechteck mit einem Kreis in der Mitte erkennen kann.

    Meine Frage: Warum normalerweise wird das doch nie so heiß?
    Grüße Furtion

  2. #2
    Erfahrener Benutzer Roboter Experte
    Registriert seit
    26.05.2005
    Ort
    Kaiserslautern
    Beiträge
    794
    Hi,

    das Ganze hängt davon ab, mit welcher Eingangsspannung du den 7805er betreibst.

    Die Verlustleistung P berechnet sich über
    P = (Eingangspannung - Ausgangspannung) * Strom

    über die Verlustleistung kannst du dann auch die Temperatur bestimmen.

    Gruß, CowZ

  3. #3
    Erfahrener Benutzer Roboter-Spezialist
    Registriert seit
    03.07.2007
    Beiträge
    349
    Du hast etwa 1W Verlustleistung. Besorg dir z.B. einen Step Down Wandler, dort wird die überflüssige Spannung nicht an einem Widerstand verbraten.
    Grüße,
    Harri

  4. #4
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    17.04.2006
    Beiträge
    2.193
    Bei mir sind das theoretisch bis zu 3W, mit etwas Abzug für den viel zu kleinen Siebelko. So oder so ist das zu viel ohne Kühlkörper.

  5. #5
    Erfahrener Benutzer Roboter-Spezialist
    Registriert seit
    03.07.2007
    Beiträge
    349
    Zitat Zitat von shaun
    Bei mir sind das theoretisch bis zu 3W, mit etwas Abzug für den viel zu kleinen Siebelko. So oder so ist das zu viel ohne Kühlkörper.
    Ich hab mich auf die "typischen" 110mA bei 7V bezogen.
    Grüße,
    Harri

  6. #6
    Erfahrener Benutzer Roboter Experte
    Registriert seit
    13.05.2005
    Alter
    26
    Beiträge
    601
    Hi,

    also brauche ich umbedingt ein Kühlkörper und einen größeren Elko.
    Was soll ich dort für Werte vor und nach dem Spannungsregler nehmen?
    Grüße Furtion

  7. #7
    Erfahrener Benutzer Robotik Visionär
    Registriert seit
    26.11.2005
    Ort
    bei Uelzen (Niedersachsen)
    Beiträge
    7.942
    Wegen der reichlich hohen Spannung vor dem Regler reicht der Elko noch aus. Viel mehr wird nicht nötig sein, vielleicht das doppelte, wenn man noch einen Serienwiderstand zwischen Trafo und Elko nimmt.
    Die Alternative zum Kühlkörper wäre ein Schaltwandler (z.B. LM2575). Eventuell würde auch ein Trafo mit weniger Spannung, ein großer Elko und ein low drop Regler reichen, das wird aber knapp.

  8. #8
    Erfahrener Benutzer Roboter Experte
    Registriert seit
    13.05.2005
    Alter
    26
    Beiträge
    601
    Hi,

    also soll ich vor den Schaltregler und nach dem Gleichrichter ein Widerstand
    auf der Vcc Leitung legen und 220µ als Elko nehmen und die Spannung
    des Netzteils runterdrehen?

    Welchen Wert würdest du für den Widerstand vorschlagen?
    Grüße Furtion

  9. #9
    Erfahrener Benutzer Robotik Visionär
    Registriert seit
    26.11.2005
    Ort
    bei Uelzen (Niedersachsen)
    Beiträge
    7.942
    Der Widerstand wäre eine Möglichkeit das zu viel an Spannung nicht am regler, sondern dafür an einem extra Widerstand in Wärme umzuwandeln. Wenn man den Weg mit dem Widerstand geht muß der Elko größer werden 220 -1000 µF sollten dann ungefähr richtig sein. Der Widerstand muss so bemessen sein, das bei maximalem Strom die Spannung gerade noch ausreicht. Die 12 V vom Trafo würden rund 15 V an einem Elko direkt dahinter geben. Man hat also gut 5 V zu viel die besser am Widerstand abfallen sollten. Bei maximal 300 mA wären das dann rund 16 Ohm und 1,5 W. Da der Strom vom Gleichreichter nicht gleichmäßig fließt sollte der Widerstand eher kleiner (z.B. 10 Ohm) sein, es ist halt schwierig den Widerstand so direkt zu berechenen. Wenn man das genauer haben will würde ich eine Simulation, z.B. mit LTspice empfehlen.
    Ganz ohne Kühlkörper wird man trotzdem kaum auskommen.
    Einfacher als ein Widerstand wäre es wenn der Trafo nur etwa 9 V geben würde.

    Wenn man einen Schaltregler nimmt, braucht man den Widerstand nicht. Dann sollten auch die 100 µF schon ausreichen, zumindestens wenn das ein hochwertiger Elko ist. Sonst eventuell noch mal 100 µF dazu. Das Problem ist weniger die Kapatzität, sondern die Strombelastbarkeit des Elkos.

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •