-
        

Ergebnis 1 bis 6 von 6

Thema: I2C LCD Display (C-Control I) am Mega32 ??? läuft nicht.

  1. #1
    Benutzer Stammmitglied
    Registriert seit
    07.01.2008
    Beiträge
    39

    I2C LCD Display (C-Control I) am Mega32 ??? läuft nicht.

    Anzeige

    Hallo,

    habe mir den I2C LCD Adapter von Conrad gekauft und ihn an meinen RN Controler Mega32 per I2C angeschlossen.
    Einen adapter von RN I2C (10pol) auf den LCD (6 Pol) habe ich gelötet.
    Alles ist verdrahtet, also +5V, Gnd, SDA, SCL.

    Aber irgenwie will der Bursche nicht. Habe die lcd_i2c.lib installiert und es damit probiert - klappt auch nicht.

    Hat das schon mal jemand probiert??

    Gruß - Klaus



    Anm: Kontroler ist PCF8574T, Adresse H40, Display leuchtet,
    es wandert ein Cursor (laut Programm), abe kein einziger Buchstabe oder was sinnvolles taucht auf.


    Muß man irgendwo den I2C Bus vonn 100 auf 400 KHz umschalten oder geht das von alleine?

    [/shadow]

  2. #2
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    22.05.2005
    Ort
    12°29´ O, 48°38´ N
    Alter
    48
    Beiträge
    2.731
    Hallo,

    ich kenne das LCD jetzt nicht , aber hast Du mal geschaut, ob die Belegung vom PCF8574 so ist wie es die Bascom-Lib erwartet ?
    Ist der Kontrast richtig eingestellt, dreh mal etwas rum.

    Man muss den Bus nicht "umschalten" wenn ein Slave die schnellere Geschwindigkeit nicht mitmacht, merkt man das ja gleich.
    Im Wiki hab ich mal was vorbereitet:
    http://www.roboternetz.de/wissen/ind...com_I2C_Master
    kannst Dir eine passende Version aussuchen.

  3. #3
    Benutzer Stammmitglied
    Registriert seit
    07.01.2008
    Beiträge
    39
    Danke.

    Habe glaube ich schon mal einen Ansatz von Fehler gefunden. Laut der LCD-Lib sind 2 Pinne zwischen PCF8574T und LCD Display auf der Conrad Platine anders beschaltet (vertauscht). werde diese mal versuchen vorsichtig umzulöten. Hoffe es klappt dann.

    Melde mich dann nochmal.

    Gruß - Klaus

  4. #4
    Benutzer Stammmitglied
    Registriert seit
    07.01.2008
    Beiträge
    39
    Alles umgelötet und es funktioniert erst mal.

    Also:
    Getrennt -also aufgepitscht -zwischen Display Platine und Controlerplatine:
    Die Pinne: pin 3, pin 4

    An Displayplatine:
    - pin 4 (RS) auf Pin 5 auf Controlerplatine (PCF8547)
    - Pin 5 (R/W) auf Masse (pin1) gelötet - fest Read

    Schon geht es.

    gruß - Klaus.

  5. #5
    Benutzer Stammmitglied
    Registriert seit
    07.01.2008
    Beiträge
    39
    Nachtrag:
    die Variable _lcd_e = 192 ist auf 192 zu setzen.

  6. #6
    Neuer Benutzer Öfters hier
    Registriert seit
    01.08.2012
    Beiträge
    11
    Zitat Zitat von dirtyklaus Beitrag anzeigen
    Hallo,

    habe mir den I2C LCD Adapter von Conrad gekauft und ihn an meinen RN Controler Mega32 per I2C angeschlossen.
    Einen adapter von RN I2C (10pol) auf den LCD (6 Pol) habe ich gelötet.
    Alles ist verdrahtet, also +5V, Gnd, SDA, SCL.

    Aber irgenwie will der Bursche nicht. Habe die lcd_i2c.lib installiert und es damit probiert - klappt auch nicht.

    Hat das schon mal jemand probiert??

    Gruß - Klaus



    Anm: Kontroler ist PCF8574T, Adresse H40, Display leuchtet,
    es wandert ein Cursor (laut Programm), abe kein einziger Buchstabe oder was sinnvolles taucht auf.


    Muß man irgendwo den I2C Bus vonn 100 auf 400 KHz umschalten oder geht das von alleine?

    [/shadow]
    Hatte mit dem Display auch exakt die gleichen Startprobleme. Falls mal jemand Code für AVR braucht: http://www.mikrocontroller.net/attac...ghlight/185358

    Kein Löten erforderlich! Funktioniert bei mir.

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •