-
        

Ergebnis 1 bis 4 von 4

Thema: STK-500 Probleme Flash schreiben

  1. #1
    Benutzer Stammmitglied
    Registriert seit
    13.04.2008
    Beiträge
    34

    STK-500 Probleme Flash schreiben

    Anzeige

    Hallo an Alle!

    Ich habe mir vor kurzem das STK-500 gekauft und mit Bascom
    erfolgreich die ersten Gehversuche gemacht.

    Heute wollte ich wieder was machen, habe aber das Problem,
    dass ich nicht mehr in den Flash schreiben kann.
    Das Firmwareupdate habe ich auch schon erfolgreich übertragen,
    aber kein Erfolg.
    Den µC Mega8 habe ich auch schon getauscht, aber keine Änderung.








    Hat vielleicht jemand eine Ahnung, was die Ursache sein könnte?
    Vielleicht habe ich unwissentlich irgend einen Parameter umgestellt???

    Danke für jeden Hinweis.

  2. #2
    Erfahrener Benutzer Roboter Experte
    Registriert seit
    20.05.2006
    Ort
    Lippe
    Alter
    48
    Beiträge
    524
    Hallo,
    kenne das stk500 nicht. Aber im dritten Bild unter Oscillator and ISP Clock die Werte sind nicht ok. Die Oscillatorfrequenz sollte deutlich höher liegen z.B. 4Mhz. Die ISP dann 1/4 der Osc. Da würde ich ansetzen.

    Gruß

    Jens

  3. #3
    Benutzer Stammmitglied
    Registriert seit
    13.04.2008
    Beiträge
    34
    Hallo Jens,

    danke für Deine Antwort.

    Das Verhalten ist sehr kurios.
    Gestern habe ich noch AVR-Studio 4.14 installiert
    aber das gleiche Verhalten - kein Zugriff auf den Flash.

    Gerade eben habe ich es nochmals versucht mit dem STK500
    den µC - Mega8 zu löschen und schreiben -
    und es funktioniert als sei es nie andern gewesen.

    Das Verhalten ist nicht gerade vertrauenserweckend.

    Danke

    Rudolf

  4. #4
    Erfahrener Benutzer Begeisterter Techniker
    Registriert seit
    29.01.2005
    Alter
    45
    Beiträge
    294
    Nun, wie es Jens schon vermutet hat (und das richtig) scheinen die Takt Einstellungen nicht zu stimmen.

    Hast Du einen Quarz auf dem STK500?

    Du solltest wirklich sinnvolle Werte einstellen. Also z.B. 3,68 MHz und dann maximal 1/4 ISP.

    Das STK500 funktioniert eigentlich sehr stabil.

    Ab und zu scheinen sich die Frequenz Einstellungen zu verändern. Ist bei mir auch schon passiert.

    Stell beim Bascom den Link zu Deinem STK500.exe ein, dann kannst Du mit F2 das Proggi übertragen ohne das Du z.B. den Controllerchip im Studio einstellen mußt. Du mußt im Studio nur die Frequenzen sinnvoll eingestellt haben.
    Das Gegenteil von "gut" ist "gut gemeint"!

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •