-
        

Ergebnis 1 bis 4 von 4

Thema: ISP Programmierkabel für parrallel Port selbst bauen

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    25.05.2005
    Beiträge
    16

    ISP Programmierkabel für parrallel Port selbst bauen

    Anzeige

    Hallo,

    ich versuche zur Zeit ein ISP Programmierkabel selbst zu bauen. Dazu habe ich mich an der Anleitung hier im Wiki orientiert: http://www.roboternetz.de/wissen/ind...ogrammierkabel

    Dabei taucht schon die erste Frage auf: Wo muss der LED Pin angelötet werden, der in der Schaltzeichnung auftraucht (das ganze soll mit dem RN-Control Board verbunden werden, da finde ich in der Steckerbelegung für ISP nichts mit LED)? Bis jetzt haben ich den einfach nicht angelötet, allerdings funktioniert das Kabel nicht... Außerdem hab ich im Internet noch andere Versionen von diesem Kabel gefunden, hat jemand schon mal ein solches Kabel gebaut und weiß ob es mit dem RN-Control Board lauffähig ist??

    Hat jemand vielleicht sonst noch ne Idee woran das liegen könnte?

    Das Problem ist das wir das Kabel relativ kurzfristig brauchen, bisher haben wir unser Board immer über RS232 und den MCS Bootloader programmiert, allerdings haben wir ausversehen den ATMEGA32 Chip auf dem Board zerschossen, daher haben wir bei Reichelt einen neuen Chip bestellt (auf dem der Bootloader natürlich nicht drauf ist). Daher brauchen wir ein Kabel um den Bootloader neu zu übertragen.

    Ihr seht schon dass, das alles nicht soo ganz einfach ist. Daher bin ich für jeden Lösungsvorschlag dankbar.

    Ich bin mir auch nicht ganz sicher, ob das hier das richtige Forum ist

  2. #2
    Erfahrener Benutzer Robotik Visionär Avatar von Hubert.G
    Registriert seit
    14.10.2006
    Ort
    Pasching OÖ
    Beiträge
    6.183
    Die Led brauchst du nicht unbedingt, hat mit der Funktion nichts zu tun. Sie kommt über einen 470 Ohm Widerstand auf +. Ich habe sie im Stecker belassen.
    So ein Programmieradapter ist Standard wenn man nicht gerade ein STK500 oder einen USB-Programmer hat.
    Ich weiss nicht welches Programm ihr zum programmieren verwendet. Hier gibt es auch ein Anleitung www.lancos.com mit PonyProg.
    Ein gern gemachter Fehler ist das verdrehen der Leitungen. Ihr habt auf eurem Programmierstecker eine Buchse, die Belegung ist auf die Lötseite gesehen.
    Grüsse Hubert
    ____________

    Meine Projekte findet ihr auf schorsch.at

  3. #3
    Neuer Benutzer Öfters hier
    Registriert seit
    25.05.2005
    Beiträge
    16
    Hmm, danke

    Ich habe jetzt erstmal testweise die extrem vereinfachte Version des Kabels zusammengelötet (Druckerkabel + 2 Widerstände), da ja erstmal nur der Bootloader übertragen werden muss. Nach einigem hin und her hat das dann auch funktioniert. Wenn ich die Tage mal wieder Zeit habe, werde ich mich nochmal mit der "richtigen" Lösung beschäftigen.

    Eine Frage habe ich aber noch, wie meinst du das mit den "Belegungen von der Lötseite her"?

  4. #4
    Erfahrener Benutzer Robotik Visionär Avatar von Hubert.G
    Registriert seit
    14.10.2006
    Ort
    Pasching OÖ
    Beiträge
    6.183
    Die Belegung der 10pol Buchse in dem Link ist auf die Lötseite der Buchse gesehen. das habe ich gemeint. Das wird oft verwechselt.
    Grüsse Hubert
    ____________

    Meine Projekte findet ihr auf schorsch.at

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •