-         

Ergebnis 1 bis 5 von 5

Thema: Seltsames Verhalten von UREF an RN-Control

  1. #1
    Benutzer Stammmitglied
    Registriert seit
    06.03.2006
    Beiträge
    56

    Seltsames Verhalten von UREF an RN-Control

    Anzeige

    SMARTPHONES & TABLETS-bis zu 77% RABATT-Kostenlose Lieferung-Aktuell | Cool | Unentbehrlich
    Hallo zusammen.
    Ich habe vor einigen Tagen schonmal eine Frage bezüglich der Referenzspannung für den ADC gestellt.
    Ich wollte nun VCC/2 als Referenz nutzen. Dafür muss man ja eigentlich den Jumper UREF auf dem Board öffnen.
    Nun tritt aber ein seltsames Phänomen zutage. Wenn ich das Board resette (ADC noch nicht initialisiert) liegt an UREF bzw. an AREF eine Spannung von VCC/2 an. Also so wie es es haben will. Initialisiere ich jetzt jedoch den ADC mit ADMUX |= (1<<REFS0); so liegt sofort VCC an AREF an. Egal wie der Jumper gesetzt ist. Es ist also IMMER so, als ob der Jumper geschlossen ist. Jemand ne Idee was da schief läuft?

  2. #2
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    06.02.2005
    Ort
    Hamburg
    Alter
    31
    Beiträge
    4.255

    Re: Seltsames Verhalten von UREF an RN-Control

    Zitat Zitat von MasterFX
    Initialisiere ich jetzt jedoch den ADC mit ADMUX |= (1<<REFS0); so liegt sofort VCC an AREF an.
    Soll auch so sein. Die Einstellung ergibt:
    AVCC with external capacitor at AREF pin
    Also: AVCC wird als Referenz genutzt und mit dem AREF-Pin verbunden, um dort einen Kondensator zur Stabilisierung anschließen zu können.

    Was meinst du mit VCC/2? Die interne Referenz mit 2,56V?

  3. #3
    Benutzer Stammmitglied
    Registriert seit
    06.03.2006
    Beiträge
    56
    Nein, das RN-Control hat nen Spannungsteiler (R11 und R12). Über einen Jumper kann der Widerstand R11 überbrückt werden. Der Mittelabgriff von R11 und R12 geht an AREF. So lässt sich an AREF wahlweise VCC oder VCC/2 anlegen. Das hat nichts mit der internen Referenz von 2,56V zu tun, welche ich aufgrund der Beschaltung eh nicht nutzen kann.

    EDIT:
    Tja da bin ich natürlich selbst Schuld. Ich muss natürlich REFS0 und REFS1 auf "0" lassen, damit überhaupt die Spannung von AREF verwendet wird. Oh man *gegenkopfhau*

  4. #4
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    06.02.2005
    Ort
    Hamburg
    Alter
    31
    Beiträge
    4.255
    Die richtige Einstellung für dich ist
    AREF, Internal Vref turned off
    Also REFS0 und REFS1 beide auf Null.

  5. #5
    Benutzer Stammmitglied
    Registriert seit
    06.03.2006
    Beiträge
    56
    Jup habs gerade noch editiert. Tja manchmal ist man halt etwas blind. Danke für deine Hilfe

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •