-         

Ergebnis 1 bis 2 von 2

Thema: LCD-Display mit RN-Control v1.4 nach P Fleury

  1. #1

    LCD-Display mit RN-Control v1.4 nach P Fleury

    Anzeige

    Moinsen,

    ich bin nen anfänger was die Mikrocontrollerprogrammierung angeht, und möchte aber nun nen Display ansteuern.
    Dazu habe ich das RN-Control v1.4 und das RN-DisplayAdapter mit einem KS0073 Display.


    Ich habe also nun das Display in das RN-DisplayAdapterboard gesteckt und mit dem RN-C v1.4(ATmega32) verbunden.

    Grundlegend die 1.Frage: Bin ich mit PortC am richtigen Port oder eignet der sich nicht dazu?

    Dann habe ich mir die Dateien von P Fleury besorgt und mal nachgeschaut was man so ändern muss. Meine Einstellungen sehen wie folgt aus:


    1.in der "lcd.h"

    #define LCD_PORT PORTC /**< port for the LCD lines */
    #define LCD_DATA0_PORT LCD_PORT /**< port for 4bit data bit 0 */
    #define LCD_DATA1_PORT LCD_PORT /**< port for 4bit data bit 1 */
    #define LCD_DATA2_PORT LCD_PORT /**< port for 4bit data bit 2 */
    #define LCD_DATA3_PORT LCD_PORT /**< port for 4bit data bit 3 */
    #define LCD_DATA0_PIN 3 /**< pin for 4bit data bit 0 */
    #define LCD_DATA1_PIN 2 /**< pin for 4bit data bit 1 */
    #define LCD_DATA2_PIN 1 /**< pin for 4bit data bit 2 */
    #define LCD_DATA3_PIN 0 /**< pin for 4bit data bit 3 */
    #define LCD_RS_PORT LCD_PORT /**< port for RS line */
    #define LCD_RS_PIN 7 /**< pin for RS line */
    #define LCD_RW_PORT LCD_PORT /**< port for RW line */
    #define LCD_RW_PIN 6 /**< pin for RW line */
    #define LCD_E_PORT LCD_PORT /**< port for Enable line */
    #define LCD_E_PIN 5 /**< pin for Enable line */


    2.in der "lcd.c"

    #define KS0073_EXTENDED_FUNCTION_REGISTER_ON 0x24
    /* |0|010|0100 4-bit mode extension-bit RE = 1 */

    #define KS0073_EXTENDED_FUNCTION_REGISTER_OFF 0x20
    /* |0|010|0000 4-bit mode, extension-bit RE = 0 */

    #define KS0073_4LINES_MODE 0x09
    /* |0|000|1001 4 lines mode */


    Alles was ich bisher erreicht habe... ein beleuchteter Bildschirm und
    nur dunkle Zeilen...



    würde mich freuen, wenn jemand auf anhieb nen tip parat hätte.

    mfg Frank

  2. #2
    Erfahrener Benutzer Robotik Visionär Avatar von Hubert.G
    Registriert seit
    14.10.2006
    Ort
    Pasching OÖ
    Beiträge
    6.186
    Wenn du auch die Taktfrequenz richtig angegeben hast du die Pin des LCD so angeschlossen hast wie beschrieben, z.B. Data0 auf PIn 3, sollte es schon funktionieren.
    Ich verwende selbst auch diese Lib. Wenn es einmal nicht funktionierte war es immer mein Fehler.
    Grüsse Hubert
    ____________

    Meine Projekte findet ihr auf schorsch.at

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •