-         

Ergebnis 1 bis 3 von 3

Thema: Mototreiber defekt - Ursachensuche - Kompatibilitätsfrage

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    27.02.2008
    Beiträge
    11

    Mototreiber defekt - Ursachensuche - Kompatibilitätsfrage

    Anzeige

    Hallo ich habe am Samstag endlich mein erstes RN-Control Bord bekommen.
    Das Programmieren des Bords macht sogar richtig Spaß.
    Nur leider habe ich gestern dann direkt den Motortreiber zerstört.
    Vermutlich war einer der angeschlossenen Motoren blockiert und so hat sich der Treiber überhitzt.
    Ich nutze ein Netzteil welches maximal einen Output von 12V und 500 mA liefert, also kann es doch nicht an einer Überlastung durch zu starke Motoren liegen oder?
    Da der Treiber pro Kanal 600 mA verträgt und wenn das Netzteil nur 500 mA liefern kann, dann kann ich den Treiber doch so nicht zerstören und warum hat der Überhitzungsschutz den Treiber nicht gerettet?
    Auf robotikhardware.de wird auch der Motortreiber L298 mit max. 2A angeboten (Leider ist auf der Seite kein Belegungsplan veröffentlicht).
    Könnte man nicht theoretisch einfach diesen in den Sockel des L293D auf dem RN-Control Board stecken?

    Vielen Dank schon mal für eure Hilfe!

  2. #2
    Erfahrener Benutzer Begeisterter Techniker
    Registriert seit
    30.07.2007
    Alter
    33
    Beiträge
    214
    Also erstmal: Für Beschaltungspläne dieser Motrtreiber kannst du z.B. in der "Roboternetz-Wiki" nachschauen: http://www.roboternetz.de/wissen/ind...iber_IC_L293_D oder gib in Google einfach "l293D" oder "l298" ein. Dann kommt gleich beim ersten Ergebnis eine Datenblatt-Datenbank wo alles genauestens drinsteht.

    Der L298 hat allerdings eine ganz andere Bauform, andere Anschlüsse und passt nicht in den DIL-Sockel vom L293D.
    Man könnte ihn aber - zusammen mit 4 Freilaufdioden - auf eine separate Platine (Lochraster o.ä.) löten und dann an das RN-Control anschließen.
    Schema: http://www.roboternetz.de/wissen/ind...haltkreis_L298

    Dann zu deinem "Problem":
    Also erstmal zieht das RN-Control alleine schon im "Leerlauf" ca. 50 mA.
    Und dann interessiert es den Motor herzlich wenig, ob dein Netzteil nur für 500 mA ausgelegt ist. Das wird ja sicher ein Stecknetzteil sein. Die haben i.d.R. keinerlei Strombegrenzung. Der angegebene Wert sagt nur was das Gerät im Dauerbetrieb liefern kann.

    Die Motoren werden mit einer gewissen Spannung betrieben (bei dir wohl 12V) und setzen dabei - abhängig von Spannung und Belastung - Leistung um. Wenn die Quelle das nicht liefern kann, dann überhitzt die sich eben und geht kaputt. Das kann den Motortreiber treffen, oder sogar das Netzteil, wenn es noch schwächer ist als der Treiber selbst.
    Weißt du wieviel Nennstrom deine Motoren im Leerlauf (ohne Belastung) ziehen?
    Und dann ist es noch so, das ein Motor sich im schlimmsten Fall - wenn er komplett blockiert wird und auch im Anlauf-Moment - ein Vielfaches des Leerlaufstroms genehmigen kann.

    Warum der Thermo-Schutz den L293D nicht gerettet hat, kann ich auch nicht sagen. Bist du denn sicher, das tatsächlich der Motortreiber kaputt ist und nicht vielleicht das Netzteil selbst?

    MfG, Cairol

  3. #3
    Benutzer Stammmitglied
    Registriert seit
    31.03.2004
    Beiträge
    57
    Hallo,
    das mit dem Netzteil seh ich auch so: 12V 500mA wird die zulässige Dauerbelastung sein. Wenn dein Motor blockiert, wird er sehr niederohmig. Dadurch steigt der Strom und die Energie wird an den ohmschen Widerständen im Stromkreis nach der Formel P = I^2 * R als Wärme umgesetzt. Diese Wärmeenergie erwärmt den Motor und dessen Ansteuerelektronik - das Ergebnis hast du erlebt.
    Ich würde mir ein etwas teureres Netzteil mit Strombegrenzung zulegen, falls du häufiger solche Versuche fährst.

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •