-         
+ Antworten
Ergebnis 1 bis 3 von 3

Thema: Problem mit I2C-Slave-Beispiel von Bascom

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    22.08.2004
    Beiträge
    11

    Problem mit I2C-Slave-Beispiel von Bascom

    Hi,
    hab ein Problem beim Compilieren des Bascom Original I2C-Slave-Beispiels:

    $crystal = 3684000
    $regfile = "2313def.dat"
    Config I2cslave = &B01000000
    Config Portb = Input
    Portb = 255
    Dim Bfake As Byte
    Do
    Loop
    I2c_master_needs_data:
    Config Portb = Input
    _a1 = Pinb
    Return
    I2c_master_has_data:
    Bfake = _a1
    Config Portb = Output
    Portb = _a1
    Return

    Es kommt die Fehlermeldung, dass er die "I2CSLAVE.LBX" nicht findet, und sie ist auch nicht im LIB-Verzeichnis.

  2. #2
    Administrator Robotik Einstein Avatar von Frank
    Registriert seit
    30.10.2003
    Beiträge
    4.943
    Blog-Einträge
    1
    Hallo sam,
    diese LIB wird auch normalerweise nicht mitgeliefert. Die LIB mußt du kostenpflichtig nachkaufen. Kostet derzeit 5 Euro wenn ich mich nicht irre

  3. #3
    Neuer Benutzer Öfters hier
    Registriert seit
    22.08.2004
    Beiträge
    11
    Ach so.
    In deren Kommentaren steht:

    The Slave library will only work for chips that have T0 and INT0 connected to the same PORT.
    'These chips are : 2313,2323, 2333,2343,4433,tiny22, tiny12,tiny15, M8
    'The other chips have build in hardware I2C(slave) support.

    Wird sie nun mit dem M16 funktionieren oder nicht?

+ Antworten

Berechtigungen

  • Neue Themen erstellen: Ja
  • Themen beantworten: Ja
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •