-         

Ergebnis 1 bis 2 von 2

Thema: RFM01/02 im non-FIFO-Modus

  1. #1
    Erfahrener Benutzer Roboter Experte
    Registriert seit
    15.01.2007
    Ort
    Göttingen
    Beiträge
    705

    RFM01/02 im non-FIFO-Modus

    Anzeige

    Liebe Community,

    die RFM01/02-Bausteine halten mich ganz schön auf Trab
    Nachdem ich nur eine Serie vn 3 Bytes übertragen möchte (und das ca. 3mal pro Sekunde), wollte ich die Module ohne die FIFO-Funktion nutzen, sondern die Daten von der UART der beiden beteiligten Controller (Mega8 übertragen lassen.

    Um erstmal zu checken, ob sich überhaupt Daten übertragen lassen, habe ich eine kleine Routine gestrickt, die den Sender im 1Hz-Takt ein- und ausschaltet (mittels ea-Bit des Power Management Commands). Die Sendung erfolgt 0,5 Sekunden unmoduliert und 0,5 Sekunden mit einem 500Hz-Testsignal, das ich auf den FSK-Pin gelegt habe. Mit einem Messempfänger höre ich ein saberes, frequenzmoduliertes Signal - senderseitig scheint also alle in Ordnung zu sein.

    Woran ich aber definitiv scheitere ist, diese 500Hz aus dem Empfänger wieder herauszubekommen.

    Der VDI-Pin geht zuverlässig auf High wenn der Sender zu senden beginnt, d.h. der Empfänger "sieht" das Sendersignal schon mal.

    Der DATA/nFFS-Pin führt aber immer nur einen high-Pegel, solange der Sender sendet. Keine Spur des 500Hz-Testsignals. Ich habe im "Output and FIFI mode Command" das letzte bit (FIFO enable) auf 0 gesetzt, und alle Kombinationen der Bits S1 und S0 (FIFO fill start condition) durchprobiert (obwohl das bei deaktiviertem FIFO ja eigentlich onhe Bedeutung sein sollte).Im "Data filter Command" habe ich die Bits S1 und S0 (data filter type) auf 00 gesetzt (=OOK).

    Zur Vollständigkeit sind hier mal alle Kommandos, die ich an den Empfänger schicke:

    Configuration setting command: &B10001001 00001100
    Frequency setting commmand: &B10100110 01000000 (434 MHz)
    Receiver setting command: &B11000000 00001001
    AFC command: &B11000110 11000000
    Data filter command: &B11000100 00100100
    Output and FIFO mode command: &B11001110 10000000

    (Der Rest bleibt auf den POR-Einstellungen)


    Weiß jemand vielleicht auf Anhieb, was ich falsch mache?

    Gruß & Co.,

    Daniel

  2. #2
    Erfahrener Benutzer Robotik Einstein Avatar von wkrug
    Registriert seit
    17.08.2006
    Ort
    Dietfurt
    Beiträge
    1.892
    Ich bin jetzt echt zu faul die ganzen Konfigurationen aus den Binärwerten rauszusuchen.
    Ich hab mir die Daten per SPI geholt und den DATA/NFFS Pin per Pull Up ( 10k ) auf +5V gelegt. Das funzt - ich benutze den FiFo.

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •