-         

Ergebnis 1 bis 4 von 4

Thema: Kameramotor-Phasenanschnittssteuerung

  1. #1
    zwanzischmark
    Gast

    Kameramotor-Phasenanschnittssteuerung

    Anzeige

    Hallo,

    ich habe bei ebay eine Kamera Schwenk-, Kippsteuerung gekauft. Die Steurungseinheit Basierte auf einem 24V Trafo und 4 Knöpfen für hoch, runter, links, rechts (jeweils ein Kabel für jede Richtung + Rückleitung gehen zur Kamera).

    Der Trafo war völlig unterdimensioniert und das mit den Knöpfen fand ich auch doof, deshalb habe ich eine neue Steuerung gebaut. Dazu habe ich einen Trafo besorgt und die 2x15V Sekundär zu 30V (mehr geschwindigkeit!?!) zusammengeschaltet. Die Steurung der 4 Kanäle übernimmt ein Atmega8 der die Stellung (Spannung) von einem 360° Joystick misst und je nach Auslenkung die Phase anschneidet.
    Funktioniert soweit im Leerlauf gut. Als ich dann die Last angeschlossen hab, viel mir auf das es erstens nur funktioniert wenn das Oszi dranhängt und sich zweitens die Geschwindigkeit nicht ändert.
    sehe ich es richtig das ich den Trafo mittels Widerstand noch an GND hängen muss?

    hier erstmal ein paar Bilder Link

    ich weiss nicht wie es in der Schwenkeinrichtung aussieht und ob es Wechselstrom Motoren sind, oder ob vorher gleichgerichtet wird.
    Die Schaltung hab ich einfach mal so aufgebaut ohne viel Ahnung zu haben, vielleicht sind die Widerstandswerte völlig falsch...

    vielleicht schaut mal einer drüber

  2. #2
    Erfahrener Benutzer Robotik Visionär Avatar von Hubert.G
    Registriert seit
    14.10.2006
    Ort
    Pasching OÖ
    Beiträge
    6.186
    Wenn du das so machst ist die ganze Potentialtrennung ziemlich sinnlos oder zumindest nicht sauber, bei den 24V aber nur für die Elektronik gefährlich. Wenn du sauber trennen willst opfere noch einen Optokoppler.
    Grüsse Hubert
    ____________

    Meine Projekte findet ihr auf schorsch.at

  3. #3
    Erfahrener Benutzer Robotik Visionär
    Registriert seit
    26.11.2005
    Ort
    bei Uelzen (Niedersachsen)
    Beiträge
    7.942
    Wie schon vermutet muß noch eine Verbindung vom Trafo noch GND. Ohne Last könnten da irgendweche parasitäre Kapatzitäten gereicht haben, da kann man sich aber nicht drauf verlassen.
    Evetuell sollte man noch einen Teifpassfilter in das Signal vom Trafo zum Int1 Pin legen, damit nicht auf irgendwelche störungen getriggert wird.

    Die Widerstandswerte sehen OK aus, eventuell sind die 600 K zum INT1 etwas groß. Den Controller könnte man eigentlich auch über den gleichen Trafo versorgen.

    Wenn das echte Wechselspannungsmotoren sind, lassen die sich leider nur vernünftig regeln wenn man die Frequenz ändert, nicht per Phasenanschnitt.

  4. #4
    zwanzischmark
    Gast
    okay bei Hochohmigen Widerständen sieht es in meinem Kasten etwas mager aus. Muss ich erstmal mein Sortiment erweitern...
    Dann checke ich nochmal den Widerstand zu Int1 und füge den zu GND hinzu.
    Da das mit dem Regeln annähernt gar nicht klappt scheint es wohl der Fall zu sein das es Wechselstpannungsmotoren sind. Da hätte ich mich wohl vorher mal informieren sollen. Wusste nicht das man die so gar nicht Regeln kann.

    Dann kann ich mir die Phasenanschnittssteuerung wohl sparen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •