-         

+ Antworten
Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 16

Thema: Fahrt mit ACS immer rechtsrum!

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    25.09.2004
    Beiträge
    6

    Fahrt mit ACS immer rechtsrum!

    Anzeige

    GearBest Black Friday Verbraucherelektronik Promotion
    Meine RP5 weicht Hindernissen immer aus indem er nach rechts abdreht obwohl es logischer ist linksrum zu fahren . Ist das normal??? Und kann ich das abstellen indem ich nicht die beiliegen Beispiele nehme sondern selbst etwas schreibe; dazu müsste ich ja die beiden Sensoren einzeln ansprechen können. Also wenn der rechte ein Hinderniss wahrnimmt dann links herum fahren und uimgekehrt.

  2. #2
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    09.06.2004
    Ort
    Aachen
    Beiträge
    2.674
    Genau so musst du das machen, schau dir doch mal die mitgelieferten Quelltexte an, dass ist nix anderes. Dafür musst du dich natürlich in die Sprache einarbeiten, aber das ist nicht so schwer, schau dir mal nen par Beipiele an, oder nen par Codes aus dem Forum. Da der RP5 ja eine C-control 1 verwendet, oder?, kannst du auch im C-control 1 Forum nachschauen.
    Ob das mit dem Linksrumfahren normal ist, kann ich dir nicht sagen, ich hab kein RP5.

    MFg Moritz

  3. #3
    Neuer Benutzer Öfters hier
    Registriert seit
    14.09.2004
    Ort
    Aue
    Alter
    30
    Beiträge
    6
    Ein ähnliches Problem hatte ich anfangs mit meinem auch. Nachdem ich das Programm Antrieb von der CD draufgespielt hatte. Nach einigem Betrachten viel mir auf das es sehr schnell dazu kam das beide Sensoren ansprachen obwohl die Distanz zu einem kürzer war. Ein Trick um das abzustellen ist, die ACS-Sensoren leicht (etwa 5 Grad) aus der mittleren Stellung nach außen zu biegen. Damit kommen die sich icht mehr so leicht in die Quere beim Auswerten.

  4. #4
    Benutzer Stammmitglied
    Registriert seit
    16.10.2004
    Alter
    26
    Beiträge
    67
    Eine kleine abschirmung ist auch gut! Zm Beispiel von kleinen Spielzeug autos. Ich hab leider noch keien habe aber schon öfter gelesen das es hilft! Leicht nach außen biegen ist gut, ich empfehle auch drinegnst einen "stoßdämpfer" anzubauen sonst knicken die Sensoren schnell um/ab

    mfg

  5. #5
    Neuer Benutzer Öfters hier
    Registriert seit
    14.09.2004
    Ort
    Aue
    Alter
    30
    Beiträge
    6
    ja, ein Stoßdämpfer ist ein wahres Muss. Ich hab mir einn aus Styrodur gebaut und ihn an den Seiten von der Sensoplatte noch hoch gehn lassen. Das ist gerade gut, wenn man Rollstühle oder Schränke hat, die unten einen Freiraum haben wo die "sensoren durchsehen" und der Robby dann dagegen fährt. Ich hab aber auch schon Versionen aus Messing rohr gesehn. Die sehen wahrscheinlich besser aus.

  6. #6
    Benutzer Stammmitglied
    Registriert seit
    16.10.2004
    Alter
    26
    Beiträge
    67
    Meiner ist aus Lego! Und dafür habe ich noch aufsätze gebaut ich kann zum beispiel ne offene Hand dran bauen dann fährt der durchs zimmer und sammelt alles ein! Ist sehr praktisch!

  7. #7
    Neuer Benutzer Öfters hier
    Registriert seit
    04.12.2004
    Ort
    Wasbek
    Alter
    28
    Beiträge
    5
    Moin mein Robby is da und ich natürlich auch schon wie wild rumprobiert so ich hab genau das gleiche problem wie der ersteller dieses Themas mein Robby fährt auch nur rechtsherum also dachte ich naja das Beispiel Programm Einführung_ACS.bas damit kann ich ja an den Dioden gucken welcher ACS anspricht aber egal wie ich das anstelle immer nur die Linke Diode leuchtet auf also vermute ich nu kaputt bin mir aber net so sicher das Programm womit der immer rechtsherum fährt lautet so:
    #loop
    pause 2:sys comnav_status

    if (acsl_f and acsr_f)=on then goto rotate
    if acsl_f=on then goto ausweichl
    if acsr_f=on then goto ausweichr
    sys fwdr:sys fwdl:speed_l=255:speed_r=255:goto loop


    #rotate
    speed_r=0:speed_l=255:goto loop

    #ausweichl
    speed_l=255:speed_r=0:goto loop

    #ausweichr
    speed_l=0:speed_r=255:goto loop

    (ja ich weiß ähnelt seeeeeeehr dem Einführung_Antrieb is ja auch daher nur selber geschrieben
    Mit dem nachvorne biegen bin ich mir ja niocht so sicher wegen dem abbrechen keine lust das der völlig im arsch ist
    So hoffe auf sinnvolle Anworten und kein benutz die Suchfunktion weil das hab ich gemacht
    MFG meister eder
    edit:
    hab grade herausgefunden das wenn ich weit weg bin (so 10 cm) dann spricht nur der linke acs an wenn ich so 3-4cm na dran bin dann beide wenn ich nur auf die linke gehe spricht nur die linke an wenn ich nur auf die rechte geh dann spricht auch die linke an also die linke geht immer und die rechte nimmer ne aber nu wenn man gaaanz nah ran geht wie kann ich das den nu ändern

  8. #8
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    12.07.2004
    Ort
    Fulda
    Alter
    29
    Beiträge
    183
    Zum Problem mit dem "immer rechtsrum fahren":
    Wenn der Robby z.B. auf ne wand zufährt und beide Sensoren ansprechen soll er ja nach rechts fahren (is im programm so definiert); dann weiß der doch garnet, ob es logischer ist nach rechts oder links zu fahren (woher auch).
    Er kann nur die richtungen entscheiden, wenn die Sensoren einzeln ansprechen.
    Ich kann auch nur das programm hier empfehlen (das ist vom "henk"); ich versteh das zwar nich wirklich, aber ich hab mich au noch net wirklich mit beschäftigt....
    Angehängte Dateien Angehängte Dateien
    MfG Jonas

  9. #9
    Neuer Benutzer Öfters hier
    Registriert seit
    04.12.2004
    Ort
    Wasbek
    Alter
    28
    Beiträge
    5
    Das hat nichts gebracht mein rechter ACS reagiert nur ganz selten mal wenn ich zum Beispiel meine Hand über dem Robby hab dann spricht der mal an ansonsten nur der linke. Ich hab auch schon mit biegen und so rumprobiert aber nichts das will net funzen
    Wer Rechtschreibfehler findet kann sie behalten!!!!!

  10. #10
    Erfahrener Benutzer Robotik Einstein Avatar von Dirk
    Registriert seit
    30.04.2004
    Ort
    NRW
    Beiträge
    3.789

    ACS-Test!

    Hallo Leute,

    wenn das ACS nicht gut funzt (3_EINFÜHRUNG_ACS_INT.bas), kann man 2 Dinge nachsehen:

    1. Beide IR-LEDs GERADE nach vorn ausgerichtet oder max. 5° nach außen gebogen?

    2. IR-Empfänger (TSOP 1836, sitzt vorn mittig auf der Hauptplatine neben einem 100uF-Elko) GERADE ausgerichtet und nicht durch irgendwelche eigenen Anbauten in der freien Sicht nach vorn behindert?

    Gruß Dirk

+ Antworten
Seite 1 von 2 12 LetzteLetzte

Berechtigungen

  • Neue Themen erstellen: Ja
  • Themen beantworten: Ja
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •