-         

Ergebnis 1 bis 6 von 6

Thema: Motorenansteuerung mit Application Board 2.0 und L293D

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    25.05.2005
    Beiträge
    16

    Motorenansteuerung mit Application Board 2.0 und L293D

    Anzeige

    SMARTPHONES & TABLETS-bis zu 77% RABATT-Kostenlose Lieferung-Aktuell | Cool | Unentbehrlich
    Hallo,

    wir versuchen zur Zeit das C-Control App-Board von Conrad dazu zu bringen, unsere Motoren zu steuern. Um das hinzukriegen haben wir von Reichelt den Motortreiber (heißt das wirklich so?) L293D gekauft. Damit man auch die Geschwindigkeit später im Programm regeln kann, haben wir ENABLE 1 und ENABLE 2 vom L293D jeweils mit DA1 und DA2 vom App-Board verbunden.
    Den Rest haben wir wie in http://www.skilltronics.de/versuch/e...k_pc/l293.html dargestellt verkabelt.

    Jetzt haben wir allerdings das Problem, das die ganze Schaltung nur funktioniert, wenn wir dem DA-Port im Programm später einen Wert von unter 100 zuweisen. Wenn wir darüber gehen, passiert nichts und das App-Board hängt sich auf (man muss das Programm mit dem Start Knopf neu starten).

    Woran kann das liegen?

  2. #2
    Neuer Benutzer Öfters hier
    Registriert seit
    25.05.2005
    Beiträge
    16
    Ich habe in der Zwischenzeit ein bisschen gegoogelt und habe einige Schaltpläne mit einem 100nF Kondensator zwischen Vs <-> GND und Vss <-> GND gefunden. Ich habe an diesen Stellen keinen Kondensator eingebaut. Was bewirkt der? Könnte es helfen, wenn ich an diesen Stellen welche einbaue?

  3. #3
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    19.12.2007
    Ort
    München
    Alter
    36
    Beiträge
    108
    Hi ich bin selbst nicht so fit mit dem Elektronikkram... Aber der Kondensator am Eingang des µCs glättet die Spannung die durch andere ICs oder Motoren Spitzen und Einbrüche bekommt.

    Ein Motor zieht zu dem Zeitpunkt an dem er sich zu drehen beginnen soll kurzzeitig hohen Strom. Dadurch bekommt kurzzeitig der µC nicht genug Saft und bleibt stehen, oder resetet...

    (korrigiert mich wenn ich Schmarrn schreibe, aber so hab ich das verstanden)

    Gibts auch nen guten Artikel hier unter RN-Wissen. Schau mal unter "Abblockkondensatoren"

  4. #4
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    16.09.2004
    Ort
    Schwabenland
    Beiträge
    156
    Ja, das ist ein Abblockkondensator. Das ist ein MUSS für nahezu jedes IC. Oftmals funktionieren ICs auch ohne, wenn es aber manchmal tut und manchmal nicht oder nur mit manchen ICs (sogar aus der gleichen Baureihe), kann man die Ursache oftmals genau dort, am fehlenden Abblockkondensator von 100nF suchen.

  5. #5
    Neuer Benutzer Öfters hier
    Registriert seit
    25.05.2005
    Beiträge
    16
    Hmm, wo müssen diese Abblockkondensatoren den überall zwischen geschaltet werden?

    Wir haben 2 Kondensatoren mit 470 nF (glaube ich, bin mit nicht ganz sicher) jetzt einfach mal zwischen GND und Vc (Spannungsquelle für die Motoren) und Vcc (Logic Supply, +5V) und GND gehängt. Wir konnten das Problem dadurch aber noch nicht lösen.

    Müssen es genau 100nF Kondensatoren sein?

  6. #6
    Moin Moin,

    Ich hatte ein ähnliches Problem mit meinem ersten Robby. In die Luft gehalten lief er wunderbar. Sobald man ihn absetzte, hat er nur noch Blödsinn gemacht. Der Grund war die Spannungsquelle. Ich hatte einen 9V Block benutzt (erstmas zu probieren) nach 3 Minuten störungsfreiem Betrieb fingen die seltsamen Verhaltensweisen an. Da war die Batterie schon zu schwach. Dann haben die Motoren Spannungseinbrüche verursacht, die der Spannungsregler mit Kondensatoren nicht mehr auffangen konnte. Die Spannungseinbrüche kamen natürlich nur unter Last vor. Ich habe 3 Tage gesucht, bis ich den Fehler hatte. Als ich den Akku eines Akkuschraubers eingesetz hatte, war alles in Ordnung.

    Fazit: Schau mal die Spannungsversorgung an. Wenn hier der Spitzenstrom nicht reicht, können der Spannungsregler und seine Kondensatoren auch nicht viel machen.

    Gruß Brar

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •