-         

Ergebnis 1 bis 7 von 7

Thema: I2C zuckt nicht mal

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    11.09.2007
    Beiträge
    6

    I2C zuckt nicht mal

    Anzeige

    Der I2C Bus meines Atmel Mega128Funk reagiert auf gar nichts.
    Er sendet keinen Takt er sendet keine Daten er macht NICHTS.

    könnte mir jemand ein Beispielprogramm zum testen geben das Garantiert funktioniert?
    [/flipv]

  2. #2
    Erfahrener Benutzer Roboter-Spezialist
    Registriert seit
    29.11.2006
    Ort
    Geislingen a. d. Steige
    Alter
    26
    Beiträge
    344
    hi sunnyboy,
    in welcher sprache und was soll er senden bzw empfangen?

    MfG Martin

  3. #3
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    07.12.2007
    Beiträge
    180
    Sind die Leitungen SDA und SCL durch Pull-Up Widerstände auf 5V gezogen?
    Gruß

  4. #4
    Neuer Benutzer Öfters hier
    Registriert seit
    11.09.2007
    Beiträge
    6
    Hi, danke für die schnelle antwort!!!

    also, im prinzip wollen wir nur das rn-digi ansprechen!! (also nur senden, nichts empfangen)!!

    nur reagiert der I2C bus im moment überhaupt nicht!! lediglich die 5V am pin 5 und pin 7 sind daa

    Mfg

  5. #5
    Benutzer Stammmitglied
    Registriert seit
    28.07.2006
    Ort
    Schweiz
    Beiträge
    78
    Zitat Zitat von MartinFunk
    in welcher sprache
    Diese Frage musst du noch beantworten wenn du eine sinnvolle Antwort willst

    Gruss Wischwasch

  6. #6
    Neuer Benutzer Öfters hier
    Registriert seit
    11.09.2007
    Beiträge
    6
    ja stimmt, sry!!

    in BASIC (also mit BASCOM)!!

    mfg

  7. #7
    Neuer Benutzer Öfters hier
    Registriert seit
    11.09.2007
    Beiträge
    6
    @TheHawk

    Da könnte das Problem liegen, danke!! jedoch in der doku des mega128 steht, dass das brereits angschlossene I2C boards machen!! weißt du vl wie ich das bei rn-digi herausfinden könnte!?

    Mfg

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •