-         

Ergebnis 1 bis 3 von 3

Thema: ungewollter reset durch/bei zuschalten von pwm

  1. #1
    Benutzer Stammmitglied
    Registriert seit
    22.02.2005
    Beiträge
    78

    ungewollter reset durch/bei zuschalten von pwm

    Anzeige

    SMARTPHONES & TABLETS-bis zu 77% RABATT-Kostenlose Lieferung-Aktuell | Cool | Unentbehrlich
    Mit dieser Sache habe ich ein Problem.
    Ich benutze einen attiny13.

    Kurzfassung: wenn ich meine Schaltung anschalte läuft der AVR los, bis zu dem Punkt wo ich meine PWM anschalte(dem Register zum ersten mal einen Wert gebe) , dann startet der AVR von allein neu.
    Woran kann das liegen?

    Langfassung: Geschaltet wird meine Glühlampe (6V 400mA) über einen BUZ10 (reicht). Zu Stromversorgung benutze ich zwei Li-Ion-Zellen (-->ca 8V),
    der AVR wird über einen lm2940 aus diesen Zellen mitversorgt. Die Kondensatoren am lm2940 sind ein 4,7µF und ein 470µF Elko (waren so in der Bastelkiste).
    Symptome:
    Wenn ich anstelle der Glühlampe eine Led mit Vorwiderstand benutze geht alles wie es soll.
    Wenn ich den AVR aus einem Steckerschaltnetzteil mit 5V versorge geht das ganze auch mit der Glühbirne.
    Wenn ich einen Widerstand in Reihe zur Glühlampe schalte geht das ganze auch (über reine Akkuversorgung, die Lampe leuchtet dann natürlich nicht.
    Als die Schaltung frisch Zusammengebaut war lief sie wie geplant, auch der vorherige (ziemlich identische) Testaufbau lief. Das Problem mit dem Neustart hatte ich vorher aber schonmal, als ich noch einen 7805 als Spannungsregler benutzt habe. Als ich diesen durch den lm2940 ersetzt habe lief die Schaltung wie gesagt einige Male ganz normal.

  2. #2
    Erfahrener Benutzer Robotik Visionär
    Registriert seit
    26.11.2005
    Ort
    bei Uelzen (Niedersachsen)
    Beiträge
    7.942
    Die Low Drop Regler sind ziehmlich wählerisch mit den Kondensatoren. das Datenbaltt vom LM2940 das ich habe, verlangt mindestens 22 uF am Ausgang. 470uF könnten schon etwas viel sein und 4,7 uF könnten auch etwas wenig vor dem Regler sein. Zumindest sollte vor dem Regler noch ein typischer Entkoppelkondensator (ca. 100 nF Keramik oder notfalls Folie) liegen. Wenn der BUZ10 direkt ohne Gatewiderstand schaltet wird, muß der Port schon ganz schön viel Strom liefern und dadurch kurzzeitige Spannungseinbrüche Verursachen. Ein kleinerer FET (logic Level) mit ca. 2 A Maximalstrom sollte sich besser schalten lassen.

    Außerdem besteht ohne Gatewidestand je nach Layout die Möglichkeit, das der MOSFET zwischendurch hochfrequent (1-100MHz) schwingt.

    Wenn genug Störungen auf der versorgung sind, kann der Reset via Browout der direkt per einkopplung auf die Resetleitung ausgelöst werden. Gegen die Einkopplung hilft der kleine KOndensator gegen GND.

  3. #3
    Benutzer Stammmitglied
    Registriert seit
    22.02.2005
    Beiträge
    78
    Der helle Wahnsinn. Danke für deine Hinweise. Ich habe den Ausgangskondensator gegen 22µF getauscht, eingangsseitig einen 22nF (ein anderer war nicht da) dazugelötet und einen 300Ohm Widerstand zwischen Port und Gate geschaltet. Kurz: es arbeitet. Ich werde es beobachten.

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •