-         

Ergebnis 1 bis 3 von 3

Thema: UART0 mit ATMEGA128 Problem

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    01.01.2008
    Ort
    Heidenrod
    Beiträge
    11

    UART0 mit ATMEGA128 Problem

    Anzeige

    Hallo, hab da ein Problem mit dem gleichzeitigen Benutzen der beiden Seriellen Schnitstellen meines ATMEGA128.
    Ziel ist es u.A. empfangene Daten auf UART0 weiter zu reichen an UART1 zur Ausgabe. Es funktioniert nicht!!. Es ist mir möglich Daten auf UART1 zu empfangen und auch als ECHO zurück zu geben auf 1. Ausgabe auf UART0 ist nicht möglich. Initialisierung von UART0 und -1 ist identisch (natürlich mit angepasstem Index des Ports). Empfangen auf Port0 geht auch incl. Weiterleitung zu Port1, der umgedrehte Weg geht aber nicht. Im Debugger ist niemals eine Veränderung von Register UDR0 zu sehen (bei Datenausgabe auf 0).
    Habe meinen Code schon auf ein minimum reduziert, aber es geht nicht. Hate jemand eine Idee?? Gibt es irgendwelche Besonderheiten bei UDR0 die im Gegensatz zu UDR1 zu beachten sind?? Habe die Kompatibilitäts Fuse für den Mega104 ausgeschaltet. Ist die Portadresse für UDR0 wirklich 0x0C oder 0x2c ?? Es kann doch nur was ganz simples sein, was ich vor lauter Bäumen nicht sehe.

    Für Tipps wäre ich echt dankbar.
    Frohes neues Jahr übrigens an alle

  2. #2
    Benutzer Stammmitglied
    Registriert seit
    03.10.2007
    Beiträge
    68
    Hallo,

    womit programmierst Du.

    Vielleicht kannst Du ja mal einen Codeschnipsel einstellen und dann kann man mal drüber sehen.

    Die angesprochene Funktionalität ist häufig genutzt beim Mega128, wir hatten noch nie irgendwelche Probleme.

    Schick einmal Deinen Code, bzw. sage mit was Du arbeitest, dann findet sich schon eine Lösung.

    Grüße

  3. #3
    Neuer Benutzer Öfters hier
    Registriert seit
    01.01.2008
    Ort
    Heidenrod
    Beiträge
    11
    Hallo Gummi_ente,

    vielen Dank für Dein Hilfeangebot. Hab den Fehler endlich gefunden. War ne miese Kombination aus Layoutfehler und schlechter Lötstelle, dadurch war alles verdreht und unlogisch. Jetzt reichts für heute.

    Gruß

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •