-         

Ergebnis 1 bis 3 von 3

Thema: Mega8 read-only, obwohl garkein write-protect gesetzt ist

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    23.12.2007
    Beiträge
    5

    Mega8 read-only, obwohl garkein write-protect gesetzt ist

    Anzeige

    Hallo Gleichgesinnte,

    ich bin in dieversen Foren unterwegs und verfolge hier einige Threads seit längerer Zeit. Nun habe ich eine konkrete Frage, die mir auch noch längerem Suchen in meinen Stammforen nicht beantwortet werden konnte.

    Hat jemand von euch ähnliche Probleme wie ich:
    Ich bastel derzeit viel mit Mega8, habe auch schon mit Mega16 und 32 gearbeitet. Da ich bereits vorher mit PICs gearbeitet habe, behaupte ich mal so einigermaßen Grundkenntnisse im Umgang mit µCs zu haben. Also mir ist durchaus bewusst das man 100n-Kerkos benutzen sollte und ähnliches.
    Jetzt habe ich schon mehrfach welche von den Mega8 zerheißt. Wobei ich nicht genau definieren kann wodurch. Fakt ist jedenfalls, dass ich die µC nicht mehr programmieren kann. Das Phänomen tritt bereits bei mehreren Controllern auf, die ich in verschiedenen Schaltungen per ISP programmiert habe. Der letzte ist mir heute hops gegangen - AVRprog in Version 1.40 erzählt mir dass das verify nicht erfolgreich war und ein anderer Zellinhalt erwartet wurde.... OK, da ein zweiter Programmierdurchgang nicht möglich ist (controller spricht nicht mehr) wurde die ganze Schaltung spannungslos gemacht und danach nochmal versucht zu Programmieren. Geht immer noch nicht, allerdings lässt sich die Seriennummer das Chips und die Fuse-Bits auslesen!! Und die stimmen auch soweit, steht noch auf XTAL medium (4MHZ Quarz dran), lässt sich aber weder ändern noch nen Chip-Erase wird durchgeführt. Nach aus- und wiedereinschalten der Spannungsversorgung läuft allerdings das alte Programm noch, also die Taktquelle bringt den kleinen durchaus in Schwung. Bisher habe ich mir immer mit neuen Controllern aus der Kiste beholfen, auf Dauer kann das aber auch keine Lösung sein.
    Kennt jemand von euch solch kurioses Verhalten von Mega's?


    Gruß
    Seppel


    PS:
    Programmiert wird mit AVR910-kompatiblen Seriellprogrammer von OB-Elektronik mit AVRprog.

  2. #2
    Erfahrener Benutzer Robotik Visionär Avatar von Hubert.G
    Registriert seit
    14.10.2006
    Ort
    Pasching OÖ
    Beiträge
    6.186
    Ein Write-Protect in dem Sinn gibt es nicht, nur ein Read-Protect das sich nur mit einem Erase wieder löschen lässt.
    Wenn dein Problem bereits mehrere Mega8 betrifft dann ist doch eher ein Hardwareproblem zu erwarten. Wenn das alte Programm noch im Kontroller ist dann hat ja schon der erste Programmierversuch fehlgeschlagen.
    Ein zweiter Programmer, eventuell mit PonyProg wäre da zum testen hilfreich.
    Grüsse Hubert
    ____________

    Meine Projekte findet ihr auf schorsch.at

  3. #3
    Neuer Benutzer Öfters hier
    Registriert seit
    23.12.2007
    Beiträge
    5
    Also lesen lässt sich der Controller. Mir werden die korrekten Fuse-Bits in AVRprog angezeigt und auch die Seriennummer des µC aber da was verändern oder gar ein Chiperase ist nicht drin. Danach ist der Controller garnicht mehr zu erreichen.
    Ich werde nachher mal versuchen meiner Programmer mit PonyProg zum Laufen zu bringen und schaue mal was die Software dazu sagt.

    Und was das mit dem alten Programm anbelangt: Ja bereits der erste Programmierversuch schlägt fehl. Danach kommt der Controller auch nur durch kappen der Spannungsversorgung wieder in Gang. Lese hingegen geht so oft ich möchte.


    Frohes Fest noch weiterhin
    Seppel

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •