-         

Ergebnis 1 bis 5 von 5

Thema: Problem mit sublw

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    20.11.2007
    Beiträge
    24

    Problem mit sublw

    Anzeige

    Hallo,
    warum ergibt bei mir:
    Code:
     movlw B'00001001'
     sublw  B'00000001'
    im WREG B'11111000'
    und nicht B'00001000'

    Hab ich irgendwo ein denkfehler?
    liebe Grüße Kante

  2. #2
    Super-Moderator Robotik Visionär Avatar von PicNick
    Registriert seit
    23.11.2004
    Ort
    Wien
    Beiträge
    6.836
    Er rechnet ja
    0001 - 1001 =>
    und nicht umgekehrt

    wird also negativ
    mfg robert
    Wer glaubt zu wissen, muß wissen, er glaubt.

  3. #3
    Neuer Benutzer Öfters hier
    Registriert seit
    20.11.2007
    Beiträge
    24
    ahh,
    vielen dank. also doch ein denkfehler
    liebe Grüße nach Wien aus Berlin
    Kante

  4. #4
    Super-Moderator Robotik Visionär Avatar von PicNick
    Registriert seit
    23.11.2004
    Ort
    Wien
    Beiträge
    6.836
    Auch Grüße
    Die PIC's haben ein paar so Fallen auf Lager
    Bei
    SUBLW literal
    glaubt jeder erstmal (zumindest ich ), er zieht das Literal von W ab
    mfg robert
    Wer glaubt zu wissen, muß wissen, er glaubt.

  5. #5
    Neuer Benutzer Öfters hier
    Registriert seit
    20.11.2007
    Beiträge
    24
    ja so hab ich auch gedacht. Na ja jetzt weis ichs besser
    vielen dank nochma

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •