-         

Ergebnis 1 bis 3 von 3

Thema: Problem mit L293D

  1. #1
    Benutzer Stammmitglied
    Registriert seit
    11.10.2007
    Beiträge
    77

    Problem mit L293D

    Anzeige

    Hi, @ll

    ich habe ein Problem mit einen L293D IC und zwar folgendes:

    Ich habe ein Programm geschrieben, der 2 Motoren mit 100% drehung nach links und 50% drehung nach rechts drehen läste.

    Aufgebaut ist es wie auf folgenden link:
    http://www.roboternetz.de/wissen/ind...en_Ansteuerung

    Der 1 Getriebemotor läuft einwandfrei links/rechts mit 100% / 50%
    Der 2 Getriebemotor läuft zwar auch links/rechts aber immer mit 100% egal welche Richtung!

    Das geschriebene Programm ist ok, habe sogar die Anschlusse von 2 Getriebemotor an 1 Getriebemotor angeschlossen. Bleibt bei 100% auf beide Richtung! Wenn der IC kaputt wäre, würde der nicht die Richtungen wechseln oder?

  2. #2
    Erfahrener Benutzer Begeisterter Techniker
    Registriert seit
    28.05.2007
    Ort
    Mannheim
    Alter
    30
    Beiträge
    270
    Ich habe ein Programm geschrieben, der 2 Motoren mit 100% drehung nach links und 50% drehung nach rechts drehen läste.
    ... Ich nehme daraus mal an das du also mit PWM arbeitest.

    Das geschriebene Programm ist ok
    Woher willst du da so sicher sein? am besten du postest es mal zur Sicherheit.

    habe sogar die Anschlusse von 2 Getriebemotor an 1 Getriebemotor angeschlossen. Bleibt bei 100% auf beide Richtung!
    Was genau meinst du damit? Das der Fehler mit dem Motor wandert oder das der Fehler an dem Pin des ICs bleibt?

    Gruß Robodriver
    Wer aufhört besser zu werden, hat aufgehört gut zu sein

    Jeder I/O Port kennt drei Zustände: Input, Output, Kaputt

  3. #3
    Benutzer Stammmitglied
    Registriert seit
    11.10.2007
    Beiträge
    77
    Hi,

    also das Programm funktionier sieh dafür Link:
    http://www.roboternetz.de/phpBB2/zei...779&highlight=

    Also ich steuere meinen L293D über Soft-PWM.
    Jetzt benutze ich z.B.

    3 Ausgänge PC0,PC1 und PC2
    PC0 und PC2 sind für die Richtung Links/Rechts beim IC an Pin 2,7
    und PC1 ist das Soft-PWM Signal für den 1 Getriebemotor beim IC an Pin 1.

    Wie gesagt das Funktioniert.
    Jetzt habe ich mal an
    PC0 und PC2 mit IC Pin 10,15
    und an PC1 mit IC Pin 9 verbunden.

    Damit habe ich jetzt nur die verbindung zum IC getausch.
    Aber wie schon gesagt, der 2 Motor läßt sich nur mit 100% drehen in beiden Richtung.

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •