-
        

Ergebnis 1 bis 10 von 10

Thema: Stromzufuhr L297/298, was beachten...???

  1. #1

    Stromzufuhr L297/298, was beachten...???

    Anzeige

    Hallo zusammen,

    mein kleines Projekt nähert sich dem Ende und da ich auf Nummer sicher gehen mag frag ich hier mal nach, wie ich die ganzen Anschlüsse meines Taktgenerators mit dem Motortreiber L297/298 verbinde.

    Die Schrittmotorsteuerung hat ja Steckkontakte, einmal für die Motorwicklungen und einmal für die Motorspannung. Motorwicklungen ist klar. Kann ich an die Motorspannung diesselbe Spannungsquelle (12V) nutzen, wie für den Taktgenerator?

    An die Stiftleiste des treibers soll ich laut Datenblatt an Pin
    1: Logikspannung 5V
    2: Masse / GND
    3: Enable (Motor wird durch GND ausgeschaltet/ Pullup vorhanden)
    4: Clockwise (Drehrichtung)
    5: Takteingang

    Zu Pin 1: Muss ich eine extra Spannungsquelle mit 5V schaffen die da dran hängt und mit GND dieser an Pin 2?

    Pin 3 ist mir momentan unklar. Wollte per Schalter Drehrichtung und Ein- Ausschalten ermöglichen.

    Pin 4: Wie Pin 3

    Pin 5: Klar, Eingang vom Taktgenerator.

    Danke für eure Hilfe.

    Gruss, Alex

  2. #2
    Also ich habe nun einen IC7805 in die Schaltung meines Takgebers mit eingebracht, funktioniert super.
    Sowohl die ausgehenden Takte als auch die Festspannung hat 5V max.
    Jetzt habe ich den Taktgeber und den Motortreiber miteinander verbunden:
    PIN1 mit 5V dauerplus
    PIN2 mit GND
    PIN3 nix
    PIN4 nix
    PIN5 Ausgang Taktgenerator

    Die Steuerung habe ich verbunden mit dem Motor, klar. Und noch am Schraubklemmeneingang mit 12V Dauerplus.

    Kann sich da schon was bewegen oder muss ich die Drehrichung noch vorgeben?

    Gruss, Alex

  3. #3
    Erfahrener Benutzer Robotik Visionär Avatar von Hubert.G
    Registriert seit
    14.10.2006
    Ort
    Pasching OÖ
    Beiträge
    6.186
    Pinbelegung
    Pin 1 Clock/Takt (bei GND Flanke bewegt sich Motor einen Schritt)
    Pin 2 CW/CCW (Drehrichtung, Pullup vorhanden)
    Pin 3 RESET (Pullup vorhanden)
    Pin 4 CNTL
    Pin 5 H/F (Halb- oder Vollschritt, Pullup vorhanden)
    Pin 6 Enable (Motor wird durch GND ausgeschaltet, Pullup vorhanden)
    Pin 7 SYNC
    Pin 8 HOME
    Pin 9 GND / Masse
    Pin10 Logikspannung +5V (dient zur Versorgung der Schaltung)
    Ich hoffe du meinst auch RN-step-297, dann wäre die Belegung so. Du brauchst Pin1, 2, 6, 9, 10

  4. #4
    Ja die Steuerung mein ich, aber ich meinte die Pins der Anschlussleiste namens JP1 im Schaltplan.


    Gruss, Alex

  5. #5
    Erfahrener Benutzer Robotik Visionär Avatar von Hubert.G
    Registriert seit
    14.10.2006
    Ort
    Pasching OÖ
    Beiträge
    6.186
    Wenn alles korrekt angeschlossen ist (Motor) dann sollte sich der Motor im Uhrzeigersinn (CW) drehen. Mit GND auf Kl.4 sollte sich die Drehrichtung umkehren.

  6. #6
    Hallo,

    er dreht sich leider nicht, habe auch schon die wicklungen umgepolt. Nichts....!

    Wenn ich an den Anschlussklemmen der Motorwicklungen die Spannung messe, merke ich von einer Wicklung zur anderen immer den unterschiedlich wechselnden Takt. 10V (aktuelle Batteriespannung) zu 0V, hat eine wicklung 10V hat die andere null, dann wechselt die Schaltung. Eingentlich sollte er doch drehen. Ich kann auch an der Messstelle U-Ref keine Spannung messen.

    Bin etwas ratlos, alles läuft vom Taktgeber her, die Schaltung taktet aber diese beiden Sachen geben mir Rätsel auf. Kann mir da jemand helfen???

    Vielen Dank.

    Gruss, Alex

  7. #7
    Erfahrener Benutzer Robotik Visionär Avatar von Hubert.G
    Registriert seit
    14.10.2006
    Ort
    Pasching OÖ
    Beiträge
    6.186
    Wenn sich da nichts tut und der Motor auch keine Geräusche von sich gibt, dann mess einmal den Widerstand der Motorwicklungen und kontrolliere ob sie auch richtig drauf sind.

  8. #8
    Also Geräusche macht der Motor nicht, die Wicklungen habe ich alle mal durchgemessen. 2 von 4 haben den Widerstand 10Ohm, und die anderen 2 haben 0,5Ohm

    Die 0,5Ohm habe ich isoliert, die anderen habe ich angeklemmt.

    Tja, nun steh ich wie der Ochs vorm Berg...

  9. #9
    Erfahrener Benutzer Robotik Visionär Avatar von Hubert.G
    Registriert seit
    14.10.2006
    Ort
    Pasching OÖ
    Beiträge
    6.186
    Wenn du eine Wicklung auf 1,2 und die andere auf 3,4 angeklemmt hast, dann weiss ich auch nicht weiter. Den Motor kenne ich nicht, haben die 0,5Ohm Wicklungen Verbindung zu den 10Ohm Wicklungen.
    Grüsse Hubert
    ____________

    Meine Projekte findet ihr auf schorsch.at

  10. #10
    Ich habe den kleinen Motor nun doch zum Leben erwecken können. Ich hatte zwar überall die richtige Spannung auf der Schaltung, doch nicht genügend Strom als das sich der Motor rührt. Mit einstellen des Spindeltrimmers auf der L297/298 fing er an zu zucken. Vielen Dank an all diejenigen, die mich unterstützt haben. Auch in den anderen Beiträgen die ich zu dem Thema eröffnet habe.
    Ohne euch hätte ich das Projekt nicht zu Ende führen können.

    Vielen Dank.

    Gruss, Alex

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •