-         

Ergebnis 1 bis 3 von 3

Thema: L297/298 Schaltg, wie testen und in Betrieb nehmen?

  1. #1

    L297/298 Schaltg, wie testen und in Betrieb nehmen?

    Anzeige

    Hallo zusammen,

    meine L297/298 Steuerung ist fertig gelötet.
    Nun habe ich wie im Datenblatt beschrieben mal die Sache an 12V angeschlossen und auch schon den Motor mal angeklemmt
    Bild:

    Im Bauplan steht, bei angelegter Spannung sollte man 50-100mA messen können. Nur wo? Beim Anschluss U-Ref??? Da sollte ich doch eher Spannung U messen, nicht die Stromstärke. Jedenfalls ist da 0V.
    Und der Motor zuckt auch nicht, auch wenn ich die Spulen umpole. Läuft der überhaupt so wie auf dem Bild oder muss der Taktgeber erst dran?
    Muss ich die Stromstärke den Klemmen für den Motor messen?
    Danke für Tips,

    Gruss Alex

  2. #2
    Erfahrener Benutzer Roboter Genie Avatar von Willa
    Registriert seit
    26.10.2006
    Ort
    Bremen
    Alter
    37
    Beiträge
    1.269
    Hi!
    In der Anleitung steht doch:
    Für die Ansteuerung benötigt man somit nur drei Leitungen:

    * einen Port zum Einschalten der Motoren
    * einen Port für die Drehrichtung
    * einen Port für den Schrittimpuls (ein kurzer Impuls bewegt den Motor genau um einen Schritt)

    d.h. du brauchst z.B. das RN-Control board um deinem Motortreiber überhaupt zu sagen was er machen soll....

    Viele Grüße,
    William
    Edit:
    Hi alex, ich hab grad gelesen dass du noch ziemlich am anfang stehst... Was du mit "taktgenerator" meinst weiss ich nicht so genau, bin auch noch anfänger... Aber willst du nicht vielleicht dein teleskop mal ganz automatisieren? also beide achsen und noch irgendwelche funktionen? weil dann würde sich echt ein mikrocontroller lohnen, damit kannst du dann schön alles am laptop einstellen und dein teleskop macht dann alles automatisch... und sowas zu basteln amcht auch spaß und ist gar nicht so schwer!
    viele grüße,
    william

  3. #3
    Hallo,

    vielen Dank schonmal. Ohne den Taktgenerator rührt sich also nix.
    Ich verwende diese Schaltung als Taktgeber mit NE555



    Wie ich diesen an den Motortreiber anschliesse ist mein nächstes Problem. Da muss ich wohl noch einen Schalter einlöten???
    Zum ein- und ausschalten und für die Drehrichtung. Und ich weiss auch noch nicht ob ich OUT1 und OUT benötige oder nur einen von beiden?

    Nee, das wird kein Antrieb für ein Teleskop (vielleicht wird das einmal wenn ich das momentane Projekt zum laufen bringe ). Es wird ein Antrieb für eine Kameramontierung, die Sternenfotografie ermöglicht (Barndoor).

    Gruss, Alex

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •