-         

Ergebnis 1 bis 3 von 3

Thema: Keine Kommunikation zwischen RN-Control und RN-Schrittmotor

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    21.09.2006
    Beiträge
    19

    Keine Kommunikation zwischen RN-Control und RN-Schrittmotor

    Anzeige

    Hi,

    nachdem mein Schrittmotorboard endlich läuft, funktioniert jetzt die Kommunikation zwischen RN-Control und RN-Schrittmotor über I2C nicht. Das Kabel hab ich durchgemessen; es gibt weder Kurzschlüsse noch falsch verbundene Pins (es ist ein 9-adriges, das müsste aber für die 7 benutzten Kanäle ausreichen, oder?)

    Ich habe schon ausprobiert, die Jumper auf dem RN-Control nacheinander herauszunehmen und das i2c-Kabel anders einzustecken, aber in keinem Fall konnte die RN-Control das RN-Schrittmotorboard steuern.
    Softwaremäßig verwende ich das Beispielprogramm zur Ansteuerung vom Schrttmotorboard in Bascom von der Robotikhardwareseite. Das Programm läuft auf dem RN-Control (zumindest piept das Bard bei Tastendruck), aber das Schrittmotorboard nimmt keine Notiz davon. Über de PC-Steuersoftware funktioniert die Steppersteuerung dagegen wunderbar.

    Irgendwas muss ich wohl furchtbar falsch machen, aber in der Beschreibung zum Schrittmotorboard habe ich auch nichts gefunden, was ich noch hätte machen sollen. Kann es sein, dass zufällig irgend eine i2c-Schnittstelle kaputt ist? Und würde dann zur Not die RS232-Verbindung zwischen den Boards funktionieren?

    Gruß Stefan

  2. #2
    Neuer Benutzer Öfters hier
    Registriert seit
    21.09.2006
    Beiträge
    19
    Update: Einsetzen der Jumper 1 und 2 auf JP1 des RN-Schrittmotor hat auch nichts gebracht und über RS232 statt I2C hört das RN-Schrittmotor-Board auch nicht

  3. #3
    Administrator Robotik Einstein Avatar von Frank
    Registriert seit
    30.10.2003
    Beiträge
    4.989
    Blog-Einträge
    1
    Irgend was musst du noch falsch aufgebaut haben. Oder irgendwas an deiner Ansteuerung stimmt nicht. Vielleicht sendest du Befehle viel zu schnell. Mach mal ein paar ms Pause hinter jedem Befehl (also Befehl nicht hinter jedem Byte).

    Wenn ein Chip nicht mehr per I2C reagiert, so kann es sein das du versehendlich die I2C Adresse verstellt hast. Das kann in seltenen Fällen auch versehendlich erfolgen wenn du schnell die Befehle geschickt hast. Indem fall musst du nur RS232 Kabel anschließen und mit dem Steuerprogramm die Grundstellung wieder aktivieren.

    Ansosnsten ist I2C eigentlich völlig problemlos mit RN-Schrittmotor verwendbar. ClockStretching sollte immer unterstützt werden, abe rdas machen ja alle modernen Compiler wie z.B. Bascom

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •