-         
+ Antworten
Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 17

Thema: RN-Control 1.4 mit Mega32 erste Schritte

  1. #1

    RN-Control 1.4 mit Mega32 erste Schritte

    Hallo,

    ich habe mir ein RN-Control 1.4 mega32 mit zugehörigem ISP Programmer gekauft.

    ich möchte unter c programmieren und scheitere schon an den ersten aufgaben. wobei sich auch die frage stellt ob mein aufbau (computer, isp-programmer, kabel, spannungsversorgung, software etc.)
    überhaupt richtig ist.
    ich habe zweifel ... da ich mir schon die finger am festspannungsregler verbrannt habe . zum programmieren des µc ist doch eine externe spannungsversorgung (7V, über die betriebsspannungsklemmen des RN-Control nötig, oder!?)
    oder ist es ein defekter isp-programmer bzw defekter rn-control?

    kann mir jemand ein tip geben um das board in einzelschritten in betrieb nehmen zu können.

    falls jemand gerade in der laune dazu ist würd ich mich über ein tutorial freuen! ich weiß es gibt diese schon zu genüge doch entweder sind sie unvollständig oder für mich zu unverständlich.

    klasse wäre ein tutorial von
    "aus dem karton auspacken"
    bis hin zu
    "eine taste drücken dann soll eine led angehen"

    freue mich über jeden tip

    gruß
    takemura

  2. #2
    Gast
    Hi,

    die Anleitung die auf der beiliegenden CD enthalten ist, beschreibt eigentlich den Einstieg recht gut. Zumindest der Einsteig mit Bascom dürfte damit Problemlos sein.

  3. #3
    Administrator Robotik Einstein Avatar von Frank
    Registriert seit
    30.10.2003
    Beiträge
    4.943
    Blog-Einträge
    1
    Der Einstie wird in der beiliegend Doku anhand Bascom beschrieben, weil es damit eine Stufe einfacher geht. Hat man das erst mal geschafft, dann kann man in der Regel auch bei Bedarf recht einfach auf C wechseln.

    Ich weiß nicht was du für ein Netzteil hast. Falls es ein 12V Steckernetzteil ist, dann ist es normal das der Spannungsregler recht heiß wird. Diese produzieren zum Teil bis zu 17V Leerlaufspannung, das sorgt für etwas Hitze. Ist aber gewöhnlich kein Problem, das verkraftet der Spannungsregler.
    Wichtig ist nur das du ISP-Programmierkabel auch an der ISP Buchse und nicht am I2C Bus anschließt. Denn im letzteren fall verursachst du Kurzschluss und dadurch wird Spannungsregler natürlich "RICHTIG HEISS"

    Unbedingt erst Doku gründlich lesen! Findest du im Verzeichnis RN-Control auf CD oder hier im Download Bereich.

    Bei der C-Programmierung helfen dir sicherlich ein paar C-Experten weiter.

    Gruß Frank

  4. #4

    kurzschluss?!

    hallo frank,

    erstmal vielen dank für deine schnelle antwort!

    ich habe das RN-Control mit meinem netzteil (8V Leerlaufspannung) mit den Betriebsspannungsklemmen verbunden. An den pins 10 und 11 vom mega32 kann ich 5V messen.

    - LED 7 und LED 8 leuchten.
    - wenn ich taster betätige pipsts es oder ein lauflicht (ohne led3 bis led6 ->
    vermutlich fuse bit) läuft.
    - bei betätigung des resets machts düdelüt und die leds 7 und 8 gehen für
    die dauer der betätigung kurz aus danach gleich wieder an.

    verbinde ich jetzt die rn-control-platine mit dem 10pol pfostenstecker des ISP (der ISP ist dabei noch NICHT mit dem pc verbunden!)
    so gehen die leds aus, der festspannungsregler wird heiß und die versorgungsspannung (pin 10 und 11 am mega32) bricht zusammen.

    das sieht doch sehr nach kurzschluss aus, oder?!

    ich hab zwar ein messgerät jedoch mit jämmerlichen prüfspitzen kann mir jemand sagen welche pins (sub-d weiblich im isp) auf keinen fall zueinander kontakt haben dürfen. vielleicht brauch ich nur einen lötspritzer
    wegkratzen .

    gruß Takemura

  5. #5
    Administrator Robotik Einstein Avatar von Frank
    Registriert seit
    30.10.2003
    Beiträge
    4.943
    Blog-Einträge
    1
    Wenn es düdelüt nach Reset macht, klingt das schon mal bestens
    Wenn du Fertigboard bestellt hast, muss es das auch machen, die sind nämlich alle schon mal getestet worden.

    Also bei 8V darf nix heiß werden, höchstens ein wenig warm, wenn überhaupt.
    Das was du beschreibst beim Anstecken des Dongels klingt eindeutig nach Kurzschluss, daher wird das Ding dann auch heiß.
    Ich frage sicherheitshalber nochmal nach: Hat du ganz genau darauf geachtet das du den ISP-Stecker nicht in die I2C Buchse gestekct hast. Die ISP und I2C Buchse sehen genau gleich aus, aber daneben ist eine eindeutige Beschriftung auf der Platine. Es ist schon öfters mal vorgekommen das dies jemand vertauscht hat. Dies würde nämlich zu einem Kurzschluss führen.

    Also bitte nochmal 100% überprüfen und Info geben.

    Gruß Frank

  6. #6
    hallo frank,

    freut mich dass ich düdelüt so treffend beschrieben habe und es sofort erkannt wurde

    ich hab den isp-programmer in den dafür vorgesehenen steckplatz gesteckt!
    er ist in der nähe vom c11 und c12 (elko 220µF) und mit ISP beschriftet!

    welche pins (sub-dweiblich) im ISP könnten für den kurzschluss verantwortlich sein?

    gruß takemura

  7. #7
    Administrator Robotik Einstein Avatar von Frank
    Registriert seit
    30.10.2003
    Beiträge
    4.943
    Blog-Einträge
    1
    Hi,
    ja "düdelüt" hab ich sofort erkannt Wenn falscher Quarz drin steckt dann gehts übrigens "düüüüdddddeeeeeeeelllllllllllllllüüüüüüüüüüüt ".
    Also wenn du es bei ISP rein gesteckt hast dann ist das ok. Falschrum kann man den ja nicht einstecken.

    Du solltest nun noch mal testen ob es am Kabel oder am Dongel liegt. Den Dongle kannst du vom Kabel über einen Stecker abziehen. Steck also nur mal Kabel rein. Wenn es dann auch ein Kurzschluss gibt, dann ist bei der Konfektionierung des Kabels was schief gelaufen.
    Defektes Kabel oder Dongels sind aber äußerst selten.
    Wenn es nicht das Kabel ist, dann am besten Dongel, Kabel und Sicherheitshalber auch Board zur Prüfung mit kurzer Notiz frei einschicken. Das wird schnell bearbeitet.

  8. #8
    hallo frank,

    ich glaube bei deinem "düdelüt" handelt es sich um einen 7,14 MHz quarz *g*.

    so kabel scheint in ordnung zu sein, denn erst wenn ich den ISP auf das an den rc-control angeschlossene kabel stecke dann gehen die lichter aus!

    ich werde morgen mal die platine mit ins geschäft nehmen und unter der lupe nach lötbrücken suchen. falls ich den fehler nicht beheben kann oder nicht finde würde ich gerne das angebot der kostenlosen reparatur wahrnehmen.

    danke frank für deine zügigen antworten! jetzt konnte den fehler schonmal eingrenzen!

    gruß takemura

  9. #9
    Administrator Robotik Einstein Avatar von Frank
    Registriert seit
    30.10.2003
    Beiträge
    4.943
    Blog-Einträge
    1
    Hi,
    die Boards werden industriell gefertigt, Lötbrücken sollten da eigentlich ausgeschlossen sein. Aber vielleicht ist bei Fertigung/Reinigung ein Metall Krümmel in Dongel gerutsch, kannst ja mal rein schaun. Ansonsten machen wir es wie vereinbart.
    Und prüfe nochmal ob die rote Leitung auch an beiden Steckern auf Pin 1 liegt. Das Kabel konfektionieren zwar auch Experten, aber Fehler macht ja jeder mal.

    Gruß Frank

  10. #10
    Neuer Benutzer Öfters hier
    Registriert seit
    17.09.2004
    Ort
    Göttingen
    Beiträge
    17
    Wichtig ist nur das du ISP-Programmierkabel auch an der ISP Buchse und nicht am I2C Bus anschließt. Denn im letzteren fall verursachst du Kurzschluss und dadurch wird Spannungsregler natürlich "RICHTIG HEISS"
    Mmm - heißt das dann I2C danach kaputt ?

    Hab mein Board die Woche bekommen und auch erst falsch gesteckt. Weiß aber nicht mehr genau ob ich saft drauf hatte oder nicht...

    Programmieren und so geht alles super.
    Nur jetzt wollte ich RN-Motor in betrieb nehmen und nichts tut sich...
    RN-Motor Blinkt auch erst wie beschrieben.
    Wie kann ich sehen oder messen ob alles richtig läuft ?!

    I2C Kabel ist selbstgemacht - 1zu1 Kabel (Hatte ich jedenfalls so verstanden bei I2C)
    und Widerstand brauch ich ja auch nicht - oder ?!

+ Antworten
Seite 1 von 2 12 LetzteLetzte

Berechtigungen

  • Neue Themen erstellen: Ja
  • Themen beantworten: Ja
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •