-
        

Ergebnis 1 bis 8 von 8

Thema: Problem mit MOSFET-Treiber IR2125

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    10.08.2007
    Beiträge
    7

    Problem mit MOSFET-Treiber IR2125

    Anzeige

    Moin,

    gegeben ist die Ansteuerung von 2 parallel geschalteten IRF1405 durch
    einen Highside-MOSFET-Treiber IR2125; siehe Anhang. Die MOSFETs
    versorgen H4-Glühbirnen (ca. 100W), die ständig an Masse (GND) hängen.

    Problem: Die Ansteuerung funktioniert nur sporadisch; manchmal nur, wenn
    die PWM zunächst mehrfach ein- und ausgeschaltet wird.
    Wird die Versorgungsspannung kurz unter ca. 10V reduziert (wohl
    undervoltage lockout) und gleich wieder erhöht, werden die MOSFETs immer
    angesteuert. Danach kann man die PWM in der Regel ab- und ohne Probleme
    mit der Ansteuerung wieder anschalten.

    Das Problem tritt mit 2 unterschiedlichen IR2125 auf, sodass ein
    Bauteilfehler unwahrscheinlich ist.

    Auf dem Oszi sind keine mir ersichtlichen Probleme (Störungen etc.)
    erkennbar. Wenn die Ansteuerung funktioniert, sind alle 2125-Signale so,
    wie wie sein sollen.

    Wieso 'zündet' der IR2125 nicht unter normalen Umständen?


    Danke im Voraus, Udo
    Miniaturansichten angehängter Grafiken Miniaturansichten angehängter Grafiken forum.jpg  

  2. #2
    Erfahrener Benutzer Begeisterter Techniker
    Registriert seit
    02.12.2004
    Alter
    32
    Beiträge
    287
    Hallo,

    ich würde einmal versuchen, der "Error" Pin richtig zu beschalten, also sprich mit einem Kondensator gegen masse, wie es das Datenblatt vorgibt.

    Ich hab mir die Funktion dieses Pins jetzt nicht durchgelesen, jedoch klingt das deutlich nach „manchmal funktioniert’s, manchmal nicht…".

    Mfg
    The future is closer then you think!

  3. #3
    Neuer Benutzer Öfters hier
    Registriert seit
    10.08.2007
    Beiträge
    7
    Moin und danke,

    Zitat Zitat von locked
    ich würde einmal versuchen, der "Error" Pin richtig zu beschalten, also sprich mit einem Kondensator gegen masse, wie es das Datenblatt vorgibt.
    Auch mit Kondensator besteht das Problem.
    Die Beschaltung sollte aber auch mit Widerstand 'erlaubt' sein; siehe Beispiel in AN-978.

    Udo

  4. #4
    Erfahrener Benutzer Begeisterter Techniker
    Registriert seit
    02.12.2004
    Alter
    32
    Beiträge
    287
    verstehe.

    Tritt dieses Phänomen auch auf, wenn du nur einen MOSFET verwendest?

    mfg
    The future is closer then you think!

  5. #5
    Neuer Benutzer Öfters hier
    Registriert seit
    10.08.2007
    Beiträge
    7
    Moin,

    Zitat Zitat von locked
    Tritt dieses Phänomen auch auf, wenn du nur einen MOSFET verwendest?
    Ja. Ich habe auch schon mit den Gatewiderständen 'herumgespielt', um die Schaltgeschwindigkeit zu reduzieren - obwohl das dVs/dt eigentlich kein Problem sein sollte.

    Was mich so irritiert ist, dass man den Treiber dadurch zum Arbeiten übereden kann, indem man kurz unter undervoltage lockout (ca. 10V) und dann wieder auf ca. 12V geht.

    Udo

  6. #6
    Neuer Benutzer Öfters hier
    Registriert seit
    10.08.2007
    Beiträge
    7

    Nachtrag

    Moin,

    habe mal ein wenig geduldiger getestet:
    Der IR2125 steuert die MOSFETs ungefähr 6 Sekunden nach Einschalten der PWM dann doch an. Die Zeit ist reproduzierbar.
    Der Bootstrap-Kondensator ist dabei die gesamte Zeit auf ca. VCC aufgeladen, also so, wie es sein sollte, wenn der Treiber abgeschaltet hat.

    Udo

  7. #7
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    14.01.2006
    Ort
    Hattingen
    Alter
    52
    Beiträge
    984
    Hallo,

    ich hab mir grad mal den Schaltplan angesehen. Das scheint ja alles so ok zu sein.

    Im Schaltplan ist mir als einzigstes aufgefallen, dass du den Bootstrap-kOndensator zu Cs geführt hast, und dann beide zusammen zu Vs.

    Im Lqayout sollte das gern, da beide Pins ja nebeneinander liegen und kurz verbunden sind. Wenn du das so auf einem Breadboard mit Drahtaufbau gemacht hast, dann könnte Vs einen Spike sehen, wenn aus dem Bootstrap-Kondensator der Strom in das Gate schießt. Eine Sternförmige Verdrahtung (alles über separate Leitungen an Vs) wäre hier sicherer.

    Was mir ooch aufgefallen ist, ist dass du Vcc (14V) direkt auf den IR2125 gibst.Da es sich um das Kfz-Boardnetz handelt, finde ich das etwas heiß, weil hier auch mal Spikes von mehr als 25V vorkommen können können.
    Evtl. also noch ein RC-Glieder mit 18V-Z-Diode davor oder so.

    Sigo

  8. #8
    Neuer Benutzer Öfters hier
    Registriert seit
    10.08.2007
    Beiträge
    7
    Moin,

    Zitat Zitat von sigo
    ich hab mir grad mal den Schaltplan angesehen. Das scheint ja alles so ok zu sein.
    Das meine ich auch. Und ich verstehe das nicht


    Zitat Zitat von sigo
    Im Schaltplan ist mir als einzigstes aufgefallen, dass du den Bootstrap-kOndensator zu Cs geführt hast, und dann beide zusammen zu Vs.
    Der Kondensator steht direkt neben dem Treiber und ist dort mit Vb und Cs und Vs verbunden. Von Cs/Vs geht dann ein ca. 2 cm langes dünnes Kabel auf der Oberseite der Platine zu den MOSFET-Sources.
    Ist eine geätzte Platine.


    Zitat Zitat von sigo
    Was mir ooch aufgefallen ist, ist dass du Vcc (14V) direkt auf den IR2125 gibst.Da es sich um das Kfz-Boardnetz handelt, finde ich das etwas heiß,
    Sigo
    Ja, sorry, mein Fehler. Ich habe für diesen Thread nur schnell die Treiberbeschaltung von einer Schaltungsversion kopiert.
    Im Anhang findet sich die Spannungsversorgung und die Treiberbeschaltung mit den richtigen Spannungen.

    Udo
    Miniaturansichten angehängter Grafiken Miniaturansichten angehängter Grafiken forum2.jpg  

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •