-
        

Ergebnis 1 bis 3 von 3

Thema: seltsame Fehlermeldung

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    04.05.2007
    Beiträge
    16

    seltsame Fehlermeldung

    Anzeige

    hallo zusammen.
    in der letzten zeit krige immer wieder dieselbe Fehlermeldung vom AVR-Studio4:
    C:\Programme\...\TEST\TEST.asm(10): error: syntax error, unexpected SYMBOL, expecting ':'

    versteh überhaupt nicht, selbst bei so einem einfachen code:
    Code:
    		.INCLUDE "m16def.inc"
    		.DEF akku=r16
    		.CSEG
    		rjmp start
    start:	
    		ldi akku, 0x FF
    		out DDRB, akku		
    loop:                          in akku, PIND
    		out PORTB, akku
    		rjmp loop
    		.EXIT
    was könnte es denn sein?..

  2. #2
    Super-Moderator Robotik Visionär Avatar von PicNick
    Registriert seit
    23.11.2004
    Ort
    Wien
    Beiträge
    6.836
    Code:
          ldi akku, 0x FF     ; 0xFF ->da sollt' kein leerzeichen drin sein

    Code:
    loop:                          
            in akku, PIND  ; mach das lieber in einer neuen Zeile, manche mögen den Label immer extra
    War das nix, dann sehen wir weiter
    mfg robert
    Wer glaubt zu wissen, muß wissen, er glaubt.

  3. #3
    Neuer Benutzer Öfters hier
    Registriert seit
    04.05.2007
    Beiträge
    16
    jo, jetzt gehts.
    ldi akku, 0x FF ; 0xFF ->da sollt' kein leerzeichen drin sein
    das ist’s gewesen – und leerzeichen nachm komma mag er anscheinend auch nicht.
    danke dir für den guten tipp!
    gruss eis

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •