-         

Ergebnis 1 bis 5 von 5

Thema: Roboter Stromversorgung ? Lithium? laden?

  1. #1
    Erfahrener Benutzer Roboter Experte
    Registriert seit
    29.10.2004
    Ort
    GRAZ
    Alter
    51
    Beiträge
    576

    Roboter Stromversorgung ? Lithium? laden?

    Anzeige

    Hallo Leute

    Sorry, wenn das Thema schon mal wo angesprochen wurde, aber bis jetzt habe ich nicht viel passendes im Netzt gefunden.

    Ich überlege mir einen kleinen Dreirad-Bod zu bauen.
    Dazu hätte ich zwei Lithium Akkus mit je 3,7V /1,4Ah
    (die gab es auch mal bei Polin)

    Ich möchte die Akkus gerne mal mit einer Stromschleife laden.
    (ähnlich wie bei den elektrischen Zahnbürsten)
    Wegen der Stromschleife muss ich die Spannung vermutlich erstmal hochtransformieren..?!

    Der Rob soll dann mal selbst über diese Stromschleife fahren und sich aufladen...

    Meine Fragen:

    *) Wie könnte ich das am besten machen?

    *) Muss ich jede Zelle extra laden oder kann ich die zwei Zellen in Serie schalten und gemeinsam laden?

    *) wie funktioniert das eigentlich bei so Akkupacks, die solche zusätzlichen Leitungen aus dem Akku haben? Balancer?


    Möchte eventuell die Laderegelung auch von dem AVR übernehmen lassen
    (Mega32)

    Als Schaltung hätte ich da mal was gefunden:
    http://www.richard-dj1pi.de/AVRlader1.jpg
    (von hier: http://www.richard-dj1pi.de/modell_elektron.html )

    Habt Ihr eine Idee, wie der Ladeablauf am besten sein könnte?
    ----------
    Woanders habe ich solch einen Hinweis gefunden:
    Konstantstrom von 1C bis 3.99Volt, danach umschalten auf
    Konstantspannung 4.1 bzw 4.2 Volt, bei 1/10C Ladestrom ist die Ladung
    beendet.
    --------------


    Würde mich um Gedankenaustausch freuen

    l.G. Roberto

  2. #2
    Erfahrener Benutzer Roboter Experte
    Registriert seit
    30.09.2006
    Beiträge
    734
    Hi Roberto,
    welche Zellen sind das? Die flachen li-poly oder die eckligen blauen li-ion? Ich habe beide hier. Bis jetzt ließen die sich problemlos mit dem Labornetzteil laden. Beide haben eine SChutzschaltung, welche ich bis jetzt nicht in Anspruch nehmen musste. An sich sind diese Akkus sicher. Hohe Ströme kann man nicht entnehmen, dafür sind sie nicht gedacht und die Schutzschaltung wird anspringen. Die mittlere Leitung der li-poly akkus ist ein temperaturwiderstand (meine ich), muss also nicht beschaltet werden. Wenn du die Zellen für Antriebsanwendungen verwenden möchtest, musst du die Akkus stark puffern, damit die Schutzschaltung nicht abschaltet.

    Zum Laden: Grundsätzlich auf www.battery-university.com nachschlagen. Die Informationen dort sind korrekt. D.h. Konstantspannung-Konstantstromladung bis ~4.1V, 0.5C. Bis 4.2V geht auch, ist aber kritischer und erlaubt nicht so viele Zykeln. Ähnlich wie ein Bleiakku

    Probier doch mal einen LM317 als Konstantspannungsquelle aus. Vorher nachmeßen, ob diese auch tatsächlich herauskommen. 0.1V mehr, d.h. von 4.1V auf 4.2V, entsprechen 10% Kapazität, also besser auf Sicherheit setzen. Probier das Laden von Hand aus, damit du ein Gefühl dafür bekommst. Das Konzept mit einem Microkontroller zu kombinieren wird dann nicht soooo schwer sein.


    Du kannst die Zellen in Serie ohne Balancer/Equalizer laden. Dann solltest du die Zellen aber auch nur mit niedrigen Strömen laden/entladen. Wird in praktisch allen kommerzielen Geräten so gemacht. Den Link, den du angegeben hast, habe ich auch gebookmarkt Problematisch ist der 10k Spannungsteiler, davon hängt die Genauigkeit ab. Theoretisch sollte es funktionieren, nachgebaut habe ich es noch nicht.

    Zu der Spule: Im Prinzip ein Transformator. Bei meiner Zahnbürste sind sekundär nur 2/4 Dioden mit den NiCd Akkus angeschlossen. Das darfst du natürlich nicht machen Je höher die Frequenz, destso niedriger muss die Induktivität sein und ich meine, es wird mehr Energie übertragen. Aber in dem Bereich bin ich nicht fitt. Hier im roboternetz ist in der letzten Woche ein Thread aufgetaucht, der sich gerade mit dem Problem befasst. Ansonsten mal nachschauen, wie die Leute mit diesen rotierenden Displays ( http://www.alan-parekh.com/rotating_display.html ) das machen. Die brauchen auch irgendwie Energie.

    Noch ein Kommentar zu deiner Idee: An sich super, finde ich gut. Vor allem merkt man, dass du dich vorher schon informiert hast. Deswegen schreibe ich auch soviel Du solltest dir aber überlegen, ob du das mit der Spule im Boden wirklich machen möchtest. Ist zwar eine sehr elegante Möglichkeit, aber auch schwierig. Z.B. wirbelströme im chasis, falsche Position, Induktion in der Elektronik, Motorwicklung (?). Man könnte auch zwei Kontakte aus dem Boden kommen lassen die dann an das Chasis angeschlossen werden. Analog zu http://www.wiesolator.de/index.php?a...Dockingstation

  3. #3
    Erfahrener Benutzer Roboter Experte
    Registriert seit
    29.10.2004
    Ort
    GRAZ
    Alter
    51
    Beiträge
    576
    Hallo Avion23

    du dich vorher schon informiert hast. Deswegen schreibe ich auch soviel
    Danke für die Antwort

    welche Zellen sind das? Die flachen li-poly oder die eckligen blauen li-ion?
    Sind die Panasonic CGP345010
    Habe da was gefunden:
    http://www.electronics-lab.com/artic...t/index_1.html
    Meine haben aber pro Akku so eine Platine drinnen.
    Nach meinen Tests schaltet diese Platine den Akku bei ca. 2,6V ab.
    Dürfte also nur eine Unterspannungsabschaltung sein!
    Das Sie bei zu viel Belastung auch abschaltet, ist mir nicht bekannt


    Die mittlere Leitung der li-poly akkus ist ein temperaturwiderstand (meine ich),
    Meine haben nur zwei Anschlüsse! (rot/schwarz)


    Probier doch mal einen LM317 als Konstantspannungsquelle aus. Vorher nachmeßen, ob diese auch tatsächlich herauskommen. 0.1V mehr, d.h. von 4.1V auf 4.2V, entsprechen 10% Kapazität, also besser auf Sicherheit setzen. Probier das Laden von Hand aus, damit du ein Gefühl dafür bekommst.
    Bei einer anderen Schaltung hatte ich mal einen L200 verwendet der auf 4,1V pro Zelle eingestellt war. (Fixer Strom) (8,2V)
    Da hatte ich aber so ein Doppelpack mit fertigen zwei Zellen von Conrad.


    Du kannst die Zellen in Serie ohne Balancer/Equalizer laden. Dann solltest du die Zellen aber auch nur mit niedrigen Strömen laden/entladen. Wird in praktisch allen kommerzielen Geräten so gemacht.
    Ahaaa....
    Dann kann ich also zwei Zellen in Serie schalten...?!
    Habe da nur bedenken, dass wenn eine mal mehr oder weniger zieht, die andere dann zu viel abbekommt
    Derzeit probiere ich gerade mal zwei Zellen in Serie und mit einem Labornetzteil mit einer Spannung von 8,3V
    Am Anfang nahmen die Akkus ca. 0,66 Ampere auf. Inzwischen sind sie ca. auf 0,2 A runter.
    Kontrolle bei beiden Zellen mit je einem Multimeter.
    Spannung pro Zelle noch im grünen Bereich (jetzt bei ca. 4,1V)

    Du solltest dir aber überlegen, ob du das mit der Spule im Boden wirklich machen möchtest. Ist zwar eine sehr elegante Möglichkeit, aber auch schwierig. Z.B. wirbelströme im chasis, falsche Position, Induktion in der Elektronik, Motorwicklung (?). Man könnte auch zwei Kontakte aus dem Boden kommen lassen die dann an das Chasis angeschlossen werden.
    Ja, hast recht. Werde das mal überdenken...
    Vielleicht dann mit zwei Platten an der Wand (+ und -) wo der dann ran fahren muss und sich dort aufladen kann.
    Auf jeden Fall soll er sich irgendwie wieder selbst aufladen können.
    Möchte den nicht immer selber mit Kabel aufladen...

    Ich studiere gerade, wie ich den AD wandler vom Mega32 am besten beschalten könnte, dass ich die Spannungen so genau wie möglich messen kann (Referenzspannung, Spannungsteiler u.s.w.)
    Ein Shunt in der Versorgung für die Stromaufnahme wäre irgendwie auch ganz gut

    l.G. Roberto

  4. #4
    Erfahrener Benutzer Roboter Experte
    Registriert seit
    30.09.2006
    Beiträge
    734
    Nur ganz kurz:

    Ja du kannst die Zellen seriell verschalten. Ab und zu mal mit dem Multimeter kontrollieren.

    Zum Spannungsmeßen wird oft folgendes verwendet: Betriebsspannung als Vref verwenden. Einen kanal dann auf die interne Referenz schalten. Spannung meßen. Diese Spannung ist bekannt, der Wert ist relativ zur Versorgungsspannung. Auf diese Weise kann man einen Pin sparen, auch wenn ich nicht so ganz verstanden habe wie.

    Den strom misst man normalerweise lowside differentiell. Du könntest den internen gain des atmega verwenden mit einem auf deinen Strom bereich abgestimmten shunt. Das kann auch ein Stück kupfer sein, wenn du große Erwärmung ausschließen kannst oder ein absinken des Stroms mit der Temperatur erwünscht ist. Beim differentiellen meßen existiert das Problem, dass man (anscheinend) die beteiligten Kanäle nicht auf Masse setzen darf! D.h. man braucht eine Hilfsspannung, ganz durchgestiegen bin ich da noch nicht.

    Ein absinken des Stromes zum Ladeende ist normal. Geht auch garnicht anders. Deswegen sollte man li-ion akkus auch immer etwas länger als eigentlich nötig im Ladegerät lassen, weil viele Ladegeräte den Akku als "voll" anzeigen, wenn zur Konstantspannungsphase gewechselt wird.
    Und schade, dass die Zellen keine Überstromabschaltung integriert haben. Mal einen Kurzschluss getestet oder die Schaltung angesehen? Normalerweise ist da ein lowside mosfet und die über R_DS_on abfallende Spannung wird von einem proprietären chip gemeßen.

    Und glaub nicht alles, was ich schreibe Nachprüfen ist sicherer, ich vertue mich öfters.

  5. #5
    Erfahrener Benutzer Roboter Experte
    Registriert seit
    29.10.2004
    Ort
    GRAZ
    Alter
    51
    Beiträge
    576
    Habe gerade die Belastung gemessen.
    2,5 Ampere ohne Abschaltung.

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •