-
        

Ergebnis 1 bis 4 von 4

Thema: L 298 (motortreiber) als Transistor für große Lasten

  1. #1
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    14.11.2006
    Beiträge
    151

    L 298 (motortreiber) als Transistor für große Lasten

    Anzeige

    Hallo
    ich wollte ein Display , das am LPT hängt über einen Mega8 an bzw. ausschalten, dafür hab ich den Strom für die Hintergrundbeleuchtung des Displays unterbrochen und wollte den über einen Transistor steuern, der das Steuersignal von meinem Mega8 bekommt.

    ich denke aber mal, das die Last des Displays zu groß für den Transistor war, das ganze hat nämlich zu merkwürdigen Fehlfunktionen geführt, unter anderem gingen andere Led's an, wenn ich das Display eingeschaltet hab.
    ein Relais hab ich nicht hier und würde ich auch ungern verbauen, da das ganze Ding in einem PC Gehäuse liegt.
    Ich hab aber einen L-298 hier und hab mir gedacht, dass ich den ja genau so nehmen kann, in dem ich den Eingang für den Motor Strom den Eingang vom Display nehme, den Ausgang auch zurück zum Display und das Ding so steuer, wie ein Transistor. ich bin mir nur nicht ganz sicher, wie das an zu schließen ist, ich habs mal probiert wir im Anhang und dachte Enable und Input sollten an 5V bzw eine Leitung vom Mega8 gesteuert und eine Leitung über ein Transistor mit 5V verbindet.
    Die Led die ich zu Testzwecken angeschlossen hab leuchtet aber auch ohne Signal GANZ schwach, etwas stärker, wenn ich eine Leitung mit dem Finger, oder Metall berühre, und ganz stark, wenn ich sie mit +5V verbinde.
    Über Tip's, wie ich das richtig an zu schließen hätte würde ich mich sehr freuen, vielleicht ist dieser mini Strom, der ohne Signal durch die Led fließt ja auch Normal.
    THX schonmal, Testus2K
    Miniaturansichten angehängter Grafiken Miniaturansichten angehängter Grafiken l298pinout.jpg  

  2. #2
    Erfahrener Benutzer Lebende Robotik Legende Avatar von PICture
    Registriert seit
    10.10.2005
    Ort
    Freyung bei Passau in Bayern
    Alter
    66
    Beiträge
    10.979
    Hallo Testus2k!

    Wir haben anscheinlich gleichzeitig Beiträge geschrieben. Schau Dir, bitte, dieses Thema an:

    http://www.roboternetz.de/phpBB2/viewtopic.php?t=33837

    Vielleicht gefällt Dir Meine Skizze?

    MfG
    MfG (Mit feinem Grübeln) Wir unterstützen dich bei deinen Projekten, aber wir entwickeln sie nicht für dich. (radbruch) "Irgendwas" geht "irgendwie" immer...(Rabenauge) Machs - und berichte.(oberallgeier) Man weißt wie, aber nie warum. Gut zu wissen, was man nicht weiß. Zuerst messen, danach fragen. Was heute geht, wurde gestern gebastelt. http://www.youtube.com/watch?v=qOAnVO3y2u8 Danke!

  3. #3
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    14.11.2006
    Beiträge
    151
    Auch mit Darlington Schaltung reicht es nicht...also zurück zu meiner Ursprünglichen Frage:
    wie schließt man den l298 richtig an?

  4. #4
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    14.11.2006
    Beiträge
    151
    hab mir jetzt ein Relais bestellt und versuch es damit

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •