-
        

Ergebnis 1 bis 7 von 7

Thema: Motorbrummen verbessern

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    29.05.2007
    Beiträge
    21

    Motorbrummen verbessern

    Anzeige

    SMARTPHONES & TABLETS-bis zu 77% RABATT-Kostenlose Lieferung-Aktuell | Cool | Unentbehrlich
    Hallo ,

    in einer kardanischen Aufhängung wird eine schwere Kamera getragen. Die Stabilisierung erfolgt mit Gyro´s als Sensoren, die ihre Steuersignale über eine entsprechende Verstärkung an 12 V-Scheibenwischermotore
    (abgesägtes Getriebe, also Direktantrieb) weitergeben. Aufgabe der Motore ist es , im Fall einer Fehlbewegung eine entsprechende Gegenkraft
    auf die zuständige Achse zu erzeugen, um eine Stabilisierung dieser Achse zu bewirken.

    Das funktioniert bisher recht gut. Pendelbewegungen ( der Schwerpunkt ist nach unten gelegt, um immer den Horizont anzustreben)welche ohne
    die Bremsmotore entstehen, werden fast eleminiert.

    Nur ein Schönheitsfehler stört mich noch :
    Im Bereich der schwachen Ansteuerung des Motors ( wenn nur eine kleine
    Fehlbewegung auftritt oder am Beginn einer Gegenbewegung des Motor´s)
    brummt dieser. Wohlgemerkt erfolgt die Ansteuerung per PWM über eine
    Motorbrücke ( bestehend auf 4 Mal BD 249 ). Es hört sich so an, als ob die Motorachse im Gleitlager flattert. Übrigens habe ich das gleiche Geräusch wenn ich den gleichen ( nicht denselben ) Motor über eine
    PWM-Drehzahlregelung von Conrad ansteuere. Dort kann ich das Geräusch vermindern wenn ich die Impulsfrequenz verändere. Wie das bei einer Impulsweitenansteuerung üblich ist, hat der Motor auch schon im unteren Drehzahlbereich Kraft, jedoch brummt er.

    Diese Impulsfrequenz kann ich bei dieser Anwendung jedoch nicht vornehmen weil dann die Nullpunkteinstellung an der PWM nicht mehr funktioniert.

    Wer kann mir einen guten Rat geben ? Der Motor ist bisher nicht entstört, könnte es evtl. daran liegen ?


    MfG Suki

  2. #2
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    22.05.2007
    Ort
    Stolberg
    Beiträge
    111
    Hallo Suki,

    Wie ist denn die Frequenz mit der Du das PWM Signal generierst, und wie steuerst Du die Low-Phasen wärend der PWM an, alle Transistoren offen oder zwei Transistoren an den selben Pol (Freilauf)?

    Gruß,
    Nils

  3. #3
    Neuer Benutzer Öfters hier
    Registriert seit
    29.05.2007
    Beiträge
    21
    Hallo Nils,
    danke für die Antwort.

    Das Steuersignal kommt aus einem Servotester von Conrad. Dieser ist mit einem 4001 aufgebaut und er erzeugt das genau richtige Signal als Ersatz für das Empfängersignal ( ein Sender und ein Empfänger werden also nicht mehr gebraucht.) Es ist also ein Servo-Signal-Generator.

    Dieses Servosignal geht zu einem Gyro, welcher im Falle von Fehlbewegungen ein entsprechendes PWM ausgibt. Dieses Signal geht zu einer Servosteuerung mit Richtungslogik ( NE544 )welche am Ausgang ein Rechts/Linkssignal ausgibt. Nach dessen Verstärkung wird dieses Signal zur Ansteuerung der Basen der H-Brücke ( bestehend aus 4 X BD 249 mit 4 Freilaufdioden ) verwendet. Es sind immer 2 Transitoren mit dem gleichen Pol ( + oder - ) angesteuert.

    beste Grüße, Suki

  4. #4
    Erfahrener Benutzer Robotik Einstein Avatar von vohopri
    Registriert seit
    11.09.2004
    Ort
    südlich der Alpen
    Beiträge
    1.708
    Hallo suki,

    schau dir die Impulse am Motor mal mit einem Oszi an, in dem Frequenzbereich ginge auch eine qualitative Beurteilung mit einem Soundkarten Programm. Dann kannst du sicher sein, ob das Signal sauber ist.

    Ob es in diesem Fall Sinn macht, den Spannungsanstieg mit einem Boucherot Glied zu verringern, könnte dir ein Spezialist sagen. Sicher ist, dass steile Flanken eher akustisch wahrnehmbar sind.

    Sonst hilft noch Abdecken des Motors, Isolieren des Motors gegen Körperschall durch Lagern auf kleinen Kautschuk Blöcken oder änlichem. Auch eine elastische Kupplung hilft. Google Bilder zeigt viele Beispiele.

    grüsse,
    vohopri

  5. #5
    Neuer Benutzer Öfters hier
    Registriert seit
    29.05.2007
    Beiträge
    21
    Hallo ,
    am Oszilloskop sind die Steuersignale rechteckig und gut ausgebildet. Die "Lastsignale", also die Signale hinter den Transistoren, direkt zum Motor sind jedoch nicht mehr rechteckig, sondern spitz nach oben und nach unten gerichtet.

    Auch ist ein deutlicher Spannungsabfall zu sehen ( die Eingangsspannung ist 12 V, die Spannung welche am Motor zur "Arbeit" kommt, ist nur noch ca. 4-5 V ( zwischen 3und 4,5 Ampere )). Hierbei ist zu bemerken, daß die Motore als Bremsmotore eingesetzt werden, d.h sie "wollen" in entgegesezter Richtung drehen ( machen aber praktisch nur den Ansatz einer Drehung weil sie ja die Fehlbewegung abbremsen sollen.) Also wenn die Fehlbewegung nach links gerichtet ist, will der Bremsmotor nach rechts laufen, kann aber nicht kontinuierlich drehen weil ja die Gegenkraft größer ist. Das ist so gewollt.

    Was also zu verbessern wäre, ist das Motorschnarren ( kein direktes Brummen) und eine Erhöhung der "Arbeitsspannung".

    Das Motorschnarren ( er will ja kann aber nicht so recht weil er ja gehalten wird) ist eigentlich nur ein Schönheitsfehler.

    Die Erhöhung der Spannung ist wichtiger, weil die Bremsen etwas kräftiger sein könnten.

    MfG Suki

  6. #6
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    06.11.2006
    Beiträge
    1.078
    Hallo
    Da könntest Du mit höheren Frequezen experementieren.
    Eventuell sind auch ein paar Drosseln in der Motorzuleitung hilfreich.

    Mit freundlichen Grüßen
    Benno
    Wo man nicht mit Vernunft handelt, da ist auch Eifer nichts nütze; und wer hastig läuft, der tritt fehl.
    Ein König richtet das Land auf durchs Recht; wer aber viel Steuern erhebt, richtet es zugrunde

  7. #7
    Neuer Benutzer Öfters hier
    Registriert seit
    29.05.2007
    Beiträge
    21
    Hallo Benno,

    mit höheren Frequenzen wird das nicht funktionieren weil dann die PWM (Servosignal) nicht mehr der Vorgabe entspricht und die Servosteurung mit der Richtungserkennung, das "Herz " des Ganzen, ausser Takt gerät. Aber die Drosseln in der Motorzuleitung werde ich mal probieren.

    Ich hatte jedoch schon eine Entstördrossel von Conrad drin, jedoch ohne Erfolg.

    MfG Suki

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •