-         

Ergebnis 1 bis 5 von 5

Thema: Ein Pic der ohne Strom funktioniert...

  1. #1
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    05.05.2007
    Beiträge
    177

    Ein Pic der ohne Strom funktioniert...

    Anzeige

    Langsam krieg ich vor meinem Sd20 Angst, ganz ehrlich.

    Entweder habe ich hier was aus der Zukunft, oder ich sollte mal meine Umgebung auf Radioaktivität prüfen...

    Also, ich habe es am Anfang nicht hingekriegt meinem Sd20 irgendein Lebenszeichen zu entlocken. Dann habe ich ihn erstmal vom Strom abgekoppelt, um noch mal die I2C Leitungen zu prüfen, aber schon geb ich auch den Mikrocontroller Strom, schon läuft der Servo

    Ich hab erstmal einen Schweißausbruch bekommen, und war doch sehr verwundert.

    Dann habe ich den Strom wieder an den Pic gemacht, und nichts ging mehr. Ich habe dann auch noch mal Plus und Masse einzeln angeschlossen, auch dann ging es nicht, nur wenn überhaupt kein Strom anliegt funktionierts

    Das kann ja eigentlich nicht sein, aber der Pic ist garantiert an keine Spannungsquelle angeschlossen. Das einzige was irgendwie mit Strom zu tun hat sind da die beiden Datenleitungen des Buses. Die Bewegungen des Servos beginnen sobald der Pic über I2C angesprochen wird (so sollte es ja auch sein), wobei sich dann der Atmega bei der Übermittlung der Servonummer aufhängt.

    Das ist irgendwie total mysteriös, da beide Leitungen ja eigentlich Plus sind und eigentlich garnichts fließen kann.

    Noch als Anmerkung: Die Schaltung des Pics ist richtig aufgebaut (Pullups, etc.) und ich habe nur die Spannung von der Platine genommen, also die interne Verkabelung steht noch.

  2. #2
    Erfahrener Benutzer Roboter Experte
    Registriert seit
    22.11.2005
    Ort
    Braunschweig
    Alter
    41
    Beiträge
    685
    Moin, ich hoffe, du hast bei Deinen Versuchen vorher alle Masseanschlüße verbunden? Dein Effekt ist ja seltsam, bei meinem SD20 habe ich das noch nicht probiert Da beim Einschalten Deines Controllers ja irgendwas mit den Pins des I2C busses passiert, könnte ich mir vorstellen, daß die Ausgänge des SD20 irgendwie rumflattern, je nachdem, was auf der SDA und SCL Leitung passiert. Benutzt Du Hardware-TWI? und welchen Controller eigentlich? Ich könnte Dir ein kleines Programm mit HEX-File schicken, welches die Servos alle mal anspricht oder so...
    MfG Volker
    Meine kleine Seite
    http://home.arcor.de/volker.klaffehn
    http://vklaffehn.funpic.de/cms
    neuer Avatar, meine geheime Identität

  3. #3
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    03.04.2005
    Beiträge
    181
    Hallo,

    Pins von CMOS IC´s haben normalerweise Schutzdioden gegen Masse und Vcc. So geschaltet, daß sie sperren, wenn der Pin nicht unter GND und über Vcc liegt.
    Wenn der Pin über Vcc geht, leitet sie nach Vcc.
    Das ist eigentlich gedacht, elektrostatische Entladungen abzuleiten.

    Wenn Du jedoch Vcc 0V machst, an SCL/SDA aber 5V liegen passiert es auch.
    Nun leitet die Diode Strom aus dem Pin nach Vcc und schon hat der Chip Spannung auf dem internen Vcc Netz. Er kann funktionieren.

    Nur wenn diese "parasitären" Vccpins zufällig gerade alle auf 0 gehen, geht ihm der Saft aus.
    Ausserdem ist dieses Vcc etwas schwach und die Funktion des Chips nicht sehr zuverlässig.

    Bernhard

  4. #4
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    05.05.2007
    Beiträge
    177
    Das einzige was ich möchte ist das dieses interne Vccnetz Spannung kriegt, ich plag mich mit diesem IC jetzt bestimmt schon über 10 Stunden zusammengerechnet rum.

    Ich habe jetzt nochmal alles ausprobiert, immer wenn ich irgendwo Spannung anlege, wo welche hinsoll, geht gar nichts mehr. Kann es sein das der Chip kaputt ist?

    Edit: Habe verschiedene Spannungen, RN-Control mit 7,5 Volt, IC 5V mit 7805, beide mit derselben Masse verbunden.

  5. #5
    Ich habe einmal einen Schwingkreis aufgebaut, die Spannung am Kondensator gleichgerichtet und die Spannung danach gemessen. Waren Null Volt. Gut, dachte ich, war ja auch nicht anders zu erwarten. Kurze Zeit später habe ich es eher zufällig nochmal gemessen und gemerkt, der Kondensator ist vollkommen aufgeladen.

    Wie kann das denn sein, dachte ich mir.

    Das Ergebnis war ein Gerichtsprozeß wegen Überschreitung von Strahlungsgrenzwerten. Denn der Schwingkreis war auf die Frequenz einer Radiostation geeicht(Zufall, war ein Drehkondensator).

    Nachdem ich gemessen hatte, gab es neue Messungen, dann unabhängige, dann Gutachten und dann gings los...
    Wie Deutsche Werbung verstehen:
    Come in and find out (Douglas) = Komm rein und finde wieder heraus.
    Drive alive (Mitsubishi) = Fahre lebend.
    Powered by emotion = Kraft durch Freude.

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •