-
        

Ergebnis 1 bis 2 von 2

Thema: Bascom UART Interrupt liefert komische Werte

  1. #1
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    16.05.2005
    Alter
    32
    Beiträge
    137

    Bascom UART Interrupt liefert komische Werte

    Anzeige

    Hallo Zusammen!

    Ich habe ein Problem mit meinem aktuellen Projekt. Programm 1 läuft wunderbar, liefert die richtigen Werte und ist einfach toll. Programm 2 allerdings funktioniert nicht richtig. Hier empfange ich im Terminal nur viele "Enter". Ich habe es mal aufs wesentliche vereinfacht:

    Programm1:
    Code:
    $regfile = "m32def.dat"
    $framesize = 32
    $swstack = 32
    $hwstack = 32
    $crystal = 16000000                                    
    $baud = 9600
    
    Open "COMd.6:9600,8,N,2" For Output As #1
    Dim I As Word
    
    On Urxc Onrxd
    Enable Urxc
    Enable Interrupts
    
    Do
      nop
      Waitms 100
    Loop
    End
    
    OnRxD:
      I = Udr
      Printbin #1 , I
    Return
    Programm2:
    Code:
    $regfile = "m32def.dat"
    $framesize = 32
    $swstack = 32
    $hwstack = 32
    $crystal = 16000000                                    
    $baud = 9600
    
    Open "COMd.6:9600,8,N,2" For Output As #1
    Dim I As Word
    
    On Urxc Onrxd
    Enable Urxc
    Enable Interrupts
    
    Do
      Printbin #1 , I
      Waitms 100
    Loop
    End
    
    OnRxD:
      I = Udr
    Return


    Brauche unbedingt Hilfe!
    Danke im Voraus!

    Majus

  2. #2
    Neuer Benutzer Öfters hier Avatar von TobiWan
    Registriert seit
    17.12.2006
    Ort
    Friedrichshafen
    Alter
    29
    Beiträge
    15
    Dein 2. Programm gibt alle 100ms die Variable I aus, vielleicht solltest du mit einem Flag arbeiten, das angibt, ob neue Daten vorhanden sind.

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •