-         

Ergebnis 1 bis 10 von 10

Thema: Oszillator und Microcontroller - Anschlussprobleme

  1. #1
    Benutzer Stammmitglied
    Registriert seit
    02.08.2005
    Beiträge
    78

    Oszillator und Microcontroller - Anschlussprobleme

    Anzeige

    Hallo,

    folgende Bauteile werden in meiner Schaltung verwendet: Microcontroller XC886C und Oszillator NX5032GA (8.0MHz).
    Der Microcontroller benoetigt den Oszillator um zu funktionieren.
    Meine Frage:
    Was fuer einen Unterschied macht die Leitungslaenge vom Oszillator zum Microcontroller?
    Bei meiner Platine ist der Oszillator ca. 5-6 cm vom Microcontroller entfernt. Wird der Oszillator an dieser Stelle eingebaut, dann funktioniert der Microcontroller nicht, wenn ich den Oszillator aber naeher zum Microcontroller bringe (ca. 1-2 cm) entfernet, funktioniert alles einwandfrei!
    Wieso ist das so?
    Wer kann mir hierbei helfen? - VIELEN DANK!

    MFG

  2. #2
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    02.11.2005
    Alter
    42
    Beiträge
    1.140
    Der Effekt, der Dein Problem verursacht, heißt Reflexion.
    Bei relativ langen Leitungen und hohen Frequenzen spielt der Wellenwiderstand und der Abschluss der Leitung eine große Rolle.

    Jetzt sagst Du sicherlich, dass 8MHz soch gar nicht so hochfrequent ist. Ein 8MHz Sinus-Signal hätte mit dieser Leitungslänge auch keine Probleme. Ein Oszillator spukt aber Rechtecksignale aus. Durch die Fourieranalyse wissen wir, dass sich Rechtecksignale in überlagerte Cosinus- und Sinus-Signale zerlegen lassen, wobei dann auch sehr hochfrequente Anteile zutage kommen. Im Klartext: Je besser das Rechtecksignal aussieht, je steiler also die Flanken sind, desto höher sind die enthaltenen Frequenzen und desto mehr Probleme bekommst Du bei langen Leitungen.

    Lösung Deines Problems:
    Entweder Du setzt den Oszillator in unmittelbare Nähe zum Prozessor (bevorzugte Lösung) oder du musst Deine Leitung am Ende abschließen.
    Setze mal mit einem kleinen Kondensator (~ 50pF) zwischen Deine Taktleitung und Ground. Wichtig: Der Kondensator muss so nah wie möglich am Prozessor liegen.

    Gruß,
    askazo

  3. #3
    Benutzer Stammmitglied
    Registriert seit
    02.08.2005
    Beiträge
    78


    das ist die schaltung.

  4. #4
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    02.11.2005
    Alter
    42
    Beiträge
    1.140
    Oha, das ist ein Quarz und kein fertiger Oszillator...
    Wie groß hast Du denn die C's und den R gewählt?
    Hast Du ein Osziloskop, um die Ausgangssignale zu messen?

    askazo

  5. #5
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    18.12.2006
    Ort
    Oderberg
    Alter
    25
    Beiträge
    870
    Hm ja das mein er sicher auch denn NX5032GA ist laut Datenblatt auch ein Quarz und kein Oszillator
    MfG Christopher
    MfG Christopher \/


  6. #6
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    02.11.2005
    Alter
    42
    Beiträge
    1.140
    Ja, nach danionbike's zweitem Beitrag habe ich mir dann das Datenblatt auch mal angeschaut...

    askazo

  7. #7
    Benutzer Stammmitglied
    Registriert seit
    02.08.2005
    Beiträge
    78
    C = 22 pF

    R = 0 Ohm

    gibt es sonst noch eine erklaerung bezueglich des von mir geschilderten verhaltens?

  8. #8
    Benutzer Stammmitglied
    Registriert seit
    02.08.2005
    Beiträge
    78
    das habe ich noch im netz gefunden:

    Normalerweise sollte der Quarz genauso wie die beiden 22pF-Kondensatoren, die zum Anschwingen des Quarzes dienen, möglichst nahe am Controller platziert werden. Auf dem Steckbrett ist das manchmal gar nicht so einfach, insbesondere wenn man wie in diesem Fall den Quarz erst später hinzufügt. Wichtig ist nämlich, dass die Leitungen vom Quarz zum Controller möglichst kurz sind, bei gedruckten Schaltungen oft nur 1 bis 2 cm! Auch die einzelnen Bauteilbeinchen, z.B. der Kondensatoren, sollten normalerweise so kurz wie möglich sein. Ist dies nicht der Fall, wie auch in unserem Bild, dann fungieren diese Leitungen fast wie eine Funkantenne. Dies führt in der Regel zu starken Hochfrequenzsignalen, die nicht nur unsere Schaltung, sondern auch andere Schaltungen in der Nähe stören könnten. Man merkt dies auch oft daran, dass sich ein Board bei höherer Quarzfrequenz immer seltener fehlerfrei ohne Übertragungsfehler programmieren läßt.

  9. #9
    Benutzer Stammmitglied
    Registriert seit
    02.08.2005
    Beiträge
    78
    eine Bemerkung moechte ich noch anbringen:

    die Schaltung hat mit einem C164CM Microcontroller unter der gleichen Kabellaenge einwandfrei funktioniert.

    Kann es somit am Microcontroller liegen? Koennte ich mir eigentlich nicht vorstellen, aber sollte auch mal in Betracht ziehen.

    Leider bin ich keine Experte, darum bitte ich nochmal um eure Hilfe.
    Danke!

  10. #10
    Benutzer Stammmitglied
    Registriert seit
    02.08.2005
    Beiträge
    78
    ich habe mit dem oszi mal den eingangspin am mC (xc886) und direkt am quarz beobachtet, ergebniss: gleiche form, gleiche amplitude, gleiches min. und max., gleiche periode.

    somit geht auf dem weg vom quarz zum oszi wohl nichts verlohren.

    hat jemand eine idee???

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •