-         

Ergebnis 1 bis 8 von 8

Thema: BackLED glimmen nur?

  1. #1
    Benutzer Stammmitglied
    Registriert seit
    09.02.2005
    Ort
    Erlangen
    Alter
    32
    Beiträge
    88

    BackLED glimmen nur?

    Anzeige

    Hi,
    gestern hab ich mal angefangen die Odometrie Sensoren durchzutesten.(also nicht die Linienverfolgung)

    Dafür hab ich mir ein kleines Programm geschrieben, das dafür sorgt, das die linke BackLED aufleuchtet, wenn data[0]<700 .
    Klappt eigentlich ganz gut, nur glimmt die LED nur, sie leuchtet nicht?

    Erst wenn ich noch ein SerWrite einfüg leuchtet sie richtig?

    Ist das ein Bug oder mach ich was falsch?

    Hier das Prog:

    Code:
    #include "asuro.h"
    
    int main(void)
    {
    
    
    	unsigned int data[2];
    	Init();
    	
    
    	OdometrieData(data);
    	while(1)
    	{
    	if (data[0]<700)
    	{
    	BackLED(ON,OFF);
    	SerWrite("Test",4);
    	}
    	}
    	return 0;
    }
    Mfg Moebius

  2. #2
    Neuer Benutzer Öfters hier
    Registriert seit
    24.03.2007
    Ort
    Köln
    Alter
    40
    Beiträge
    8
    ich glaube, irgendwo gelesen zu haben, dass Odometrie und BackLEDs nicht gleichzeitig funktionieren.

  3. #3
    Neuer Benutzer Öfters hier
    Registriert seit
    13.05.2007
    Alter
    50
    Beiträge
    13
    Ja, dass habe ich auch gelesen!

  4. #4
    Benutzer Stammmitglied
    Registriert seit
    09.02.2005
    Ort
    Erlangen
    Alter
    32
    Beiträge
    88
    mmh gut zu wissen

    Aus dem Schaltplan wird mir das zwar noch nicht klar, aber zumindest passt mein Programm

    Mfg

  5. #5
    Moderator Robotik Visionär Avatar von radbruch
    Registriert seit
    27.12.2006
    Ort
    Stuttgart
    Alter
    54
    Beiträge
    5.782
    Blog-Einträge
    8
    BackLEDs und Odo-Leds können aus Schaltungsgründen nicht zusammen eingeschaltet sein. Weil OdometrieData() die Odo-Leds automatisch anschaltet, gehen dabei die BackLEDs aus. Durch SerWrite() wird das Ganze etwas verzögert, deshalb haben die BackLEDs mehr Zeit und leuchten heller.

    Übrigens beeinflussen die BackLEDs den Odowert, wenn sie vor der Lesung eingeschaltet sind.

    Gruß

    mic

    Atmel’s products are not intended, authorized, or warranted for use
    as components in applications intended to support or sustain life!

  6. #6
    Moderator Robotik Einstein Avatar von damaltor
    Registriert seit
    28.09.2006
    Ort
    Jena
    Alter
    31
    Beiträge
    3.913
    wirklich? warum? die backleds gehen an, wenn der port als ausgang geschaltet und high gesetzt wird. odo-werte werden gemessen, wenn der port als (analoger) EINGANG gesetzt wird. dadurch geht die led doch aus (bzw flackert wenn man das schnell hintereinander mach, wie moebius). das einzige was einen geringen einfluss nehmen könnte ist doch, dass ein eingang mit gesetztem HIGH-bit im entsprechenden register einen PullUp widerstand zugeschaltet bekommt. aber macht der einen auffälligen unterschied?
    kleinschreibung ist cool!

  7. #7
    Moderator Robotik Visionär Avatar von radbruch
    Registriert seit
    27.12.2006
    Ort
    Stuttgart
    Alter
    54
    Beiträge
    5.782
    Blog-Einträge
    8

    Atmel’s products are not intended, authorized, or warranted for use
    as components in applications intended to support or sustain life!

  8. #8
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    02.07.2004
    Beiträge
    138
    Hallo,

    wie schon gesagt sind Bsck-LED und Odometrie gleichzeitig nicht möglich. Analyse laut Schaltplan (Dokumentation S. 74) sieht so aus:

    Odometrie ein:
    - PD7 ist Output auf +5V, schaltet die Odo- IR-LED D13/D14 ein
    - PC0 und PC1 sind ADC-Eingang für die Fototransistoren T11 und T12
    Dadurch entsteht ein Spannungsteiler von +5V über R18 und T11 zu Masse (bzw. R20 und T12 ..)
    Die Anode der Back-LED liegt dadurch auf +5V, die Kathode über R19 bzw. R21 am Pin PD7 (der ja +5V führt). Die Back-LED können also nicht leuchten!

    Odometrie aus:
    - PD7 ist Eingang, auf 0V
    - PC0 und PC1 sind Ausgang, auf +5V, daher jetzt Back-LED eingeschaltet.

    Ob im ersten Fall zwischen PD7 und +5V durch interne Spannungsabfälle doch eine Spannung für die Back-LED entsteht, so dass sie glimmen, müsste mal nachgemessen werden.

    MfG

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •