-         

Ergebnis 1 bis 7 von 7

Thema: Das leidige Thema: Fusebits; hier: am mega2561

  1. #1
    Benutzer Stammmitglied
    Registriert seit
    17.07.2004
    Alter
    30
    Beiträge
    81

    Das leidige Thema: Fusebits; hier: am mega2561

    Anzeige

    Hallo Leute,

    mal wieder ein Problemchen...
    Nachdem ich alle Probs mit meinem ISP-Adapter aus der Welt geschafft hab hier eine weitere Sache die nicht so funktioniert wie sie es sollte...

    Ich hab die Fusebits eingestellt und zwar so wie hier

    Nur nach dem Programmieren der lFuse mit avrdude reagiert mein Controller nicht mehr.
    Ideen was falsch gelaufen sein könnte?

  2. #2
    Ich wette du hast einen Quarz und keinen Oszillator angeschlossen, gell?

    http://www.roboternetz.de/phpBB2/zei...g.php?p=283117

    Gruß
    zebrafalke
    Kaum macht mans richtig, schon klappts!

  3. #3
    Benutzer Stammmitglied
    Registriert seit
    17.07.2004
    Alter
    30
    Beiträge
    81
    Ja, ich hab einen Quarz angeschlossen. Aber das hab ich genauso wie im Datenblatt beschrieben gemacht.
    Hier ab Seite 40 steht was über einen "Low Power Crystal Oscillator" und da steht auch die Fusebit-Einstellung für eine Taktfrequenz > 8MHz mit CKSEL3:0=1111 und SUT=01.

    Alle anderen Möglichkeiten haben sich für mich irgendwie falsch angehört:
    - Full Swing Crystal Oscillator für Taktsignale in Umgebungen mit vielen Störsignalen: Liegt bei mir nicht vor
    - Low Frequency für niedrige Frequenzen bis 32kHz und internen 128kHz Oscillator, soll bei mir wesentlich höher sein
    - internal RC Oscillator, will ich ja gerade abschalten
    - external Clock, brauch ich nicht da ich ja den Quarz zum laufen bringen will


    Welche Einstellung von CKSEL und SUT ist denn nun für den Quarz geeignet?
    Und reicht es nun vollkommen aus ein Taktsignal an XTAL1 anzulegen um den µC zum laufen zu bringen? (Muss ich dabei den Quarz auslöten?)


    --edit--
    Das hier steht im Datenblatt unter "Low Power Quarz Oscillator":
    Either
    a quartz crystal or a ceramic resonator may be used.

  4. #4
    Erfahrener Benutzer Robotik Visionär Avatar von Hubert.G
    Registriert seit
    14.10.2006
    Ort
    Pasching OÖ
    Beiträge
    6.183
    Könnte es sein das du für die 1 ein Häckchen gesetzt hast?
    Sonst sollte die Einstellung richtig sein.
    Taktsignal reicht, Quarz muss nicht heraus.

    Hubert

  5. #5
    Benutzer Stammmitglied
    Registriert seit
    17.07.2004
    Alter
    30
    Beiträge
    81
    Nein, ich habs zuerst per Hand ausgerechnet und anschließend mit dem Formular oben überprüft und dabei darauf geachtet, dass ich 1 für un- und 0 für programmed benutzt hab.

    Mit dem Takt hat es übrigens funktioniert. Ich hab mit nem m8 das Signal erzeugt und erstmal den Standard-Wert des lFuse wiederhergestellt.

    Könnte es sein, dass das Problem an der Start-up Time liegt? Ich hatte ja mit SUT1:0=01 und CKSEL0=1 das Delay nur auf 14k+0ms gestellt, lt. Datenblatt "Crystal Oscillator, BOD enabled". Allerdings steht das eFuse noch auf Standardwert mit Brown-out Detection disabled.

    Ist es da sinnvoll das "Additional Delay" zu erhöhen (4,1ms oder sogar 65ms)?

  6. #6
    Erfahrener Benutzer Robotik Visionär Avatar von Hubert.G
    Registriert seit
    14.10.2006
    Ort
    Pasching OÖ
    Beiträge
    6.183
    Da hättest du ja schauen können was tatsächlich eingestellt war.
    Ich nwhme immer das max. Delay da es nur bei einem Reset oder im Sleep-Mode zum tragen kommt.
    Probier mal den FullSwingCristallOszillator aus, vielleicht ist der Quarz nicht ganz OK.
    Kondensatoren beim Quarz überprüfen, die können auch Mist machen.
    Hubert

  7. #7
    Benutzer Stammmitglied
    Registriert seit
    17.07.2004
    Alter
    30
    Beiträge
    81
    Also eingestellt war noch der Wert den ich gestern programmiert hatte: 0xDF.

    Ich werd aber mal deinem Rat folgen und die Bauteile checken, hoffe natürlich das es kein HW-Fehler ist

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •