-
        

Ergebnis 1 bis 5 von 5

Thema: AVR910 Programmer Atmega128

  1. #1
    Benutzer Stammmitglied
    Registriert seit
    20.07.2004
    Ort
    Hollabrunn
    Alter
    33
    Beiträge
    85

    AVR910 Programmer Atmega128

    Anzeige

    Hallo da draußen!

    Ich habe ein paar bluetooth Dongles, die das reine SPP
    besitzen. Der Eine ist am Com Port vom PC angeschlossen,
    und der Andere AVR910 Programmer. Nun stellen die zwei
    Dongles eine Verbindung mit 115200 Baud her. Aber dennoch
    erkennt avrdude den Programmer nicht. Der AVR910 ist ebenfalls
    auf die gleiche Baud rate eingestellt.

    Die Anschlußeinstellungen: 115200,8,keine,1,keine auf Com Port 2

    Der AVR910 benötigt ja nur Gnd, Tx und Rx.
    Dennoch funktioniert es nicht.
    Ist mein vorhaben nicht realisierbar?

    Ehrlich gesagt wollte ich mir eigentlich die arbeit mit max232 und Bootloader ersparen.

    PS. Funktionieren tut alles super wenn ich die zwei Dongles entferne.
    Miniaturansichten angehängter Grafiken Miniaturansichten angehängter Grafiken anschluss_213.jpg  

  2. #2
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    22.05.2005
    Ort
    12°29´ O, 48°38´ N
    Alter
    48
    Beiträge
    2.731
    Hallo,
    der Programmierdongle wird keine weiteren Signale brauchen, aber evtl. das Bluetoothmodul.
    Das kann man aber i.d.R. austricksen in dem man die RTS-CTS Leitungen gleich nach dem Dongle auf der AVR-Seite zusammenklemmt.

  3. #3
    Benutzer Stammmitglied
    Registriert seit
    20.07.2004
    Ort
    Hollabrunn
    Alter
    33
    Beiträge
    85
    Hi linux_80

    danke für denn tip aber so hatte ich es ja gemacht
    aber du hast mich halt auf die idee gebracht die die rts-cts und dtr-dsr leitung nicht zusammen zuklemmen. Siehe da es funktioniert

    und schon kommt das nächste problem die datenübertragung von 30250 bytes dauert jetzt bei 115200 baud eine halbe stunde vorher ohne bluetooth 40 sec.

    Kann ich das irgend wie beschleunigen

  4. #4
    Benutzer Stammmitglied
    Registriert seit
    20.07.2004
    Ort
    Hollabrunn
    Alter
    33
    Beiträge
    85
    bevor ich drauf vergiss was für ein linux verwendest du?
    ich persöhnlich bevorzuge ubuntu :P

  5. #5
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    22.05.2005
    Ort
    12°29´ O, 48°38´ N
    Alter
    48
    Beiträge
    2.731
    Ich hatte da mal ein BT-Modul, da ging nix ohne überbrücken.


    Du meinst Linux als Desktop ? Hab ich eigentlich nicht, hab nur einige Server rumstehen, Suse und Debian.
    Zwar hab ich mal ubuntu installiert, aber noch nicht wirklich was gemacht damit.

    Aber irgendeinen Nick braucht man halt

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •