-
        

Ergebnis 1 bis 3 von 3

Thema: Frage zur AD messung Rn-Control

  1. #1

    Frage zur AD messung Rn-Control

    Anzeige

    Hallo erstmal,

    glei vorweg bin noch ein Anfänger auf dem Gebiet, also bitte um Gnade falls die Antwort auf die Frage eigentlich klar sein müsste...

    Also ich hier das RN-Control 1.4 und hab jetzt das Testprogramm raufgespielt (das mit lauflicht usw) wenn das Programm jetzt die AD Ports abfragt kommt außer beim port 6 der ja für die Batteriemessung verwendet wird überall 1023 als adc Wert raus obwohl nichts anliegt.

    Ich habe einfach mal versucht vom + Pol meines Netzteils mit ca. 2 Volt auf einen Port zu gehn und erhofft das dann ca 2 V ausgegeben wird... Brauche ich eine Schaltung vor dem adc port???

    Bin für jede Antwort dankbar

  2. #2
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    22.05.2005
    Ort
    12°29´ O, 48°38´ N
    Alter
    48
    Beiträge
    2.731
    Hallo,

    hast Du Massse (Gnd) auch miteinander verbunden, sonst geht nix.

    Das der 1023 ausgibt wird an dem liegen, das die internen Pullups aktiviert werden.

    Wenn du nur testen willst, kannst Du zB. ein Poti nehmen, und den Mittelabgriff (Schleifer) an den ADC-Eingang legen, die andern beiden jeweils an +5V und an Gnd.
    Grösse mind. 10k, würd ich sagen.

    Sonst braucht man erstmal nix, evtl. einen kleinen (100nF) Kondensator damit die Spannung stabiler ist.

  3. #3
    man man ich i.... ja mit ground funktionierts doch gleich viel besser

    vielen Dank!!!

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •