-
        
+ Antworten
Ergebnis 1 bis 9 von 9

Thema: probleme mit treiber p5driv12.s19

  1. #1
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    02.06.2004
    Ort
    HDN
    Alter
    35
    Beiträge
    102

    probleme mit treiber p5driv12.s19

    Habe ein prog geschrieben wo ich mit fernbediehnung meinen Robby steuern kann und das acs system hindernissen entweicht.
    habe mir jetzt eine be selbergebaut die mit einen 74hct4049 und 8 leds bestückt ist.Dafür habe ich mir den treiber in den µP geladen und die leds gingen wunderbar anzusteuern.
    Wollte jetzt mein altes prog das fur p5driv.s19 geschrieben würde aufrüsten und habe alle definitionen übernommen und jetzt geht garnichts mehr auser das die leds blinken.

    HILFE HILFE sind die treiber so verschieden???
    Das prog poste ich mal lieber
    Angehängte Dateien Angehängte Dateien

  2. #2
    Erfahrener Benutzer Robotik Einstein Avatar von Dirk
    Registriert seit
    30.04.2004
    Ort
    NRW
    Beiträge
    3.788

    Definitionen für P5DRIV12.s19

    Hallo Smi,

    für den P5DRIV12.s19 gelten teilweise andere Einsprungadressen für die Systemroutinen als beim P5DRIV.s19:
    '--- SYSTEMROUTINEN -----------
    define PLM_SLOW &H01C2
    define SYSTEM &H01C7
    define LED_DRIVE &H01CA
    define COMNAV &H0144
    '- ERWEITERTE SYSTEM ROUTINEN -
    define REVR &H0101 'ANTRIEB RECHTS RÜCKWÄRTS
    define REVL &H0106 'ANTRIEB LINKS RÜCKWÄRTS
    define FWDR &H010B 'ANTRIEG RECHTS VORWÄRTS
    define FWDL &H0110 'ANTRIEB LINKS VORWÄRTS
    define ROTR &H0115 'RECHTS DREHEN
    define ROTL &H0119 'LINKS DREHEN
    define REV &H011D 'RÜCKWÄRTS
    define FWD &H0121 'VORWÄRTS
    define COMNAV_STATUS &H0125 'UPDATED ALLE FLAGS IM STATUS-REGISTER
    define ACS_LO &H01E0 'ACS POWER LO
    define ACS_HI &H01E8 '
    define ACS_MAX &H01F0 '
    define SEND_TLM &H013A 'SENDET TELEMETRIE (CH=HBYTE, DATEN=LBYTE)
    define SEND_SYSSTAT &H0134 'SENDET TLM KANAL 0, SYSTEM STATUS
    '(FLAGS für ACS, FWD/REV, ACS_LO/HI/MAX)

    Außerdem fallen 2 Systemroutinen ganz weg: SEND_SPEEDR und SEND_SPEEDL.

    Gruß Dirk

    P.S.: Zu Deinem Prog: Gefällt mir gut!
    Kleiner Hinweis: Wenn Du z.B. ACSL_F testest, dann geht das mit "if ACSL_F then ..." statt "if (ACSL_F=on) then ...". Die negative Bedingung sieht dann so aus: "if not ACSL_F then ..."
    (Aber natürlich funktioniert Dein Prog so wie Du es gemacht hast auch!)

  3. #3
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    02.06.2004
    Ort
    HDN
    Alter
    35
    Beiträge
    102
    Eh tausen danke es lebt wieder und zuckelt durch die bude. =D>
    Ich fitze mich ersi inassambler rein und hab das garnicht mittbekommen das sich die adressen ändern

    Ach so byte 6 überschneidet sich noch im prog ansonsten noch viel spaß damit.

    kann man eigentlich die 2 offenen ports des 74hct4049 9 und 10
    die von der mainunit fur das acs system verwendet werden auch noch nutzen oder braucht mann erst einen neuen treiber
    dachte so an bit 49 und 50???

    Ach ja hab probleme beim prog mit hi max umschalten das get im tutorial irgendwie besser?? noch paar verbesserungsvorschläge

  4. #4
    Neuer Benutzer Öfters hier
    Registriert seit
    15.08.2005
    Beiträge
    12

    Benötigen Treiber p5driv.s19

    Hallo,

    wir probieren gerade unseren Roboter mit Hilfe der Fernsteuerung zu bewegen. Wir benötigen dafür jedoch den Treiber p5driv.s19.

    Leider haben wir den weder auf der Installations-CD noch im Internet gefunden.

    Kann uns den jemand zur Verfügung stellen???

    DANKE!!!!

  5. #5
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    07.03.2004
    Beiträge
    127
    @Spielkind

    Den Treiber findest du hier:
    http://www.arexx.com/downloads/rp5/en/P5DRIV.asm.txt

    mfg blizzard

  6. #6
    Neuer Benutzer Öfters hier
    Registriert seit
    15.08.2005
    Beiträge
    12
    @ Blizzard

    Vielen Dank! Hoffe, dass funktioniert jetzt alles...

    Gruß
    Spielkind

  7. #7
    Neuer Benutzer Öfters hier
    Registriert seit
    15.08.2005
    Beiträge
    12
    Habe gerade festgestellt, dass ich mich heute Vormittag verschrieben habe. Ich benötige den Treiber

    p5driv12.s19

    Entschuldigung Blizzard!
    Kannst Du mir dafür vielleicht dafür auch einen Link schreiben???

    Vielen, vielen Dank
    Spielkind

  8. #8
    Erfahrener Benutzer Robotik Einstein Avatar von Dirk
    Registriert seit
    30.04.2004
    Ort
    NRW
    Beiträge
    3.788

    Treiber

    Hallo Spielkind,

    hier ist der Treiber! Du must nur .txt entfernen.

    Gruß Dirk
    Angehängte Dateien Angehängte Dateien

  9. #9
    Neuer Benutzer Öfters hier
    Registriert seit
    15.08.2005
    Beiträge
    12
    Hallo Dirk,

    vielen Dank. Dann kann ich jetzt ja loslegen!

    Gruß
    Spielkind

+ Antworten

Berechtigungen

  • Neue Themen erstellen: Ja
  • Themen beantworten: Ja
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •