-
        

Ergebnis 1 bis 4 von 4

Thema: INT0 und INT1 ansteuern, Problem: nehmen sehr viel Strom auf

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    25.02.2006
    Beiträge
    13

    INT0 und INT1 ansteuern, Problem: nehmen sehr viel Strom auf

    Anzeige

    Ich will die externen Interupts an meinem mega32 (rncontrol) ansteuern.

    Das funktioniert auch einzeln ganz gut.

    Momentan nutze ich noch einen internen Timer zu Testzwecken (später will ich einen externen Timerbaustein nehmen ...). Mit dem Timer 0 wird
    der PINB3(gezaehlt ab 0)/OC0 angesteuert.

    INT0 (PIND2) soll auf die fallende Flanke reagieren.
    INT1 (PIND3) soll auf die steigende Flanke reagieren.

    Einzeln funktioniert alles prima. Nur wenn ich beide von PINB3 treiben lassen will, bricht die Spannung total zusammen.

    Mit nur einem Interupt verbunden messe auch nur noch die Hälfte der erwarteten Spannung. Geht aber noch.
    Der INT-Eingang nimmt dann 35 mA auf (möglicherweise noch mehr, da ich nur den Mittelwert/Effektivwert o. so ähnlich messe).

    Das Signal aufzufrischen mit einem alten 7407 Open-Collector-Treiber bringt es auch nicht, der schafft auch nur 40 mA nach unten zu ziehen.

    Hat jemand eine Idee wie man einfach (ohne viel Aufwand) die geforderte Leistung zur Verfügung stellen kann.

    Oder habe ich etwas falsch gemacht? Der Strom kommt mir etwas hoch vor.

    Thanx
    Maikel

  2. #2
    Erfahrener Benutzer Robotik Visionär Avatar von Hubert.G
    Registriert seit
    14.10.2006
    Ort
    Pasching OÖ
    Beiträge
    6.183
    Ich denke da hast du was falsch gemacht, die Eingänge sind hochohmig, es sei denn du hast sie als Ausgang geschaltet, dann liegen sie auf + oder GND.

    Hubert

  3. #3
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    22.05.2005
    Ort
    12°29´ O, 48°38´ N
    Alter
    48
    Beiträge
    2.731
    Mach einfach einen Widerstand dazwischen, denn wenn der Ausgang mit einem Eingang verbunden wird, ist das so wie ein Kurzschluss, und es fliesst der max. Strom den der AVR hergibt.

  4. #4
    Neuer Benutzer Öfters hier
    Registriert seit
    25.02.2006
    Beiträge
    13
    wie immer: der Fehler sitzt meist vorm Computer

    Ich hatte vergessen, die PINs als Eingang zuschalten. Der hohe Strom hatte mich eigentlich misstrauisch machen sollen ...

    Thanx

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •