-         

Ergebnis 1 bis 8 von 8

Thema: Problem mit Taktgenerierung (NE555)

  1. #1
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    07.03.2004
    Beiträge
    127

    Problem mit Taktgenerierung (NE555)

    Anzeige

    Hi,

    Hab folgende Schaltung auf einer Lochrasterplatine aufgebaut, um mit einer IR-Diode ein modoliertes Signal abzustrahlen: http://www.the-starbearer.de/Roboter...-Oszilator.jpg
    Der NE555 gibt aber kein Signal aus (Pin mit Voltmeter gemessen und IR-Diode mit Handykamera auf IR Licht überprüft). Solche "Ferndiagnosen" sind zwar schwierig, vielleicht kann mir aber drotzdem jemand einen Tip für die Fehlersuche geben?

    mfg Blizzard

  2. #2
    Erfahrener Benutzer Robotik Visionär Avatar von Hubert.G
    Registriert seit
    14.10.2006
    Ort
    Pasching OÖ
    Beiträge
    6.183
    Bei der Schaltung fehlt mir was, schau mal hier www.domnick-elektronik.de/elek555.htm

  3. #3
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    07.03.2004
    Beiträge
    127
    Bitte etwas genauer. Bin noch nicht der große Elektronikprofi
    mfg Blizzard

    Edit: Auf starbearer.de wird genau diese Schaltung verwendet und hat auch so funktioniert. Die Schaltung dürfte also stimmen?

    mfg blizzard

  4. #4
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    07.12.2005
    Ort
    Euskirchen-Großbüllesheim
    Alter
    67
    Beiträge
    2.063
    In der Schaltung von the-starbearer.de sind die Pins 5 und 6 nicht angeschlossen; die Schaltung kann so nicht funktionieren.
    Schau mal im Link vom domnick-elektronik (kalledom) die Schaltung "Der 555 als astabile Kippstufe / Multivibrator", die funktioniert.
    MfG Karl-Heinz
    HobbyElektronik hier klicken ....

  5. #5
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    07.03.2004
    Beiträge
    127
    Stimmt. Pin 6 und 7 sind nicht angeschlossen. Welche Werte benötige ich denn für eine Frequenz von 38 kHz (verwende einen TSOP 173? Und wofür ist das Potentiometer in der Schaltung von the-starbearer.de, wenn nicht zur Frequenzeinstellung?

    mfg Blizzard

  6. #6
    Erfahrener Benutzer Robotik Visionär Avatar von Hubert.G
    Registriert seit
    14.10.2006
    Ort
    Pasching OÖ
    Beiträge
    6.183
    Nach der Schaltung von domnik R1 4k7, P2 20k, R2 4k7, C1 1n, der Rest wie in der Schaltung.

  7. #7
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    07.03.2004
    Beiträge
    127
    Danke erstmal.
    Für P2 hab ich jetzt einen 10k Widerstand + 4,7k Widerstand + 5k Poti verwendet und komm damit auf (gemessene) 19k. Das dürfte so passen? Für Reset hab ich den 100 Ohm Widerstand drinnen gelassen. Dürfte auch keine Rolle spielen. Für C2 hatte ich nur noch einen 1n Kondensator. Könnte der, der Grund dafür sein das die Schaltung immer noch nicht richtig funktioniert? Mit der Kamera erkennt man zwar das die IR Diode jetzt leuchtet, aber anscheinend nicht mit der richtigen Frequenz. Der TSOP zeigt nämlich keine Reaktion.

    mfg Blizzard

  8. #8
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    07.12.2005
    Ort
    Euskirchen-Großbüllesheim
    Alter
    67
    Beiträge
    2.063
    38kHz sind 1/38.000 = 0,000026s => 0,026ms => 26µs.
    Die Timer-Zeit in Sekunden errechnet sich aus R(MOhm) * C(µF) * 1,28.
    Für Zeiten in µs könnte mit R in kOhm und C in nF gerechnet werden.
    26µs für 38kHz ergibt sich aus 13µs Ladezeit plus 13µs Entladezeit des 555.
    Dann wäre mit C=1nF der Widerstand R = 13µs / (1,28 * 1nF) = 10,15625kOhm
    R1 würde ich auf 1k lassen, C1 = 1nF, P2 = 5k und R2 = 8,2k; damit ist die Zeit von 8,2k (10,5µs * 2 => 47,6kHz) bis 8,2+5=13,2k (16,9µs * 2 = 29,6kHz) regelbar.
    Edit: Den PullUp-Widerstand für Reset wähle bitte zwischen 1...10kOhm; es ist bei den Nicht-CMOS-Typen des 555 die Basis eines internen Transistors, dessen Emitter an GND angeschlossen ist. Bei 100 Ohm fließt etwas sehr viel Basisstrom.
    MfG Karl-Heinz
    HobbyElektronik hier klicken ....

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •