-         

Ergebnis 1 bis 4 von 4

Thema: AVR nicht mehr autonom sobald programmer ab

  1. #1
    Benutzer Stammmitglied
    Registriert seit
    06.08.2006
    Beiträge
    41

    AVR nicht mehr autonom sobald programmer ab

    Anzeige

    Hallo,
    mein atmega32 läuft nicht mehr autonom sobald ich den AVRISP MK II Programmer abnehme. Heißt also ich kann eine led blinken lassen, solange der Programmer über den ISP stecker verbunden ist. Wenn ich ihn abnehme läuft nichts mehr. Sobald er wieder dran hängt läuft auch wieder alles, ohne neu zu flashen. Kennt jemand dieses Problem??
    Getting VTARGET.. 4.2V .. OK

  2. #2
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    06.02.2005
    Ort
    Hamburg
    Alter
    31
    Beiträge
    4.255
    Wie ist der Reset beschaltet? Betriebsspannung in Ordnung?

  3. #3
    Benutzer Stammmitglied
    Registriert seit
    06.08.2006
    Beiträge
    41
    Der Reset ist ohne pullup und ohne irgendeinen kondensator direkt mit dem Programmer verbunden. Hab meine schaltungen bisher immer so gebaut und das board mit dem ich grad arbeite lief wochen lang ohne probleme, das kanns irgendwie nicht sein. Aber der Programmer "fasst" den reset pin ja eh nur beim flashen an, das kanns nicht sein. Die spannung liegt bei 4,2V, kommt direkt aus 3 AAA batterien, da mein Spannungsregler auf dem board kaputt gegangen ist.

  4. #4
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    06.02.2005
    Ort
    Hamburg
    Alter
    31
    Beiträge
    4.255
    Wie ist die Brown-Out Detection eingestellt? Es könnte sein, das sie auf 4,5V steht, und der ISP per USB 5V draufgibt...

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •