-
        

Ergebnis 1 bis 4 von 4

Thema: Problem mit Fahrtregler-Servo-Ansteuerung

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    28.03.2007
    Beiträge
    5

    Problem mit Fahrtregler-Servo-Ansteuerung

    Anzeige

    Ich habe an eine RN-Control einen Servo und einen Fahrtregler angeschlossen. Die Werte (Ausschlag) werden über UART dem mega32 mitgeteilt (mit ON URXC, Programmierung mit BASCOM).
    Sind 2 Servos oder die Kombi ohne Motor betrieben, funktioniert alles tadellos. Schließe ich einen Motor an so reagiert das Servo nur bei Nullstellung oder Vollgas des Fahrtreglers. Manchmal spielt das Servo bei zB 20%-Ausschlag des Fahrtreglers völlig verrrückt bzw nimmt irgendwelche Werte an.
    Alles hängt an einem 12V Bleiakku. Motor (Kühlermotor ausm Auto) ist entstört (3 Kondensatoren).

    Woran kann das liegen? Ist der Motor nicht genügend entstört (Kapazität erhöhen, Feritkern?) oder liegt es vielleicht am Fahrtregler?

  2. #2
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    11.09.2004
    Ort
    Düsseldorf
    Beiträge
    3.948
    Hmmmm,schwer zu sagen aber ich Vermute mal das der Motor die Versorgung der Schaltung stört.
    Ein Oskar könnte jetzt wunderbar Auskunft geben aber ich vermute stark das steht nicht zur Verfügung.

    Vieleicht sollte ich doch nochmal den "Preiswerten einfachen Selbstbau-Spikedetektor" in Angriff nehmen.
    Das Problem taucht ja ständig auf.
    Gruß
    Ratber

  3. #3
    Neuer Benutzer Öfters hier
    Registriert seit
    28.03.2007
    Beiträge
    5
    Hmm, ich habe jetzt noch weiter experimentiert. Diverse Teilsysteme mit verschiedenen Akkus gespeist und siehe da, wenn der Fahrtregler mit einem eigenen Akku betrieben wird (ein Massepotential), dann treten die Probleme nur noch sehr geringfügig auf -> Der Servo zuckt teilweise nur noch kurz wenn er verstellt wird. Sonst scheint alles iO.
    Kann das nicht auch mit dem Fahrtregler zusammenhängen? Immerhin erzeugt der ja ein PWM-Signal mir mehreren kHz.
    Kann man das System evtl mit weiteren Elementen wie Kondensatoren oder Feritkernen/ringen noch besser entstören? Wenn ja welche und wo?

  4. #4
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    11.09.2004
    Ort
    Düsseldorf
    Beiträge
    3.948
    Ja,es ist offensichtlich das der Leistungsteil für die Störungen verantwortlich ist und das die Versorgung der Komponennten kaum Entstöhrmaßnahmen besitzen (Annahme)

    Die möglichen Maßnahmen hats du ja schon genannt.

    Primär sind da drei Punkte die immer wieder auffallen.

    Spannungsversorgngen von Leistungs- und Steuerteilen möglichst früh hinter der Energiequelle trennen.
    Den Motorstrom mitten durch die Steuerschaltung zu treiben ist so Sinvoll wie eine Nervenklinik direkt in der Einflugschneise des Frankfurter Flughafens.

    Da der Steuerteil in der Regel mit wesentlich weniger Energie betrieben wird als der Leistungsteil kann man diesen recht einfach entstören.

    Stützelkos für Anlaufströme und verschiedene Kerkos (50,100,200nF Je nach Fall) für die Spikes sind meist schon sehr hilfreich.
    Der Spannungsregler erledigt dann schon fast alleine den Rest.
    Eine Induktivität in der Zuleitung (zb. 10µH.Wert ist auch hier Fallabhängig) ) bringt weitere Linderung.

    Datenleitungen ,auch höherfrequente,sollte man besser Schützen.
    Einige pF und ein kleiner Widerstand nebst Feritperle wirken manchmal wahre Wunder.
    Gerade eine Servoleitung (Die Leitung zum Fahrtregler ist das Gleiche) ist ja oft länger und wirkt damit wie eine Antenne die jeden Dreck aufnimmt.
    Hier ist eine Geschickte Verlegung,Ferite,Kondensatoren und ggf. eine Schirmung fällig.

    Dann der Leistungsteil der ja der Verursacher ist.
    Hier gilt das Gleiche.
    Besonders Induktive Verbraucher sollten gut entstört sein.(Auch bürstenlose Motoren "Senden" etwas)
    Ein guter Stützelko (Statt einem Großen lieber mehrere kleine mit guten ESR-Eigenschaften.Beispiel siehe PC-Mainboard am CPU-Sockel).direkt vor dem Fahrtregler macht Sinn.

    Dazu sollten die Versorgungsleitungen entsprechend dem Strom (Impulsströme nicht vergessen) dimensioniert sein.
    Lieber zu dicke Kabel als zu dünne,das mindert den Spannungsabfall und damit die Störamplituden.

    Ein Besonderer Punkt in der Versorgung ist die Bezugsmasse.
    Da man bei der Bastelei nur selten den Steuer- vom Lastkreis trennt steckt man in der Zwickmühle denn die Signale sind Massebezogen also darf man kein "Spinnennetz" bauen weils sonst zu schwingen anfangen kann aber eine Punktförmige Anbindung bringt oft zuviel Störungen.
    Deswegen der Filteraufwand den ich beschrieben habe.

    Wie gesagt ist das alles ziemlich Fallabhängig also lasse ich mich nicht festnageln.
    Experimentier einwenig.
    Gruß
    Ratber

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •