-         

Ergebnis 1 bis 5 von 5

Thema: RN-KeyLCD Tastatur

  1. #1
    Benutzer Stammmitglied
    Registriert seit
    28.04.2004
    Ort
    Himmelstadt
    Alter
    29
    Beiträge
    80

    RN-KeyLCD Tastatur

    Anzeige

    Moin,

    ich habe mal wieder ein Problem mit dem RN-KeyLCD. Diesmal betrifft es die Tastatur. Das Ding reagiert nicht mehr darauf, wenn ich eine Taste drücke, betroffen sind alle Tasten.
    Normal ertönt ja ein kurzer Ton bei einem Tastendruck, doch der Summer bleibt still (der Summer funktioniert, beim Einschalten spielt er Töne ab).
    Per 1 & 3 müsste ich bspw. ins Einstellungsmenü kommen, aber es tut sich gar nichts.

    Ich kann auch keine Tastenabfrage per I2C mehr machen. Wenn ich eine Anfrage sende, sendet mir das KexLCD nicht mal mehr eine 0, sondern gar nichts mehr, auch keine Bestätigung, weswegen anchfolgende Befehle im Programm auch nicht mehr ausgeführt werden (Der I2C Befehl wartet ja noch in einer Schleife auf eine Bestätigung).

    Das LCD funktioniert, ich kann hier auch Texte anzeigen lassen.

    Die Tastatur an sich scheint zu funktionieren, beim Tastendruck werden nämlich die Kontakte überbrückt. Die Tastatur steckt auch korrekt drin.

    Woran kann das liegen? Sind die Pins des µC kaputt? Kann die Firmware teilweise gelöscht sein?

    Danke

  2. #2
    Benutzer Stammmitglied
    Registriert seit
    28.04.2004
    Ort
    Himmelstadt
    Alter
    29
    Beiträge
    80
    Inzwischen hat sich noch eweng was geändert, es geht noch weniger, bzw gar nichts mehr.
    Wird das RN-KeyLCD mit Strom versorgt, dann zeigt jedes "LCD-Feld" nur noch eine weiße Fläche (auch wenn der Kontrast ganz runtergedreht ist) und unabhängig ob die Stromversorgung über I2C oder extern (7,2V) erfolgt. Es spielt dabei auch keine Rolle, ob der ATmega8 eingesteckt ist oder nicht.
    Ist dieser allerdings eingesteckt, erwärmt er sich sehr stark. Es ertönt auch keine Beep mehr wenn das RN-KeyLCD angeschalten wird.

    Die Spannung am Atmega8 beträgt 5V, egal wie "bestromt" wird (direkt an den Pins gemessen).

    Was ist hier faul? Ist der ATmega8 vllt hinüber?

  3. #3
    Administrator Robotik Einstein Avatar von Frank
    Registriert seit
    30.10.2003
    Beiträge
    4.989
    Blog-Einträge
    1
    Nun da scheint irgendwas mit dem Aufbau nicht in Ordung. Nur schwierig zu sagen worans liegt. Du musst wohl die ganze Schaltung und Lötpunkte nochmal checken. Da COntroller bei dir heiß geworden ist, ist dieser vermutlich auch hinüber. Den kannst du nachbestellen, aber du solltest vorher die Ursache für die Probleme suchen.
    Versorgen solltets du es nur über die Schraubklemmen, da sist günstige rals über I2C Kabel da Strom doch etwas höher ist.

  4. #4
    Benutzer Stammmitglied
    Registriert seit
    28.04.2004
    Ort
    Himmelstadt
    Alter
    29
    Beiträge
    80
    Nachdem ich mir jetzt nen neuen Controller gekauft hab, bei dem das gleiche passiert, konnte ich das LCD als Ursache ausmachen. Mit ausgestecktem Display wird nämlich nichts mehr heiß.
    Wie gesagt wird des Display weiß bei angelegter Spannung, es sieht auch weng so aus als würden sich am Rand mancher Anzeigenblöcke Franzen nach innen rein bilden.
    Ich denke also das hier ein Defekt vorliegt. Hatte das jemand schonmal und konnte es reparieren? Es handelt sich um das LCD 204BL-4 DIP von Reichelt.
    Ich hab auch schon vorsucht, die schwarze Verkleidung vorsichtig zu entfernen, ich seh jedoch keine Bauteile, die einen äußeren Defekt zeigen.

    Danke

  5. #5
    Benutzer Stammmitglied
    Registriert seit
    28.04.2004
    Ort
    Himmelstadt
    Alter
    29
    Beiträge
    80
    Kann mir dann vllt wenigsten einer sagen, wie ich herrausfinden kann, ob das Displaymodul defekt ist?
    Was für Ursachen gibt, dass sich der µC überhitzt? Die Spannung an Vcc und Gnd passt. Was gibt es noch an Möglichkeiten?

    Auch am Display passt die Spannung an Vcc, Gnd und Vee (Kontrast).

    Ich wäre über Hilfe sehr dankbar, weil ich nicht unnötig Geld für ein neues Display ausgeben möchte.

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •