-         

Ergebnis 1 bis 3 von 3

Thema: Frage zum AVRStudio 4.13 Simulator

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    21.01.2007
    Ort
    Gemeinlebarn, Niederösterreich
    Alter
    48
    Beiträge
    12

    Frage zum AVRStudio 4.13 Simulator

    Anzeige

    Hallo!

    Ich bin nun von VMLAB auf AVRStudio 4.13.528 umgestiegen! Ich verwende die Debugblattform AVR Simulator. Leider muss ich feststellen, dass der Simulator immer mit 4Mhz Taktfrequenz arbeitet. (Prozessor-View =Frequenz 4.000MHz)! Obwohl die richtige Frequenz in den Compiler Optionen eingetragen und auch über Make richtig verarbeitet wurde, ignoriert der Simulator diese Taktfrequenz. Delayzeiten bzw. Timer Interruptzeiten sind somit in der Stoppuhr falsch interpretiert! Ich finde keine Möglichkeit die 4MHz zu ändern!
    Arbeitet der Simulator womöglich nur mit 4MHz und man muss das Testprogramm erst mit 4MHz compilieren , dann testen und bei Erfolg das Programm mit der richtigen Taktfrequenz der Hardware erneut compilieren?
    Wer hat dafür eine Lösung?

  2. #2
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    10.02.2005
    Ort
    eastside, L.E.
    Alter
    46
    Beiträge
    104
    Hi, ich mach zwar nur Assambler, aber das wird schon in C das selbe sein.

    Die Frequenz des Simulators kannst / mußt Du über einen Menüpunkt einstellen, allerdings geht das erst, wenn Du eine Simulation laufen hast.

    "Debug" ->"AVR Simulator Options"

    greetz Rajko

  3. #3
    Neuer Benutzer Öfters hier
    Registriert seit
    21.01.2007
    Ort
    Gemeinlebarn, Niederösterreich
    Alter
    48
    Beiträge
    12
    Hallo!

    Danke für die Info! Klappt jetzt einwandfrei! Ich hatte alle Menüoptionen abgeklappert, aber immer vor dem Start der Simulation! Da war eben nur der Menüpunkt "Debugplattform und Device" zum wählen.
    Na ja ...man lernt eben nie aus!

    Vielen Dank nochmal!

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •