-         

Ergebnis 1 bis 4 von 4

Thema: RN-LCD-Adapter an RN-Control - kann Display nicht ansteuern

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    13.02.2007
    Beiträge
    7

    RN-LCD-Adapter an RN-Control - kann Display nicht ansteuern

    Anzeige

    Habe gerade den RN-LCD-Adapter und LCD 20x4 von robothardware zusammengebaut und versuche das Display mit Bascom anzusteuern. Ich habe alle Ports versucht, glaube aber B wäre richtig. Das mitgelieferte Testprogramm für den LCD-Adapter ist für RN-Mega128Funk geschrieben.
    Ich habe versucht es auf RN-Control 1.4 Mega 32 umzuschreiben, aber als Neuling im Programmieren bekomme ich das bislang nicht gebacken.
    Kann mir jemand einen Hinweis / Listing geben, so dass ich damit weiterkomme. Mein Ziel ist es bei einem Tastendruck einen Text erscheinen zu lassen.
    Danke
    Heinz-Jürgen

  2. #2
    Benutzer Stammmitglied
    Registriert seit
    05.03.2005
    Beiträge
    36

    Kleine Lösungshilfe

    Hallo Heinz-Jürgen,

    ich habe das Bähscom-Programm für RN-Control und das Robotikhardware Display angepasst (als Attachment zum Beitrag).

    Bei mir hat es funktioniert. Ich benutze Port B, deswegen die Pinb Änderung im Code und ausserdem wurde der Ganze andere Funk- und UART-Teil rausgeschmissen.

    Viel Glück damit.


    Banzai
    Angehängte Dateien Angehängte Dateien

  3. #3
    Neuer Benutzer Öfters hier
    Registriert seit
    13.02.2007
    Beiträge
    7
    Hallo Banzai,

    Danke für die prompte Antwort. Nachdem ich Dein Programm geladen hatte und es immer noch nicht ging - alle Segmente waren angesteuert, habe ich das Verbindungskabel gegen ein anderes ausgetauscht.
    Und was soll man sagen - es geht. Puh... also nicht immer liegt es an den Programmierkünsten - manchmal ist es ein "dummer" Fehler

    Heinz-Jürgen

  4. #4
    Glacier
    Gast
    Also mein LCD funktioniert leider auch nicht.

    Wenn ich messe liegt spannung an. Aber weder derhen am Wiederstand noch tausch des Kabels brigen besserung.

    Wie kann ich testen woran es liegen kann ?

    /Glacier

    Edit: Der fehler ist, das ich das falsche LCD habe. Ich habe ein PLCD mit 2x16 geschickt bekommen und kein normales mit 2x40 Zeichen.. Naja.. Also darf dieser Post ignoriert werden

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •