-
        

Ergebnis 1 bis 4 von 4

Thema: Schritmotor mit L6208 ansteuern

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    23.09.2006
    Ort
    Feldkirch
    Alter
    32
    Beiträge
    14

    Schritmotor mit L6208 ansteuern

    Anzeige

    habidere leute,

    ich versuch einen Schrittmotor mit dem L6208 anzusteuern. ich habe die schaltung aus dem datenblatt aufgebaut (auf Bauteilwerte gleich) und an einen MC gehängt. Ich weiss jetzt nicht wie ich denn IC richtig ansteuern soll. Die Vref hab ich so eingestellt, dass ein Strom von 0,5A pro Wicklung fliesst.

    ich habs mal so probiert:
    CTRL = High
    CW/CCW = High
    H/F = High
    und am CLK hab ich 50hz dran

    wenn ich den Schrittmotor dranhänge, pfeift der nur.

    ich weiss nicht wo der Fehler liegt, in der Schaltung oder in der Software

    sg relaxxo

  2. #2
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    01.03.2007
    Ort
    Kornwestheim (kWh)
    Beiträge
    1.118
    HI
    Also 50 Hz sind schon ein bisschen viel, kann sein, dass dein armer motor da einfach nicht mehr hinterherkommt. Probier mal obs mit 1Hz oder per entprelltem Taster am CLK-Eingang funktioniert, dann weißt du wenigstens, obs funktioniert.

    Wenn das nicht geht, probier mal, obs was bringt, wenn du Control auf LOW legst. Denn durch CTRL=High klingt der Motorstrom langsam ab, vlt ist das das problem. (oder wars so nur beim L297???)

    AlKi

  3. #3
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    06.11.2006
    Beiträge
    1.078
    Hallo
    beim 1,8° Motor und Halbschritt sind 50Hz gerade 7,5u/min.
    Das Pfeifen kommt wahrscheinlich vom Chopper.
    ich weiss nicht wo der Fehler liegt, in der Schaltung oder in der Software
    Das weiß ich auch nicht.
    Mit freundlichen Grüßen
    Benno
    Wo man nicht mit Vernunft handelt, da ist auch Eifer nichts nütze; und wer hastig läuft, der tritt fehl.
    Ein König richtet das Land auf durchs Recht; wer aber viel Steuern erhebt, richtet es zugrunde

  4. #4
    Benutzer Stammmitglied
    Registriert seit
    26.01.2007
    Ort
    Boppard
    Alter
    46
    Beiträge
    81
    Hallo..

    Hab zwar die Schaltung mit dem L297/298 aber das gleiche Problem wenn ich Vref zu nidrig eingestellt hab.

    evtl. hilfts

    Gruß Babylon
    VOLT WATT AMPERE OHM - Ohne uns gibts keinen Strom

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •