-         

Ergebnis 1 bis 5 von 5

Thema: K8055D USB Schnittstellenkarte von Conrad Elektronik

  1. #1
    Benutzer Stammmitglied
    Registriert seit
    02.03.2007
    Alter
    39
    Beiträge
    84

    K8055D USB Schnittstellenkarte von Conrad Elektronik

    Anzeige

    Hallo,

    ich habe ein Problem mit meiner Interfacekarte und hoffe das mir einer von Euch helfen kann.Zunächst mal zur Karte.Diese welche habe ich von Vellemann (Conrad Katalog)
    Zudem ist dort eine .dll Datei mit dazu.
    Digitale Ausgänge,Analoge Ausgänge setzen und benutzen via VB Programm ist kein Problem.Wo wir beim Wort wären(Problem).Ich möchte an besagter Karte Servos steuern (Modellbau-Servos) aber Schrittmotoren.Wobei mir zweiters lieber wäre.Am Analogen Ausgang den Servo zu steuern geht das auch mit einem Servo-Tester der aus der Spannung durch ein Poti Impulse generiert die mit einer Länge von 15ms im Bereich von 0,8 -2,2 ms liegen.Nur funktioniert es nicht einwandfrei da das Servo zu unruhig ist.Was komisch ist:Wenn ich den Poti zwischen Analog Ausgang und Servotester schalte ,Ausgangsspannung 100%und das Poti zum steuern benutze geht das auch ohne Probleme.
    Ich denke das das einstellen der Spannung über das Poti anders geht als wenn ich anstatt des Poti's den Ausgang benutze.Mit Poti arbeitet der Servo weicher und fährt auch einen größeren Bereich an.Mit der Analogen Ansteuerung von der Karte zittert er wie verrückt obwohl die Karte nichts anderes macht als das Poti.Spannungstechnisch.
    Spannungsbereich Poti = ca.4,5V - 5,6V (Arbeitsbereich)
    Spannungsbereich Karte = 0-5V generell,per VB 3,8 - 4,7V (Value)

    Nun...
    Da der PWM Ausgang auch so etwas kann(Impulse erzeugen) dachte ich mir könnte ich es mit dem PWM Ausgang versuchen.Davon hat die Karte nämlich zwei.
    Tja und da liegt mein Problem.Ich weiß nicht wie!Wer kann mir helfen?

    Würde auch mal die dll mit anhängen, wenn es was nützt.Evtl. auch die Declare Anweisungen die zur dll dazu waren.

    Würde mich riesig über Antwort freuen




    Gruß
    Maik

  2. #2
    Erfahrener Benutzer Roboter Genie Avatar von robocat
    Registriert seit
    18.07.2006
    Beiträge
    935
    der pwm ausgang ist dafür nicht brauchbar, weil er, soweit ich weiß, mit 23,43kHz getaktet sind. (servos wollen 50Hz).
    ich habe zum servo ansteuern diese schaltung verwendet:

    das servogezappel hatte ich auch, exakt das verhalten, das du beschreibst. das board landete damals irgendwann in einer schublade, und wurde seitdem nicht mehr verwendet. fehlkauf.

    Schrittmotoren ansteuern sollte gehen, entweder mit der kombi l297/l298 oder nur l298. guck mail in die Wiki unter motoren->schrittmotoren. ich würde dazu enable des l298 an den pwm ausgang hängen und die 2 motorbrücken an 4 digitalausgänge. am besten zur versorgung des motors nicht die 5V vom board verwenden, 500mA sind schnell überschritten, was dich deinen usb-port kosten kann.

    die dll besser nicht posten, um ärger mit velleman zu vermeiden.

    gruesse

  3. #3
    Benutzer Stammmitglied
    Registriert seit
    02.03.2007
    Alter
    39
    Beiträge
    84
    Danke Dir für Deine Auskunft.Werd mal das versuchen was Du mir geraten hast.

    Werd mich dann wenn ich es probiert hab wieder dazu melden.

    Ach ja eins noch, wie muß ich denn dann den PWM Ausgang der Karte setzen?Oder laüft der Parallel mit dem jeweiligen Analogen Ausgang mit?



    Gruß
    Maik

  4. #4
    Erfahrener Benutzer Roboter Genie Avatar von robocat
    Registriert seit
    18.07.2006
    Beiträge
    935
    ja, soweit ich weiss laufen beide parallel. hier ein thread der evtl hilft:
    http://www.roboternetz.de/phpBB2/zei...ag.php?t=17653

    gruesse

  5. #5
    Benutzer Stammmitglied
    Registriert seit
    02.03.2007
    Alter
    39
    Beiträge
    84
    Vielen Dank hat mir sehr geholfen.

    Beide Ausgänge laufen also parallel mit.
    So, na denn Schrittmotor Steuerung bestellt (schon erledigt im Shop) und probiert und [-o<


    Gruß
    Maik

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •