-         

Ergebnis 1 bis 5 von 5

Thema: Beschaltung von ATMs

  1. #1
    Benutzer Stammmitglied
    Registriert seit
    23.02.2007
    Beiträge
    59

    Beschaltung von ATMs

    Anzeige

    Hallo,

    ich beschäftige mich erst kurze Zeit mit der Materie und bin mir in Bezug auf Pullup-Widerstände etwas im Unklaren. Ich habe zwar gelesen, dass z.B. RESET einen internen Widerstand nach Vcc besitzt, weiß aber nicht, ob ich den irgendwie einschalten muss. Auch unbenutzte PORTS - sollen die an Masse gelegt, offen oder mit einem Widerstand an Vcc gelegt werden.

    Vielen Dank, LotharK

  2. #2
    Erfahrener Benutzer Robotik Einstein Avatar von Vitis
    Registriert seit
    06.01.2005
    Ort
    Südpfalz
    Alter
    43
    Beiträge
    2.240
    normalerweise, ich geh mal vom Atmel aus wird der
    Reset extern mit Widerstand (irgendwas zwischen 4 und 10 KR noch
    +Ub gezogen, da brauchste softwaremäßig nix zu regeln, ist reine
    Hardwaresache. Der genaue Widerstandswert ist nebensächlich.
    Ob 's 8K 7K 10K oder 12K sind ist ziemlich wurst.
    Die ungenutzten ports soll man wenn man der Literatur
    glaubt auf GND legen wegen EMV oder dergleichen.
    Wichtig, dann bei der Programmierung interne Pullups auf
    alle fälle softwaremäßig ausgeschaltet lassen und Port auf Input schalten.
    Ich hab aber auch schon größere Projekte gemacht wo ich die
    ungenutzten einfach offen gelassen, bzw. auf ne Stiftleiste geführt hab,
    man weiß ja nie was einem noch so einfällt, und hatte auch keine Probleme
    hardwareseitig.
    Vor den Erfolg haben die Götter den Schweiß gesetzt

  3. #3
    Benutzer Stammmitglied
    Registriert seit
    23.02.2007
    Beiträge
    59
    Danke, ist aber beim Reset nicht auch schon ein Widerstand intern vorhanden?

  4. #4
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    29.12.2005
    Ort
    Nähe Mainz
    Alter
    26
    Beiträge
    3.467
    Weiß ich jetzt nicht, aber es wird noch einer benötigt. Ohne den externen geht es nicht.

    jon
    Nice to be back after two years
    www.roboterfreak.de

  5. #5
    Benutzer Stammmitglied
    Registriert seit
    23.02.2007
    Beiträge
    59
    Danke, ich löte halt einen mehr ein - auch nicht das Problem.

    MfG LotharK

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •