-
        

Ergebnis 1 bis 4 von 4

Thema: L297-298 -an ParPort

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    03.02.2007
    Ort
    Berlin
    Beiträge
    5

    L297-298 -an ParPort

    Anzeige

    Hallo,
    ich habe mir eine Schrittmotorsteuerung mit L297/L298 zusammengebaut.
    Nun würde ich diese Schaltung gern über den Parallelport betreiben.
    Ich habe Clock, CW/CCW, Half/Full und Enable an die Anschlüsse D0-D3 des Ports gelegt, sowie GND auf 19.
    Meine Frage: ist dies ausreichend, oder muß ich sonst noch irgend etwas besonderes beachten?
    (Hab ja keine Lust mir meinen PC zu zerstören.)

    Noch eine Frage: Was hat es mit dem Control-Ausgang des L297 auf sich? ..hab ihn an GND gelegt.

    ..wäre nett wenn mir jemand von euch helfen würde.

    ron

  2. #2
    Erfahrener Benutzer Robotik Visionär Avatar von Hubert.G
    Registriert seit
    14.10.2006
    Ort
    Pasching OÖ
    Beiträge
    6.186
    Mit einem L297 habe ich noch nicht gearbeitet und kann dir daher nichts zum Control-Eingang sagen.
    Wenn du dein Parallelport schützen willst solltest du einen Bustreiber dazwischen schalten 74HC244 oder 245. Über diese kannst du 8 Leitungen schalten und schützt damit deinen PC.

    Hubert

  3. #3
    Neuer Benutzer Öfters hier
    Registriert seit
    03.02.2007
    Ort
    Berlin
    Beiträge
    5
    Hallo Hubert,
    ..habe erst einmal eine Optokopplerschaltung dazwischengehauen und noch etwas an den Werten gespielt. läuftsoweit ganz prima (mit C programmierte Steuerung).

    ...aber das mit dem M54HCT244 ist eine gute Idee.
    Eine Frage noch: merke gerade das der Motor sehr warm wird ...
    (habe Enable auf High)
    Wäre es vielleicht angebracht Vref (also Haltestrom) ebenfalls von der Software steuern zu lassen? Ich habe nämlich Angst das, wenn ich den Strom von vornherein gering einstelle, der Motor sich dann durch das Getriebe bei start-stop "verdreht".

    ron

  4. #4
    Neuer Benutzer Öfters hier
    Registriert seit
    03.02.2007
    Ort
    Berlin
    Beiträge
    5
    ..ich muß doch nochmal etwas zur Dimensionierung fragen:
    habe SMotor 0,6A 12V (Emis) und an der Schaltung 24V
    der Motor wird meines erachtens viel zu heiß (nach ca.10min on kann man ihn beinahe nicht mehr anfassen)
    Derzeit: Sense-widerstände 2x0,51 Ohm (8W) und am Trimmer 0,43V(VRef) eingestellt.
    Oder bin ich da irgendwie so völlig daneben mit meiner Berechnung...?
    Bitte helft mir!

    Gruss
    ron

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •