-
        

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 18

Thema: USB-RS232-Adapter killte den IR-Receiver?

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    11.02.2007
    Beiträge
    6

    USB-RS232-Adapter killte den IR-Receiver?

    Anzeige

    Hi Leute

    Ich wollte den Asuro an mein Laptop anschließen und da er keinen COM-Anschluss hat habe ich es mit einem USB-RS232-Adapter versucht. Der Test mit dem weißem Blatt hat nicht geklappt.

    Soweit nicht so schlimm. Ich habe jetzt hier im Forum nachgelesen, dass es nicht allzu ungewöhnlich ist und das es dafür viele Gründe geben kann (zu geringe Spannung, zu langes Kabel etc.).

    Jetzt aber funktioniert der Adapter gar nicht mehr. Davor hatte er an einem "echtem" COM-Port funktioniert (also der Weißblatt-Test). Ich habe es an 2 verschiedenen PCs ausprobiert aber Receiver empfängt einfach keine Zeichen mehr.

    Die gemessen Spannungen entsprechen etwa denen in diesem Thread.
    Ich habe auch ein paar Lötstellen nachgelötet aber keine Veränderung. Manchmal erscheinen ein paar Zeichen im Hyperterminal wenn man am Potentiometer dreht aber mehr passiert nicht.

    Kann sein, dass der Receiver jetzt einfach hin ist? Liegt es jetzt am Adapter oder an etwas anderem?

  2. #2
    Moderator Robotik Einstein Avatar von damaltor
    Registriert seit
    28.09.2006
    Ort
    Jena
    Alter
    31
    Beiträge
    3.913
    den adaptern fehlen einige steuerleitungen.

    ausserdem benötigt der rs232-transceiver etwa 12V an allen leitungen, aber ein usb-anschluss gibt nur 5V, was vielen geräten reicht, dem transceiver aber nicht. trotzdem kann ich mir nicht vorstellen, dass er dadurch zerstört wurde.
    kleinschreibung ist cool!

  3. #3
    Neuer Benutzer Öfters hier
    Registriert seit
    04.02.2007
    Ort
    Ingolstadt
    Alter
    40
    Beiträge
    5
    Hallo,

    ich hatte mit dem RS232-Adapter auch einige Probleme zu Beginn (an einem richtigen COM-Port). Das Problem bei mir war, dass der Adapter zum Einen Steuerleitungen mit +12V braucht zur Energieversorgung, zum Anderen aber auch, um die nötigen Pegel an der TX-Leitung (von Adapter zu PC) zu erzeugen.

    Von dem IR-Empfänger, der einen Ausgang von 0v bzw 5V erzeugt wird an der SUB-D Buchse ein Signal von ca 0V und 11,8V erzeugt. Dazu MUSS der Pin 7 der Buchse von der PC-Seite auf 12V liegen, um dann über den R2 den Pegel auf der TX-Leitung auf den High-Level zu ziehen.
    Sobald nun der Transistor Q1 vom dem IR-Empfänger angesteuert wird, zieht der Transistor den Pegel auf der TX-Leitung auf 0V herunter.
    Somit ergibt sich ein Pulssignal mit einer Amplitude von ca. 11,8V am TX-Ausgang an der Buchse.
    Ist nun der Pin 7 (RTS) ncht auf +12V, dann stellt sich auf der TX-Leitung nur ein Pegel von 0-5V ein, was zu wenig ist um ein Signal zu erkennen.

    Also zusammenfassend: Pin7 am SubD MUSS auf 12V liegen, der Pin 4 (DTR) sollte auch auf 12V liegen, damit die Spannungsversorgung der Schaltung stabiler ist.

    Ein USB2Serial Konverter bedient üblicherweise nicht diese beiden Steuerleitungen, so dass zum Einen die Schaltung nicht mit genügen SPannung versorgt wird und zum Anderen der Pegel auf der TX-Leitung zu gering ist.

    Hoffe, die kurze Beschreibung hilft ein wenig zu verstehen, was da nicht geht und woran es liegen könnte.

    Schöne Grüße,
    D e n i s

  4. #4
    Neuer Benutzer Öfters hier
    Registriert seit
    11.02.2007
    Beiträge
    6
    Danke für die Hintergrundinfos Leute. Schon komisch, dass der Receiver Spannungen braucht, die nicht jeder COM-Port liefern kann.

    Kann man den Receiver auch durch statische Aufladung kaputt machen? Wenn ja wie kann man es sehen? Ich würde gern wissen warum der Receiver kaputt ist, weil es ein Schulprojekt werden soll.

  5. #5
    Neuer Benutzer Öfters hier
    Registriert seit
    04.02.2007
    Ort
    Ingolstadt
    Alter
    40
    Beiträge
    5
    Hallo,

    diese Spannungen liefert jeder echte COM-Port! Allerdings unterstützen dei USB-to-Serial Umsetzer nicht die ganzen Steuerleitungen. Diese werden dann nicht bedient und somit fehlt dem IR-Receiver/Transmitter eben die Versorgungsspannung.

    Prinzipiell kann durch statische Aufladung sowohl der NE555 als auch der SFH5110 zerstört werden, womit dann der Sender und/oder der Empfängerteil betroffen wäre.

    Hast du die Einstellung des Trimmers mal überprüft? Ich kann meinen Adapter auch per Poti so einstellen, dass der Weißblatt-Test nicht mehr funktioniert.

    Zur Überprüfung, ob etwas gesendet wird, kann man auch mit einer Digicam die Sende-Diode beobachten. Dann sollte man ein leichtes bläuliches Schimmern feststellen, das zu sehen ist, wenn etwas gesendet wird.

    Ansonsten warst du in dem von dir angegebenem Thread schon richtig mit den einzelnen Spannungen, die an verschiedenen Stellen der Schaltung anliegen müssen. In dem Thread sind auch Tests beschrieben, wie man den SFH5110 überprüfen kann.

    Ansonsten, hast du ein Oszilloskop zur Verfügung? Dann könnte ich dir auch noch einige Signale beschreiben, die du nachmessen ud überprüfen kannst.

    Schöne Grüße,
    D e n i s
    Keep on coding!
    01000100 01100101 01101110 01101001 01110011

  6. #6
    Moderator Robotik Einstein Avatar von damaltor
    Registriert seit
    28.09.2006
    Ort
    Jena
    Alter
    31
    Beiträge
    3.913
    hmm also wenns durch satische aufldung ist, dann könnte es nur sein dass der chip defekt ist, da wirst du nicht viel sehen können.

    früher (damals... die alten zeiten...) waren alle comports etwa gleich, lieferten knappe 12V und funktionierten. modernere geräte brauchten die 12V nicht unbedingt, und ein comport der weniger strom liefert, verbraucht auch weniger. spart natürlich strom, vor allem an laptops und an den netzteilen. da jedoch der transceiver keine eigene stromversorgung hat, ist er auf die 12V angewiesen.
    hab mal gelesen, dass das flashen mit dem flash-gerät von LEGO mindstorms gehen soll, dieser hat eine eigene abtterie zur spannungsversorgung.
    kleinschreibung ist cool!

  7. #7
    Neuer Benutzer Öfters hier
    Registriert seit
    11.02.2007
    Beiträge
    6
    Den Trimmer habe ich mal überprüft. Das Drehen brachte aber nichts. Mit "sehen" meinte ich einen Test durchführen. Alle Tests aus dem oben angegeben Thread waren erfolgreich (was mich auch etwas stutzig macht).

    Hast du vielleicht einen Link zu der Benutzung des Lego-Flash-Gerätes? Ich habe nur eine kurze Erwähnung hier im Forum gefunden.

    Den Kamera-Test mache ich noch.

  8. #8
    Moderator Robotik Einstein Avatar von damaltor
    Registriert seit
    28.09.2006
    Ort
    Jena
    Alter
    31
    Beiträge
    3.913
    hmm... ich selbst habe es nicht probiert. schliesse den flasher mal an, und dann wähle ihn im flash-tool aus. oder benutze die lego-flash-software. leider weiss ich auch nix genaues.

    um zu sehen ob der transceiver sendet, öffne hyperterminal, drücke ein paar zeichen und schau durch ene digitalkamera oder handy-kamera auf die leuchtdiode. sie müsste grünlich leuchten, das sieht man nur auf dem bild der kamera.
    kleinschreibung ist cool!

  9. #9
    Neuer Benutzer Öfters hier
    Registriert seit
    11.02.2007
    Beiträge
    6
    Die Diode des Receivers leuchtet (ob's grünlich ist, weiß ich nicht, hab so meine Schwierigkeiten mit den Farben).

    Die Sache mit dem Lego-Flasher hat sich erledigt, der Kumpel von dem ich das Ding ausleihen wollte hat ein Funkmodell.

    Ich glaube ich gebe das Ganze langsam auf und hole mir einen USB-Receiver.

  10. #10
    Moderator Robotik Einstein Avatar von damaltor
    Registriert seit
    28.09.2006
    Ort
    Jena
    Alter
    31
    Beiträge
    3.913
    hmm, das ist natürlich blöd. ich selbst nutze auch den usb-transceiver, habe ihn mir aber nur gekauft weil ich nicht gemerkt habe dass der empfänger-IC des asuro defekt war.
    empfängt der transceiver noch daten? also zB während des selbsttests? oder wenn du hyperterminal an hast, dann kannst du auch mit einer normalen infrarot-fernbedienung zeichen an ihn senden, dann sollten einige komische zeichen ankommen.
    kleinschreibung ist cool!

Seite 1 von 2 12 LetzteLetzte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •