-         

Ergebnis 1 bis 4 von 4

Thema: Problem beim Portieren eines Projektes

  1. #1
    Erfahrener Benutzer Robotik Einstein Avatar von Vitis
    Registriert seit
    06.01.2005
    Ort
    Südpfalz
    Alter
    43
    Beiträge
    2.240

    Problem beim Portieren eines Projektes

    Anzeige

    Hi Forum,

    ich bin gerade am Übertragen eines Bascom Codes nach C.
    Grund dafür ist u.A. mal an nem richtigen Projekt mit identischem
    Programmablauf die Codegröße zu vergleichen und die
    Ausführungsgeschwindigkeit mal zu vergleichen.
    Das Projekt besteht aus ner Kamera
    C-328 an UART,
    EIN EDO-RAM-Rigel SIMM30 parallel,
    Ein GLCD von Optrex an SPI.

    Beim umcoden hab ich verschiedene Befehle von Bascom
    in C nachgebildet ... daher sieht der Code für die eingefleischten
    C Programmierer vermutlich etwas wild aus, wollt aber einfach
    ne schöne Gegenüberstellung haben.

    Mein Problem ist nun, wenn ich im AVR-Studio die Simulation
    laufen lassen will schmiert mir das Studio 4 ab.
    Seltsamerweise trat der Fehler erst auf als ich an die Portierung
    des URXC-Interrupts ging.

    Hat jemand nen heißen Tipp für mich?
    Angehängte Dateien Angehängte Dateien
    Vor den Erfolg haben die Götter den Schweiß gesetzt

  2. #2
    Erfahrener Benutzer Robotik Einstein Avatar von Vitis
    Registriert seit
    06.01.2005
    Ort
    Südpfalz
    Alter
    43
    Beiträge
    2.240
    Hab nochmal am Code gefeilt,
    aber das Studio bringt nochimmer im Windoofs
    "Runtime Error"
    Angehängte Dateien Angehängte Dateien
    Vor den Erfolg haben die Götter den Schweiß gesetzt

  3. #3
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    08.05.2005
    Ort
    Issum
    Alter
    46
    Beiträge
    2.236
    Hallo,

    Ich hab mir Deine 'Portierung' kurz angeschaut,

    Geht es sich um den Interrupt?

    Du schreibst
    ISR (SIG_UART_RECV)
    das ist aber Falsch, versuch mal mit
    Code:
    ISR (USART_RXC_vect)
    Am sonsten, gab es da auch mal Probleme mit AVR Studio ohne ServicePacks

    Gruß Sebastian
    Software is like s e x: its better when its free.
    Linus Torvald

  4. #4
    Erfahrener Benutzer Robotik Einstein Avatar von SprinterSB
    Registriert seit
    09.06.2005
    Ort
    An der Saar
    Beiträge
    2.801
    Ohne mir das zip angeguckt zu haben... Scheint ein Problem von AStudio zu sein. Hast du schon mal bei Atmel Support angefragt deshalb? Der ist ganz gut und Post landet nicht in der Tonne sondern wird sich wirklich gekümmert.
    Disclaimer: none. Sue me.

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •