-
        
+ Antworten
Ergebnis 1 bis 4 von 4

Thema: Kommunikationproblem zwischen CC2 und CC1 Hilfe!!

  1. #1
    Maro
    Gast

    Kommunikationproblem zwischen CC2 und CC1 Hilfe!!

    Hallo Leute ,
    bin ein Anfänger, hab mir die Erweiterungsplatine und den CC2 für mein Robby RP5 gekauft. Ich habe den Treiber ( GATEWAY.BAS)auf CC1 geladen und die Platine mit dem CC2 auf meinen robby montiert. Alle Module die mitgeliefert sind haben funktioniert ( lcd, melody.....) ausser der Modul ccpr5.c2 ( wo alle Fahrfonktionen sind) . Ich hab gelesen bei der Dokumentation in ccpr5.c2 dass ich den ccpr5.hex laden soll, das habe ich auch gemacht. Aber trotzdem laufen alle Fonktionen des Moduls ccpr5.c2 immer noch nicht.

    BITTE UM HILFE!!!

  2. #2
    Erfahrener Benutzer Robotik Einstein Avatar von Dirk
    Registriert seit
    30.04.2004
    Ort
    NRW
    Beiträge
    3.788

    CC2 - CC1

    Hallo Maro,

    das Modul ccrp5.c2 ist bei jedem CC2-Programm beteiligt, das über Gateway.bas mit der CC1 kommuniziert. Es sind also nicht nur die Fahrfunktionen, die über dieses Modul laufen.
    Was funktioniert bei Dir nicht? Welche der DEMOS1 .. 3 klappen bei Dir nicht?

    Gruß Dirk

  3. #3
    Maro
    Gast

    Re: CC2 - CC1

    Hallo Dirk,
    Da alle Demos was mit dem Modul ccrp5.c2 zu tun haben , keiner von diesen Demos funktioniert. Aber was ich mit andere Module gemient habe ,ist dass ich selber ein kleines Program geschrieben habe in dem nur Funktionen von dem Modul melody und lcd benutzt habe , die haben funktioniert ( weil ich glaube diese beide Module sind nur für CC2 und die haben nichts mit CC1 zu tun oder ??). also ich glaube das problem liegt bei der Verbindung zwischen CC1 und CC2, soll ich was anderes als GATEWAY lade ??? oder wo liegt das Problem.??
    Danke

  4. #4
    Erfahrener Benutzer Robotik Einstein Avatar von Dirk
    Registriert seit
    30.04.2004
    Ort
    NRW
    Beiträge
    3.788

    Verbindung CC1 -> CC2

    Hallo Maro,

    was Du immer tun mußt:

    1. Die CC2 noch NICHT montieren: "Gateway.bas" in die CC1 laden.
    2. War das erfolgreich, dann Robby ausschalten, CC2 aufstecken und Robby wieder einschalten.
    3. Ab jetzt NIE mehr den seriellen Stecker auf dem Robby und die Reset- und Start-Taste auf dem Robby benutzen!!!!
    4. Serielles Kabel auf den Stecker der Basiserweiterung umstecken und dort lassen.
    5. Die Grundeinrichtung der CC2 machen: Betriebssystem laden und den Treiber CCRP5DRIVER.HEX ins Segment 3 laden.
    6. Wenn das alles fehlerfrei geklappt hat, muss danach die CCRP5_DEMO1 funktionieren, einschließlich aller Teile, die man nacheinander auskommentieren muss.
    7. Die anderen beiden DEMOS (2..3) funktionieren u.U. nicht, weil das Modul "asmcall.c2" nicht eingebunden ist, das mußt Du erst noch nachholen. Dann funktionieren die auch.

    Gruß Dirk

+ Antworten

Benutzer, die dieses Thema gelesen haben: 0

Derzeit gibt es keine Benutzer zum Anzeigen.

Berechtigungen

  • Neue Themen erstellen: Ja
  • Themen beantworten: Ja
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •