-
        

Ergebnis 1 bis 5 von 5

Thema: Probleme mit M128

  1. #1
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    24.01.2004
    Ort
    z.Zt. Istanbul
    Alter
    62
    Beiträge
    108

    Probleme mit M128

    Anzeige

    SMARTPHONES & TABLETS-bis zu 77% RABATT-Kostenlose Lieferung-Aktuell | Cool | Unentbehrlich
    Vorweg: Ich bin derzeit am Umsteigen auf den M128. Und dabei wohl in die bekannte Fuse-Falle gelaufen (CKSEL - man sollte doch das Manual lesen: gesetzte Fuse bedeutet disabled ).
    Nachdem der Prozessor sich totgestellt hat habe ich ihn mit einem Funktionsgenerator von außen angestoßen und wieder zum laufen gebracht - die CKSEL dann in Pony schön mit Tick versehen, dazu noch SUT1. Nur kann ich jetzt überhaupt nicht mehr den Speicher flashen und ob das lesen geht wissen die Götter - er meldet immer FF. Egal ob mit Prozessor oder ohne.
    Prozessor kaputt oder was habe ich falsch gemacht?
    Gesetzte Fuse: CKSEL0,1,2,3, SUT1 und OCDEN.
    Pony meldet Device missing or unknown device. (Device ist eingestellt).
    Der Programmer funktioniert bei meinem 32-Board.

  2. #2
    Erfahrener Benutzer Robotik Einstein Avatar von SprinterSB
    Registriert seit
    09.06.2005
    Ort
    An der Saar
    Beiträge
    2.801
    Um verwirrung zu vermeiden (gesetzt, ist das 0 oder 1?), sollte man die Bezeichnung von Atmel verwenden (programmed / unprogrammed).

    Unprogrammed entspricht das Quarz/Ker, unprogrammed extern F_CPU. Mit deinem F-Generator sollte er also zu proggen sein (f=1MHz oder so) falls es mit Quarz schweigt, f-Gen am besten über 1kΩ an den XTAL1 und nicht direkt.
    Disclaimer: none. Sue me.

  3. #3
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    24.01.2004
    Ort
    z.Zt. Istanbul
    Alter
    62
    Beiträge
    108
    Hm
    die Atmel Bezeichungen halte ich eher für verwirrend. Ich kann ein bit auf Null oder eins programmieren...
    Aber meinetwegen: die genannten fusebits programmed. Die Aktion mit dem F-Gen ist schon passé; den Widerstand habe ich mir erspart, dafür aber das Signal mittels Oskar überwacht. Der Atmel ist nun nachweislich auf Quarz/Ker.
    Wenn ich nun versuche ein Programm mittels Pony zu überspielen meldet er die o.g. Fehlermeldung.
    Ist der Atmel noch zu retten oder für die Rundablage? Wenn zu retten: wie? Und welche Fuses sind dann zu setzen (=programmed)?

  4. #4
    Erfahrener Benutzer Robotik Einstein Avatar von SprinterSB
    Registriert seit
    09.06.2005
    Ort
    An der Saar
    Beiträge
    2.801
    Wenn er *nachweislich* auf Quarz steht und sich mit Quarz nicht proggen lässt, ist er nachweislich im Eimer. Allerdinge bedeutet programmed der CKSELn nachweislich (pp. 37), daß er dann auf external clock steht...
    Disclaimer: none. Sue me.

  5. #5
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    24.01.2004
    Ort
    z.Zt. Istanbul
    Alter
    62
    Beiträge
    108
    Zitat Zitat von SprinterSB
    Wenn er *nachweislich* auf Quarz steht und sich mit Quarz nicht proggen lässt, ist er nachweislich im Eimer. Allerdinge bedeutet programmed der CKSELn nachweislich (pp. 37), daß er dann auf external clock steht...
    Touché!
    Nachweislich heißt dass er sich noch ein mal ohne externe "Hilfe" proggen ließ - und dann nie mehr.
    Und, wie gesagt, die Atmel Bezeichnungen verwirren mich eher.
    Sagen wir doch ganz einfach: die CKSEL wurden auf logisch eins gesetzt...

    Aber meine Frage ist damit beantwortet. Danke dafür!

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •